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How to Use This Book

Who This Book Is For
This book is for the reader who has never used this 
particular technology or software application. It is also 
for readers who want to expand their knowledge.

The Conventions in This Book
1 Steps
This book uses a step-by-step format to guide you 
easily through each task. Numbered steps are actions 
you must do; bulleted steps clarify a point, step, or 
optional feature; and indented steps give you the 
result.

2 Notes
Notes give additional information — special conditions 
that may occur during an operation, a situation that 
you want to avoid, or a cross reference to a related 
area of the book.

3 Icons and Buttons
Icons and buttons show you exactly what you need to 
click to perform a step.

4 Simplify It
Simplify It sections offer additional information, 
including warnings and shortcuts.

5 Bold
Bold type shows command names, options, and text 
or numbers you must type.

6 Italics
Italic type introduces and defines a new term.

Working with Excel

CHAPTER

1

11

22
33

44

66

55

22

11

55

44

33

If I find the gallery preview feature distracting, can I turn it off?
Yes. The Live Preview feature is often handy because it shows you exactly what 
will happen when you click a gallery option. However, as you move the mouse  
through the gallery, the previews can be distracting. To turn off Live Preview, 
click the File tab, click Options, click the General tab, click Enable Live Preview 
(  changes to ), and then click OK.

Work with a Drop-Down Gallery

1 If necessary, click the object 
with which you want to apply 
an option from the gallery.

2 Click the tab that contains the 
gallery you want to use.

3 Click the gallery’s drop-down 
arrow ( ).

 Excel displays a list of the 
gallery’s contents.

4 If the gallery contains one or 
more subgalleries, click the 
subgallery you want to use.

 Excel displays the subgallery’s 
contents.

• If a gallery has commands that 
you can run, those commands 
appear at the bottom of the 
gallery menu.

5 Move the mouse  over a 
gallery option to see a preview 
of the effect.

• Excel displays a preview of the 
effect.

6 Click the gallery option you 
want to use.

 Excel applies the gallery 
option to the selected object.

 Excel displays a list of the 
gallery’s contents.

4 Move the mouse  over a 
gallery option to see a preview 
of the effect.

• Excel displays a preview of the 
effect.

5 Click the gallery option you 
want to use.

 Excel applies the gallery 
options to the selected object.

Work with a Gallery List

1 If necessary, click the object 
with which you want to apply 
an option from the gallery.

2 Click the tab that contains the 
gallery you want to use.

3 Click the gallery’s More 
arrow ( ).

• You can also scroll through 
the gallery by clicking the 
Down ( ) and Up ( ) arrows.

Work with Excel’s Galleries

In Excel’s Ribbon, a gallery is a collection of 
preset options that you can apply to the 
selected object in the worksheet. To get the 
most out of galleries, you need to know how 
they work.

Although some galleries are available all the 
time, in most cases you must select an object — 
such as a range of cells or a clip art image — 
before you work with a gallery.

Work with 
Excel’s Galleries

1

6

4

5

3
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ChapterChapter 111
Working 
with Excel
You use Microsoft Excel to create 
spreadsheets, which are 
documents that enable you to 
manipulate numbers and 
formulas to quickly create 
powerful mathematical, financial, 
and statistical models. In this 
chapter you learn about Excel 
and you find out the kinds of 
tasks you can perform with Excel. 
You also learn how to start the 
program, and you take a tour of 
the program’s major features. 
This chapter also shows you how 
to work with Excel Ribbon and 
the Ribbon’s galleries, how to 
customize the Ribbon and the 
Quick Access Toolbar, how to 
work with smart tags, and how 
to customize the view and other 
aspects of the program.
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Add Data
You can insert text, numbers, and other characters into any cell in 
the spreadsheet. Click the cell that you want to work with and then 
type your data in the Formula bar. This is the large text box above 
the column letters. Your typing appears in the cell that you selected. 
When you are done, press Enter. To edit existing cell data, click the 
cell and then edit the text in the Formula bar.

Getting to 
Know Excel
Working with Excel involves two basic tasks: 
building a spreadsheet and then manipulating 
the data on the spreadsheet. Building a 
spreadsheet involves adding data, formulas, and 
functions. Manipulating data involves calculating 

totals, working with series, creating tables for 
your data, and visualizing data in charts.
This section just gives you an overview of these 
tasks. You learn about each task in greater 
detail as you work through the book.

Build a Spreadsheet

Add a Formula
A formula is a collection of numbers, cell addresses, and 
mathematical operators that performs a calculation. In 
Excel, you enter a formula in a cell by typing an equal 
sign (=) and then the formula text. For example, the 
formula =B1-B2 subtracts the value in cell B2 from the 
value in cell B1.

Add a Function
A function is a predefined formula that performs a specific task. 
For example, the AVERAGE function calculates the average of 
a list of numbers, and the PMT function calculates a loan or 
mortgage payment. You can use functions on their own, 
preceded by =, or as part of a larger formula. Click Insert 
Function ( ) to see a list of the available functions.
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Calculate Totals Quickly
If you just need a quick sum of a list of 
numbers, click a cell below the numbers and 
then click the Sum button ( ), which is 
available in the Home tab of Excel’s Ribbon. 
In Excel, you can also select the cells that you 
want to sum, and their total appears in the 
status bar.

Fill a Series
Excel enables you to save time by completing a 
series of values automatically. For example, if 
you need to enter the numbers 1 to 100 in 
consecutive cells, you can enter just the first few 
numbers, select the cells, and then click and 
drag the lower right corner to fill in the rest of 
the numbers. Most programs also fill in dates, 
as well as the names for weekdays and months.

Manage Tables
The row-and-column format of a spreadsheet 
makes the program suitable for simple 
databases called tables. Each column becomes 
a field in the table, and each row is a record. 
You can sort the records, filter the records to 
show only certain values, and add subtotals.

Add a Chart
A chart is a graphic representation of spreadsheet 
data. As the data in the spreadsheet changes, the 
chart also changes to reflect the new numbers. 
Excel offers a wide variety of charts, including 
bar charts, line charts, and pie charts.
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 The App Programs menu 
appears.

3 Click Microsoft Office.

1 Click Start.

 The Start menu appears.

2 Click All Programs.

Start Excel

Before you can perform tasks such as adding 
data and building formulas, you must first start 
Excel. This brings the Excel window onto the 
Windows desktop, and you can then begin 
using the program. This task and the rest of 
the book assume that you have already 
installed Excel 2010 on your computer.

When you have finished your work with Excel, 
you should shut down the program. This 
reduces clutter on the desktop and in the 
taskbar, and it also conserves memory and 
other system resources.

Start 
Excel
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Are there faster methods I can use to start Excel?
Yes. After you have used Excel a few times, it should appear on the main Start 
menu in the list of your most-used programs. If so, you can click that icon to start 
the program. You can also force the Excel icon onto the Start menu by following 
Steps 1 to 3, right-clicking the Microsoft Excel 2010 icon, and then clicking Pin 
to Start Menu. If you are using Windows 7, you can also click Pin to Taskbar 
to add the Excel icon to the taskbar.

 The Microsoft Excel window 
appears on the desktop.

Note: When you are finished 
with Excel, close the program by 
clicking the File tab and then 
clicking Exit.

 The Microsoft Office menu 
appears.

4 Click Microsoft Excel 2010.
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To get up to speed quickly with Excel, it helps 
to understand the various elements of the 
Excel window. These include standard window 

elements such as the title bar and status bar, 
as well as Office-specific elements such as the 
Ribbon and the File tab.

Tour the 
Excel Window

Title Bar
The title bar displays the name of the current 
workbook.

Quick Access Toolbar
This area gives you one-click access to a few often-
used features. To learn how to customize this 
toolbar, see “Customize the Quick Access Toolbar.”

Workbook Window 
Controls
You use these controls to 
minimize, maximize, restore, 
and close the current workbook 
window.

File Tab
Click this tab to access file-related 
commands, such as Save and 
Open.

Worksheet
This area displays the current 
worksheet, and it is where you 
will do most of your Excel work.

Status Bar
This area displays messages about 
Excel’s current status, the results 
of certain operations, and other 
information.

Ribbon
This area gives you 
access to all of Excel’s 
commands, options, 
and features. To learn 
how to use this 
element, see “Work 
with Excel’s Ribbon.”

Excel Window 
Controls
You use these controls 
to minimize, maximize, 
restore, and close 
Excel’s application 
window.
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 Excel displays the controls in 
the tab.

• Each tab is organized into 
groups of related controls, and 
the group names appear here.

• In many groups you can click 
the dialog box launcher button 
( ) to display a dialog box 
that contains group settings.

2 Click the control for the feature.

• If the control displays a list of 
options, click the option you 
want.

 Excel runs the command or 
sets the option.

Work with 
Excel’s Ribbon
You use Excel’s Ribbon element to access all of 
the program’s features and commands. The 
Ribbon is the horizontal strip that runs across 
the top of the Excel window, just below the 
title bar. The Ribbon is organized into various 

tabs, such as File, Home, and Insert, and each 
tab contains related controls, which usually 
include buttons, lists, and check boxes. There 
is no menu bar in Excel, so you do not use 
pull-down menus to access commands.

Work with Excel’s Ribbon

1 Click the tab that contains 
the Excel feature you want to 
work with.

22

11
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 Excel displays a list of the 
gallery’s contents.

4 Move the mouse  over a 
gallery option to see a preview 
of the effect.

• Excel displays a preview of the 
effect.

5 Click the gallery option you 
want to use.

 Excel applies the gallery 
options to the selected object.

Work with a Gallery List

1 If necessary, click the object 
with which you want to apply 
an option from the gallery.

2 Click the tab that contains the 
gallery you want to use.

3 Click the gallery’s More 
arrow ( ).

• You can also scroll through 
the gallery by clicking the 
Down ( ) and Up ( ) arrows.

Work with Excel’s Galleries

In Excel’s Ribbon, a gallery is a collection of 
preset options that you can apply to the 
selected object in the worksheet. To get the 
most out of galleries, you need to know how 
they work.

Although some galleries are available all the 
time, in most cases you must select an object — 
such as a range of cells or a clip art image — 
before you work with a gallery.

Work with 
Excel’s Galleries
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If I find the gallery preview feature distracting, can I turn it off?
Yes. The Live Preview feature is often handy because it shows you exactly what 
will happen when you click a gallery option. However, as you move the mouse  
through the gallery, the previews can be distracting. To turn off Live Preview, 
click the File tab, click Options, click the General tab, click Enable Live Preview 
(  changes to ), and then click OK.

Work with a Drop-Down Gallery

1 If necessary, click the object 
with which you want to apply 
an option from the gallery.

2 Click the tab that contains the 
gallery you want to use.

3 Click the gallery’s drop-down 
arrow ( ).

 Excel displays a list of the 
gallery’s contents.

4 If the gallery contains one or 
more subgalleries, click the 
subgallery you want to use.

 Excel displays the subgallery’s 
contents.

• If a gallery has commands that 
you can run, those commands 
appear at the bottom of the 
gallery menu.

5 Move the mouse  over a 
gallery option to see a preview 
of the effect.

• Excel displays a preview of the 
effect.

6 Click the gallery option you 
want to use.

 Excel applies the gallery 
option to the selected object.
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 The Excel Options dialog box 
appears.

• Excel automatically displays 
the Quick Access Toolbar tab.

3 Click the Choose commands 
from .

4 Click the command category 
you want to use.

1 Click the Customize Quick 
Access Toolbar button ( ).

• If you see the command you 
want, click it and skip the rest 
of the steps in this section.

2 Click More Commands.

Customize the Quick Access Toolbar

You can make Excel easier to use by customizing 
the Quick Access Toolbar to include the Excel 
commands you use most often. You run Quick 
Access Toolbar buttons with a single click, so 
adding your favorite commands saves time. By 
default, the Quick Access Toolbar contains three 
buttons: Save, Undo, and Redo, but you can 
add any of Excel’s hundreds of commands.

Since there is only so much room for the Quick 
Access Toolbar in Excel’s menu bar, consider 
moving the Quick Access Toolbar below the 
Ribbon to gain more space for your custom 
commands.

Customize the Quick 
Access Toolbar
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• Excel adds a button for the 
command to the Quick Access 
Toolbar.

5 Click the command you want 
to add.

6 Click Add.

• Excel adds the command.

• To remove a command, click it 
and then click Remove.

7 Click OK.

Can I get more room on the Quick 
Access Toolbar to show more buttons?
Yes, you can increase the space available 
to the Quick Access Toolbar by moving it 
below the Ribbon. This gives the toolbar 
the full width of the Excel window, so 
you can add many more buttons. Click 
the Customize Quick Access Toolbar 
button ( ) and then click Show Below 
the Ribbon.

Is there a faster way to add buttons 
to the Quick Access Toolbar?
Yes. If the command you want to add 
appears on the Ribbon, you can add a 
button for the command directly from the 
Ribbon. Click the Ribbon tab that contains 
the command, right-click the command, 
and then click Add to Quick Access 
Toolbar. Excel inserts a button for the 
command on the Quick Access Toolbar.
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Display the Customize Ribbon Tab

1 Right-click any part of the 
Ribbon.

2 Click Customize the Ribbon.

Add a New Tab or Group

 The Excel Options dialog box 
appears.

• Excel automatically displays 
the Customize Ribbon tab.

1 Click the tab you want to 
customize.

• You can also click New Tab to 
create a custom tab.

2 Click New Group.

• Excel adds the group.

3 Click Rename.

4 Type a name for the group.

5 Click OK.

Customize the Ribbon

You can improve your Excel productivity by 
customizing the Ribbon with extra commands 
that you use frequently. The default Ribbon 
contains eight tabs, and each of those tabs 
contains dozens of commands in the form of 
buttons, galleries, lists, and other controls. 
However, Excel has many other commands 

available, and you may wish to add one or 
more of these other commands if you use any 
of them frequently.
To add a new command to the Ribbon, you 
must first create a new tab or a new group 
within an existing tab, and then add the 
command to the new tab or group.

Customize 
the Ribbon
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Add a Command

1 Click the Choose commands 
from .

2 Click the command category 
you want to use.

3 Click the command you want 
to add.

4 Click the custom group or tab 
you want to use.

5 Click Add.

• Excel adds the command.

• To remove a custom 
command, click it and then 
click Remove.

6 Click OK.

• Excel adds the new group and 
command to the Ribbon.

Can I customize the tabs that appear only 
when I select an Excel object?
Yes. Excel calls these tool tabs, and you can 
add custom groups and commands to any 
tool tab. Right-click any part of the Ribbon 
and then click Customize the Ribbon to 
display the Excel Options dialog box with the 
Customize Ribbon tab displayed. Click the 
Customize the Ribbon  and then click 
Tool Tabs. Click the tab you want and then 
follow the steps in this section to customize it.

How do I restore the Ribbon to its default 
configuration?
Right-click any part of the Ribbon and then 
click Customize the Ribbon to display the 
Excel Options dialog box with the Customize 
Ribbon tab displayed. To restore a tab, click the 
tab, click Restore Defaults, and then click 
Restore only selected Ribbon tab. To remove 
all customizations, click Restore Defaults and 
then click Restore all Ribbon tabs and Quick 
Access Toolbar customizations.
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2 Click the smart tag.

• The smart tag displays a list of 
its options.

1 Perform an action that displays 
a smart tag, such as copying 
and pasting a cell as shown 
here.

• The smart tag appears.

Work with Smart Tags

You can make your Excel work faster and easier 
by taking advantage of smart tags. A smart tag 
is a special icon that appears when you perform 
certain Excel tasks, such as pasting data and 
using the AutoFill feature. Clicking the smart 
tag displays a list of options that enable you to 

control or modify the task you just performed. 
Some smart tags appear automatically in 
response to certain conditions. For example, if 
Excel detects an inconsistent formula, it displays 
a smart tag to let you know.

Work with 
Smart Tags
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• Excel applies the option to the 
task you performed in Step 1.

3 Click the option you want to 
apply.

Are there other types of smart tags I can use?
Yes, Excel offers a few other smart tag types. For 
example, a Date smart tag recognizes a worksheet 
date and offers options such as scheduling a meeting 
on that date. To turn on these extra smart tags, click 
File, click Options, click Proofing, click AutoCorrect 
Options, and then click the Smart Tags tab. Click the 
Label data with smart tags check box (  changes 
to ), and then click the check box beside each 
smart tag in the Recognizers list (  changes to ). 
Click OK.
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Switch to Page Break Preview

1 Click the View tab.

2 Click Page Break Preview.

• You can also click the Page 
Break Preview button ( ).

Switch to Page Layout View

1 Click the View tab.

2 Click Page Layout.

• You can also click the Page 
Layout button ( ).

• Excel switches to Page Layout 
view.

Change the View

You can adjust the Excel window to suit what 
you are currently working on by changing the 
view to match your current task. Excel offers 
three different views: Page Layout, which 
displays worksheets as they would appear if 

you printed them out; Page Break Preview, 
which displays the page breaks as blue lines, as 
described in the first Tip on the next page; and 
Normal, which is useful for building and editing 
worksheets.

Change 
the View
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Switch to Normal View

1 Click the View tab.

2 Click Normal.

• You can also click the Normal 
button ( ).

 Excel switches to Normal view.

• The Welcome to Page Break 
Preview dialog box appears.

• Excel switches to Page Break 
Preview.

3 Click OK.

What does Page Break Preview do?
In Excel, a page break is a position within a 
worksheet where a new page begins when you 
print the worksheet. When you switch to Page 
Break Preview, Excel displays the page breaks 
as blue lines. If a page break occurs in a bad 
position — for example, the page break includes 
the headings from a range, but not the cells below 
the headings — you can use your mouse  to click 
and drag the page breaks to new positions.

What does Full Screen view do?
Full Screen view is useful when you 
want to see the maximum amount of 
a worksheet on the screen. Full Screen 
view removes many of the Excel 
window features, including the File 
button, Ribbon, Quick Access Toolbar, 
Formula bar, and status bar. To return 
to the Normal view, press , or click 
the Restore Down button ( ).
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2 Click Options.

1 Click the File tab.

Configure Excel Options

You can customize Excel and set up the 
program to suit the way you work by 
configuring the Excel options. You use these 
options to set your Excel preferences in a 
number of program categories, including 
formulas, proofing, and saving.

To use these options, you must know how to 
display the Excel Options dialog box. These 
options are dialog box controls such as check 
boxes, option buttons, and lists that enable 
you to configure many aspects of Excel.

Configure 
Excel Options
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4 Use the controls on the right 
side of the dialog box to 
configure the options you 
want to change.

5 Click OK.

 Excel puts the new options into 
effect.

 The Excel Options dialog box 
appears.

3 Click a tab on the left side of 
the dialog box to choose the 
configuration category you 
want to work with.

• The controls that appear on 
the right side of the dialog box 
change according to the tab 
you select.

Are there faster methods I can use to open 
the Excel Options dialog box?
Yes. Some features of the Excel interface offer 
shortcut methods that get you to the Excel 
Options dialog box faster. For example, right-click 
the Ribbon and then click Customize Ribbon to 
open the Excel Options dialog box with the 
Customize Ribbon tab displayed. From the 
keyboard, you can open the Excel Options dialog 
box by pressing +  and then pressing .

How do I know what each option 
does?
Excel offers pop-up descriptions of 
some — but, unfortunately, not all — 
of the options. If you see a small i with 
a circle around it to the right of the 
option name, it means pop-up help is 
available for that option. Hover the 
mouse  over the option and Excel 
displays a pop-up description of the 
option after a second or two.
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ChapterChapter 2222
Entering and 
Editing Excel 
Data
Are you ready to start using 
Excel to build a spreadsheet? To 
create a spreadsheet in Excel, 
you must understand the layout 
of an Excel worksheet as well as 
the types of data that you can 
enter into a worksheet. You also 
must know how to enter data — 
including text, numbers, dates, 
times, and symbols — into the 
worksheet cells, and how to edit 
that data to fix typos, adjust 
information, and remove data 
you no longer need.
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In Excel, a spreadsheet file is called a 
workbook, and each workbook consists of one 
or more worksheets. These worksheets are 
where you do most  of your work in 

Excel — including entering your data and 
formulas — so you need to know the layout 
of a typical worksheet.

Learning the Layout 
of a Worksheet

24

Mouse 
Pointer
Use the Excel 
mouse  to 
select cells.

Cell 
Address
Each cell 
has its own 
address, which 
is determined 
by the letter 
and number 
of the 
intersecting 
column and 
row. For 
example, 
the cell at the 
intersection of 
column C and 
row 10 has 
the address 
C10.

Cell
A cell is a box in which you enter 
your spreadsheet data.

Row
A row is a horizontal line of cells. 
Each row has a unique number 
that identifies it. For example, the 
topmost row is 1, and the next 
row is 2.

Column
A column is a vertical line of cells. 
Each column has a unique letter 
that identifies it. For example, the 
leftmost column is A, and the next 
column is B.

Worksheet Tab
The worksheet tab displays the 
worksheet name. Most workbooks 
contain multiple worksheets, 
and you use the tabs to navigate 
between the worksheets.

Range
A range is a rectangular grouping of two or more cells. The range 
address is given by the address of the top left cell and the address 
of the bottom right cell. H12:K16 is an example of a range of cells, 
and it refers to all of the cells selected between column H, cell 12 
and column K, cell 16.
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To build a spreadsheet in Excel, it helps to 
understand the three main types of data that 

you can enter into a cell: text, numbers, and 
dates and times.

Understanding the Types 
of Data You Can Use

Numbers
Numbers are the most common type of Excel data. The numbers 
you enter into a cell can be dollar values, weights, interest rates, 
temperatures, or any other numerical quantity. In most cases you 
just type the number that you want to appear in the cell. However, 
you can also precede a number with a dollar sign ($) or other 
currency symbol to indicate a monetary value, or follow a number 
with a percent sign (%) to indicate a percentage value.

Text
Text entries can include any combination of letters, symbols, and 
numbers. You will mostly use text to describe the contents of your 
worksheets. This is very important because even a modest-sized 
spreadsheet can become a confusing jumble of numbers without 
some kind of text guidelines to keep things straight. Most text entries 
are usually labels such as Sales or Territory that make a worksheet 
easier to read. However, text entries can also be text/number 
combinations for items such as phone numbers and account codes.

Dates and Times
Date entries appear in spreadsheets that include dated data, such 
as invoices and sales. You can either type out the full date — 
such as August 23, 2010 — or use either the forward slash (/) or 
the hyphen (-) as a date separator — such as 8/23/2010 or 
8-23-2010. Note that the order you enter the date values depends 
on your regional settings. For example, in the United States the 
format is month/day/year. For time values, you use a colon (:) as a 
time separator, followed by either AM or PM — such as 9:15 AM.
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2 Start typing your text.

• Excel opens the cell for 
editing and displays the 
text as you type.

• Your typing also appears in 
the Formula bar.

Note: Rather than typing the 
text directly into the cell, you 
can also type the text into the 
Formula bar.

1 Click the cell in which you 
want to enter the text.

• Excel marks the current cell by 
surrounding it with a thick, 
black border.

Enter Text into a Cell

Your first step when building a spreadsheet 
is usually to enter the text data that defines 
the spreadsheet’s labels or headings. This is 
particularly important if other people will be 
reading or editing the spreadsheet, because the 
labels and headings help people make sense of 

the data and help them understand the 
purpose of the spreadsheet.
Most labels appear in the cell to the right or 
above where the data will appear, while most 
headings appear at the top of a column of data 
or to the left of a row of data.

Enter Text 
into a Cell
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When I press Enter, the selection 
moves to the next cell down. Can 
I make the selection move to the 
right instead?
Yes. When you have finished adding 
the data to the cell, press . This 
tells Excel to close the current cell for 
editing and move the selection to the 
next cell on the right. If you prefer to 
move left instead, press ; if you 
prefer to move up, press .

When I start typing text into a cell, 
why does Excel sometimes display 
the text from another cell?
This is part of an Excel feature called 
AutoComplete. If the letters you type 
at the start of a cell match the contents 
of another cell in the worksheet, Excel 
fills in the full text from the other cell 
under the assumption that you are 
repeating the text in the new cell. If 
you want to use the text, click  or 
press ; otherwise, just keep 
typing your text.

• Excel closes the cell for editing.

• If you pressed , Excel 
moves the selection to the cell 
below.

3 When your text entry is 
complete, press .

• If you do not want Excel to 
move the selection, click Enter 
( ) or press +  
instead.
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2 Start typing your number.

• Excel opens the cell for editing 
and displays the number as 
you type.

• Your typing also appears in 
the Formula bar.

Note: Rather than typing the 
number directly into the cell, you 
can also type the number into 
the Formula bar.

1 Click the cell in which you 
want to enter the number.

• Excel marks the current cell by 
surrounding it with a thick, 
black border.

Enter a Number into a Cell

Excel is all about numbers, so most of your 
worksheets will include numeric values. Some 
worksheets store only numeric values, but most 
use numbers as the basis for one or more 
calculations, such as monthly loan payments, 
statistical analysis, or budget totals.

To get the most out of Excel, you need to 
know how to enter numeric values, including 
percentages and currency values.

Enter a Number 
into a Cell
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Can I use symbols such as a comma, decimal 
point, or minus sign when I enter a numeric 
value?
Yes. If your numeric value is in the thousands, you can 
include the thousands separator (,) within the number. 
For example, if you enter 10000, Excel displays the 
value as 10000; however, if you enter 10,000, Excel 
displays the value as 10,000, which is easier to read. 
If your numeric value includes one or more decimals, 
you can include the decimal point (.) when you type 
the value. If your numeric value is negative, precede 
the value with a minus sign (–).

• Excel closes the cell for editing.

• To enter a percentage value, 
type the number followed by a 
percent sign (%).

• To enter a currency value, type 
the dollar sign ($) followed by 
the number.

3 When your number is 
complete, press .

• If you do not want Excel to 
move the selection, click Enter 
( ) or press +  
instead.

Is there a quick way to 
repeat a number rather 
than entering the entire 
number all over again?
Excel offers a few methods for 
doing this. The easiest method 
is to select the cell directly 
below the value you want to 
repeat and then press +’. 
Excel adds the value to the 
cell. For another method, see 
“Fill a Range with the Same 
Data” in Chapter 3.
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2 Type the date.

Note: The format you use 
depends on your location. In the 
United States, for example, you 
can use the month/day/year 
format — 8/23/2010. See the 
Tip on the next page.

3 When your date is complete, 
press .

• If you do not want Excel to 
move the selection, click Enter 
( ) or press +  
instead.

 Excel closes the cell for editing.

Enter a Date

1 Click the cell in which you 
want to enter the date.

• Excel marks the current cell by 
surrounding it with a thick, 
black border.

Enter a Date or Time into a Cell

Many Excel worksheets use dates either as part 
of the sheet data or for use in calculations, such 
as the number of days an invoice is overdue. 
Excel worksheets also often use times, such as 
recording when a transaction took place or 

calculating the total number of hours an 
employee has worked in a given period.
For these and similar uses, you need to know 
how to enter date and time values into a cell.

Enter a Date or 
Time into a Cell
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How can I tell which date and time formats my 
version of Excel accepts?
Follow these steps:

1 Click the Home tab.

2 Click the dialog box launcher button in the 
bottom right corner of the Number group.

3 Click the Number tab.

4 Click Date.

5 Click the Locale (location) drop-down arrow  and then click your location.

6 Examine the Type list to see the formats you can use to enter dates.

7 Click Time.

8 Examine the Type list to see the formats you can use to enter times.

9 Click Cancel.

Enter a Time

1 Click the cell in which you 
want to enter the time.

• Excel marks the current cell by 
surrounding it with a thick, 
black border.

2 Type the time.

Note: The general format 
for entering a time is 
hour:minute:second AM/PM; for 
example, 3:15:00 PM. See the 
following Tip.

3 When your time is complete, 
press .

• If you do not want Excel to 
move the selection, click Enter 
( ) or press +  instead.

 Excel closes the cell for editing.
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3 Click the Insert tab.

4 Click Symbol.

1 Click the cell in which you 
want the symbol to appear.

2 Type the text that you want 
to appear before the symbol, 
if any.

Insert a Symbol

You can make your Excel worksheets more 
readable and more useful by inserting special 
symbols that are not available via your 
keyboard’s standard keys. These special symbols 

include foreign characters such as ö and é, 
mathematical symbols such as ÷ and ∞, financial 
symbols such as ¢ and ¥, commercial symbols 
such as © and ®, and many more.

Insert a 
Symbol
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Are there keyboard shortcuts available for symbols I use frequently?
Yes, in many cases. In the Symbol dialog box, click  in the from list and select 
ASCII (decimal). Click the symbol you want to insert and then examine the 
number in the Character code text box. This number tells you that you can 
enter the symbol via the keyboard by holding down , pressing , and then 
typing the number. For example, you can enter the © symbol by pressing +

. Be sure to type all the numbers using your keyboard’s numeric 
keypad.

 The Symbol dialog box 
appears.

5 Click the Symbols tab.

6 Click the symbol you want to 
insert.

Note: Many other symbols are 
available in the Webdings and 
Wingdings fonts. To see these 
symbols, click the Font , and 
then click either Webdings or 
Wingdings.

7 Click Insert.

• Excel inserts the symbol.

8 Repeat Steps 6 and 7 to insert 
any other symbols you require.

9 Click Close.
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• Excel opens the cell for editing 
and moves the cursor to the 
end of the existing data.

• Excel displays Edit in the 
status bar.

• You can also click inside the 
Formula bar and edit the cell 
data there.

3 Make your changes to the 
cell data.

1 Click the cell in which you 
want to edit the text.

2 Press .

 You can also double-click the 
cell you want to edit.

Edit Cell Data

Once you enter text, a number, a date, or a 
time into a cell, that cell data is not set in 
stone. If the data you entered into a cell has 
changed or is incorrect, you can edit the data 

to the updated or correct value. You can edit 
cell data either directly in the cell or by using 
the Formula bar.

Edit Cell 
Data
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Is there a faster way to 
open a cell for editing?
Yes. Move  over the cell 
you want to edit, and center 

 over the character where 
you want to start editing. 
Double-click the mouse. Excel 
opens the cell for editing and 
positions the cursor at the 
spot where you double-clicked.

• Excel closes the cell for editing.

• If you pressed , Excel 
moves the selection to the cell 
below.

4 When you finish editing the 
data, press .

• If you do not want Excel to 
move the selection, click Enter 
( ) or press +  
instead.

I made a mistake when I edited a cell. Do 
I have to fix the text by hand?
Most likely not. If the cell edit was the last 
action you performed in Excel, press +

 or click the Undo button ( ) in the Quick 
Launch Toolbar. If you have performed other 
actions in the meantime, click the Undo  
and then click the edit in the list that appears. 
Note, however, that doing this will also undo 
the other actions you performed after the 
edit.
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2 Click the Home tab.

3 Click Clear ( ).

4 Click Clear Contents.

Note: You can also delete cell 
data by pressing Delete .

Delete Cell Data

1 Select the cell that contains the 
data you want to delete.

Delete Data from a Cell

If your worksheet has a cell that contains data 
you no longer need, you can delete that data. 
This helps to reduce worksheet clutter and 
makes your worksheet easier to read. If you 

want to delete data from multiple cells, you 
must first select those cells; see “Select a Range” 
in Chapter 3. To delete cells and not just the 
data, see “Delete a Range” in Chapter 3.

Delete Data 
from a Cell
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When I delete cell data, Excel 
keeps the cell formatting intact. Is 
it possible to delete the data and 
the formatting?
Yes. Excel offers a command that deletes 
everything from a cell. First, select the 
cell with the data and formatting that 
you want to delete. Click Home, click 

, and then click Clear All. Excel 
removes both the data and the 
formatting from the selected cell.

Is it possible to delete just a cell’s 
formatting?
Yes. Excel offers a command that 
deletes just the cell formatting while 
leaving the cell data intact. Select the 
cell with the formatting that you want 
to delete. Click Home, click , and 
then click Clear Formats. Excel 
removes just the formatting from 
the selected cell.

Undo Cell Data Deletion

1 Click the Undo .

2 Click Clear.

Note: If the data deletion was 
the most recent action you 
performed, you can undo it by 
pressing +  or by clicking 
Undo ( ).

• Excel restores the data to the 
cell.

• Excel removes the cell data.
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  Working with 
Excel Ranges
In Excel, a range is a collection 
of two or more cells that you 
work with as a group rather 
than separately. This enables 
you to fill the range with values, 
move or copy the range, sort 
the range data, filter the range 
to show only certain values, 
insert and delete ranges, hide 
entire rows or columns, and 
merge two or more cells. You 
learn these and  other range 
techniques in this chapter, and 
in later chapters you learn techniques such as formatting a range, applying a 
formula to a range, and building a chart from a range.
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Select a Range of Individual Cells

1 Click in the first cell that you 
want to include in the range.

2 Hold down  and click in 
each of the other cells that you 
want to include in the range.

• Each time you click in a cell, 
Excel adds it to the range.

3 Release  to end the range 
selection.

Select a Rectangular Range

1 Position  over the first cell 
you want to include in the 
range.

2 Click and drag  over the cells 
that you want to include in the 
range.

• Excel selects the cells.

3 Release the mouse button to 
end the range selection.

Select a Range

To work with a range in Excel, you must select 
the cells that you want to include in the range. 
After you select the range, you can fill it with 
data, move or copy it to another part of the 
worksheet, format the cells, delete the data, 
and so on. You can select a range as a 

rectangular group of cells, as a collection of 
individual cells, or as an entire row or column. 
It is almost always easiest to select a range 
using the mouse, but Excel does offer a few 
keyboard shortcuts for selecting ranges, as 
described in the Tip on the next page.

Select a 
Range
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Are there keyboard techniques 
I can use to select a range?
Yes. To select a rectangular range, 
navigate to the first cell that you 
want to include in the range, hold down , and then 
press  or  to extend the selection. To select an 
entire row, navigate to any cell in the row and press 

+ . To select an entire column, navigate 
to any cell in the column and then press + .

Select an Entire Column

1 Position  over the header of 
the column you want to select.

  changes to .

2 Click the column header.

• Excel selects the entire column.

 To select multiple columns, 
click and drag across the 
column headers, or hold down 

 and click each column 
header.

Select an Entire Row

1 Position  over the header of 
the row you want to select.

  changes to .

2 Click the row header.

• Excel selects the entire row.

 To select multiple rows, click 
and drag across the row 
headers or hold down  
and click each row header.

Is there an easy way to 
select every cell in the 
worksheet?
Yes. Excel offers two methods 
you can use. Either press 

+ , or click the Select 
All button ( ) in the upper 
left corner of the worksheet.
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4 Release the mouse button.

• Excel fills the range with the 
initial cell value.

Fill a Vertical or Horizontal Range

1 In the first cell of the range 
you want to work with, enter 
the data you want to fill.

2 Position  over the bottom 
right corner of the cell.

  changes to .

3 Click and drag  down to fill 
a vertical range or across to fill 
a horizontal range.

Fill a Range with the Same Data

If you need to fill a range with the same data, 
you can save time by getting Excel to fill the 
range for you. The most common method for 
filling a range in this way is to use Excel’s 
AutoFill feature, which makes it easy to fill a 
vertical or horizontal range with the same value. 

However, Excel also offers an alternative method 
that enables you to fill any selected range.
See “Select a Range,” earlier in this chapter, 
to learn how to select a range of cells.

Fill a Range with 
the Same Data
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How do I fill a vertical or horizontal 
range without also copying the 
formatting of the original cell?
Follow these steps:

1 Perform Steps 1 to 4 to fill the 
data.

• Excel displays the AutoFill Options 
smart tag ( ).

2 Click the AutoFill Options .

3 Click Fill Without Formatting.

 Excel removes the original cell’s formatting from the copied cells.

• Excel fills the range with the 
value you typed.

Fill a Selected Range

1 Select the range you want 
to fill.

2 Type the text, number, or 
other data.

3 Press + .

22

33
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AutoFill a Series of Numeric, Date, 
or Alphanumeric Values

1 Click in the first cell and type 
the first value in the series.

2 Click in an adjacent cell and 
type the second value in the 
series.

3 Select the two cells.

4 Position  over the bottom 
right corner of the second cell.

  changes to .

5 Click and drag  down to fill 
a vertical range or across to fill 
a horizontal range.

• As you drag through each cell, 
Excel displays the series value 
that it will add to the cell.

6 Release the mouse button.

• Excel fills the range with a 
series that continues the 
pattern of the initial two 
cell values.

Fill a Range with a Series of Values

If you need to fill a range with a series of 
values, you can save time by using Excel’s 
AutoFill feature to create the series for you. 
AutoFill can fill a series of numeric values such 
as 5, 10, 15, 20, and so on; a series of date 
values such as January 1, 2011, January 2, 
2011, and so on; or a series of alphanumeric 

values such as Chapter 1, Chapter 2, Chapter 3, 
and so on.
You can also create your own series with a 
custom step value, which determines the 
numeric difference between each item in the 
series.

Fill a Range with 
a Series of Values
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Can I create my own AutoFill series?
Yes. You can create a custom list. When you add the first value in your custom list, you can 
then use AutoFill to fill a range with the rest of the series. Follow these steps:

Fill a Custom Series of Values

1 Click in the first cell and type 
the first value in the series.

2 Select the range you want to 
fill, including the initial value.

3 Click the Home tab.

4 Click Fill ( ).

5 Click Series.

 The Series dialog box appears.

6 In the Type group, select the 
type of series you want to fill 
(  changes to ).

7 If you selected Date in Step 6, 
select an option in the Date 
unit group (  changes to ).

8 In the Step value text box, 
type the value you want 
to use.

9 Click OK.

• Excel fills the range with the 
series you created.

77

66

55

88

1 Click the File tab.

2 Click Options.

3 Click Advanced.

4 Click Edit 
Custom Lists.

5 Click NEW LIST.

6 In the List entries 
box, type each 
item in your 
list, and press 

 after each 
item.

7 Click Add.

8 Click OK.
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Move a Range

1 Select the range you want to 
move.

2 Position  over any outside 
border of the range.

  changes to .

3 Click and drag the range to 
the new location.

  changes to .

• Excel displays an outline of 
the range.

• Excel displays the address of 
the new location.

4 Release the mouse button.

• Excel moves the range to the 
new location.

Move or Copy a Range

You can restructure or reorganize a worksheet 
by moving an existing range to a different part 
of the worksheet. For example, if you have 
two related ranges that are far apart on the 
worksheet, you can move one of them so that 
the ranges appear close to each other.

You can also make a copy of a range, which 
is a useful technique if you require either a 
duplicate of the range elsewhere, or if you 
require a range that is similar to an existing 
range.

Move or Copy 
a Range

05_577639-ch03.indd   4605_577639-ch03.indd   46 3/15/10   2:38 PM3/15/10   2:38 PM



47

Working with Excel Ranges

CHAPTER

3

11

33

44

55

Copy a Range

1 Select the range you want 
to copy.

2 Press and hold .

3 Position  over any outside 
border of the range.

  changes to .

4 Click and drag the range to the 
location where you want the 
copy to appear.

• Excel displays an outline of 
the range.

• Excel displays the address of 
the new location.

5 Release the mouse button.

6 Release .

• Excel creates a copy of the 
range in the new location.

Can I move or copy a range to 
another worksheet?
Yes. Click and drag the range as 
described in this section. Remember 
to hold down  if you are copying 
the range. Press and hold  and 
then drag the mouse pointer over the 
tab of the sheet you want to use as 
the destination. Excel displays the 
worksheet. Release  and then 
drop the range on the worksheet.

Can I move or copy a range to another 
workbook?
Yes. If you can see the other workbook on-screen, 
click and drag the range as described in this 
section, and then drop it on the other workbook. 
Remember to hold down  if you are copying 
the range. Otherwise, select the range, click the 
Home tab, click Cut ( ) to move the range or 
Copy ( ) to copy it, switch to the other workbook, 
select the cell where you want the range to appear, 
click Home, and then click Paste ( ).
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• Excel inserts the new row.

• The rows below the new row 
are shifted down.

5 Click the Format smart 
tag ( ).

6 Select a formatting option for 
the new row (  changes 
to ).

Insert a Row

1 Click in any cell in the row 
above where you want to 
insert the new row.

2 Click the Home tab.

3 Click the Insert .

4 Click Insert Sheet Rows.

Insert a Row or Column

You can insert a row or column into your 
existing worksheet data to accommodate more 
information. This is particularly useful if the 
information you need to add fits naturally 
within the existing data, rather than at the end.
When you insert a row, Excel shifts the existing 
rows down, so you must first determine the 

row above where you want your new row to 
appear. Similarly, when you insert a column, 
Excel shifts the existing columns to the right, so 
you must first determine the column to the left 
of where you want your new column to appear.

Insert a Row 
or Column
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Can I insert more than one row or column at a time?
Yes. You can insert as many new rows or columns as you need. First, select the 
same number of rows or columns that you want to insert. (See “Select a Range” 
earlier in this chapter to learn how to select rows and columns.) For example, if 
you want to insert four rows, select four existing rows. Follow Steps 2 to 4 in 
“Insert a Row” to insert rows, or Steps 2 to 4 in “Insert a Column” to insert 
columns.

• Excel inserts the new column.

• The columns to the right of the 
new column are shifted to the 
right.

5 Click the Format smart 
tag ( ).

6 Select a formatting option for 
the new column (  changes 
to ).

Insert a Column

1 Click any cell in the row to the 
left of where you want to 
insert the new column.

2 Click the Home tab.

3 Click the Insert .

4 Click Insert Sheet Columns.
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2 Click the Home tab.

3 Click the Insert .

4 Click Insert Cells.

Note: You can also press 
+ + = .

1 Select the cell or range where 
you want the inserted cell or 
range to appear.

Insert a Cell or Range

If you need to add data to an existing range, 
you can insert a single cell or a range of cells 
within that range. When you insert a cell 
or range, Excel shifts the existing data to 
accommodate the new cells.
Excel can either shift the existing data down or 
to the right. Therefore, you need to decide in 

advance where you want the new range to be 
inserted. You then tell Excel where you want 
the insertion to take place by selecting existing 
data either below or to the right of where you 
want the new range to appear.

Insert a Cell 
or Range
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Under what circumstances would 
I insert a cell or range instead of 
inserting an entire row or column?
In most cases, it is better to insert a cell 
or range when you have other data 
either to the left or right of the existing 
range, or above or below the range. 
For example, if you have data to the 
left or right of the existing range, 
inserting an entire row would create a 
gap in the other data.

How do I know which cells to select 
to get my inserted cell or range in 
the correct position?
The easiest way to do this is to select 
the existing cell or range that is exactly 
where you want the new cell or range 
to appear. For example, if you want 
the new range to be A5:B5 as shown in 
this section’s example, you first select 
the existing A5:B5 range. When you 
insert the new range, Excel shifts the 
existing cells down (in this case) to 
accommodate it.

 The Insert dialog box appears.

5 Select the option that 
corresponds to how you want 
Excel to shift the existing cells 
to accommodate your new 
cells (  changes to ).

Note: In most cases, if you 
selected a horizontal range, click 
the Shift cells down option; if 
you selected a vertical range, 
click the Shift cells right 
option.

6 Click OK.

• Excel inserts the cell or range.

• The existing data is shifted 
down (in this case) or to the 
right.

7 Click the Format smart 
tag ( ).

8 Select a formatting option for 
the new row (  changes to ).
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2 Click the Home tab.

3 Click Clear ( ).

4 Click Clear Contents.

• If you want to delete the range 
data and its formatting, click 
Clear All instead.

Delete Range Data

1 Select the range that contains 
the data you want to delete.

Delete Data from a Range

If your worksheet has a range that contains 
data you no longer need, you can delete that 
data. This helps to reduce worksheet clutter 
and makes your worksheet easier to read. 
Note that the technique in this section only 
applies to deleting the data that exists within 

each cell in a selected range; it does not apply 
to deleting the actual range. If you want to 
delete cells and not just the data, see “Delete a 
Range” later in this chapter.

Delete Data 
from a Range
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11 Undo Range Data Deletion

1 Click the Undo .

2 Click Clear.

Note: If the data deletion was 
the most recent action you 
performed, you can undo it by 
pressing +  or by clicking 
Undo ( ).

• Excel restores the data to the 
range.

• Excel removes the range data.

Are there faster ways to 
delete the data from a 
range?
Yes. Probably the fastest 
method is to select the range 
and then press Delete . You can 
also select the range, right-click 
any part of the range, and then 
click Clear Contents.

Is it possible to delete a cell’s numeric 
formatting?
Yes. Select the range with the formatting 
that you want to delete, click Home, click 

, and then click Clear Formats. Excel 
removes all the formatting from the selected 
range. If you prefer to delete only the 
numeric formatting, click Home, click the 
Number Format , and then click General.

05_577639-ch03.indd   5305_577639-ch03.indd   53 3/15/10   2:38 PM3/15/10   2:38 PM



54

22

11

33
44

2 Click the Home tab.

3 Click the Delete .

4 Click Delete Cells.

1 Select the range that you want 
to delete.

Delete a Range

If your worksheet contains a range that you no 
longer need, you can delete that range. Note 
that when you delete a range, Excel deletes not 
just the data within the range, but the range 
cells themselves. Excel shifts the remaining 
worksheet data to replace the deleted range.

Note that the technique in this section deletes 
the actual cells from the selected range. If you 
want to delete only the data in the range, see 
“Delete Data from a Range” earlier in this 
chapter.

Delete 
a Range
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 The Delete dialog box appears.

5 Select the option that 
corresponds to how you want 
Excel to shift the remaining 
cells after it deletes the range 
(  changes to ).

Note: In most cases, if you have 
data below the selected range, 
click the Shift cells up option; 
if you have data to the right of 
the selected range, click the 
Shift cells left option.

6 Click OK.

• Excel deletes the range and 
shifts the remaining data.

Are there faster ways to 
delete a range?
Yes. Probably the fastest method 
is to select the range and then 
press + . You can also 
select the range, right-click any 
part of the range, and then click 
Delete. Both methods display 
the Delete dialog box.

How do I delete a row or column?
To delete a row, select any cell in the row, 
click the Home tab, click the Delete , and 
then click Delete Sheet Rows. To delete a 
column, select any cell in the column, click 
the Home tab, click the Delete , and then 
click or Delete Sheet Columns. Note, too, 
that you can delete multiple rows or 
columns by selecting at least one cell in each 
row or column.
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• Excel removes the row from 
the worksheet display.

• Excel displays a slightly thicker 
heading border between the 
surrounding rows to indicate 
that a hidden row lies between 
them.

 Another way to hide a row is 
to move  over the bottom 
edge of the row heading 
(  changes to ) and then 
click and drag the edge up 
until the height displays 0.

Hide a Row

1 Click in any cell in the row you 
want to hide.

2 Click the Home tab.

3 Click Format.

4 Click Hide & Unhide.

5 Click Hide Rows.

Note: You can also hide a row 
by pressing + .

Hide a Row or Column

If you do not need to see or work with a row 
or column temporarily, you can make your 
worksheet easier to read and to navigate by 
hiding the row or column.
Hiding a row or column is also useful if you are 
showing someone a worksheet that contains 

private or sensitive data that you do not want 
the person to see. For example, if a row or 
column contains salary data, passwords, or 
Social Security numbers, you should hide the 
row or column to protect this data from non-
authorized viewers.

Hide a Row 
or Column
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How do I display a hidden row or column?
To display a hidden row, select the row above and the row below the hidden 
row, click Home, click Format, click Hide & Unhide, and then click Unhide 
Rows. Alternatively, move  between the headings of the selected rows 
(  changes to ) and then double-click. To unhide row 1, right-click the top 
edge of the row 2 header and then click Unhide.
To display a hidden column, select the column to the left and the column to the 
right of the hidden column, click Home, click Format, click Hide & Unhide, and 
then click Unhide Columns. Alternatively, move  between the headings of the 
selected columns (  changes to ) and then double-click. To unhide column 
A, right-click the left edge of the column B header and then click Unhide.

• Excel removes the column 
from the worksheet display.

• Excel displays a slightly thicker 
heading border between the 
surrounding columns to 
indicate that a hidden column 
lies between them.

 Another way to hide a column 
is to move  over the right 
edge of the column heading 
(  changes to ) and then 
click and drag the edge left 
until the width displays 0.

Hide a Column

1 Click in any cell in the column 
you want to hide.

2 Click the Home tab.

3 Click Format.

4 Click Hide & Unhide.

5 Click Hide Columns.

Note: You can also hide a 
column by pressing + .
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• Excel splits the worksheet into 
two horizontal panes.

4 Click the View tab.

5 Click Freeze Panes.

6 Click Freeze Panes.

• If you want to freeze just the 
first row, you can bypass Steps 
1 to 3 and click the Freeze 
Top Row command.

 Excel freezes the panes.

Freeze Rows

1 Scroll the worksheet so that 
the row or rows that you want 
to freeze are visible.

2 Position  over the horizontal 
split bar ( ).

  changes to .

3 Click and drag  and drop it 
below the row you want to 
freeze.

Freeze Rows or Columns

As you vertically scroll a worksheet, you can 
keep your column labels in view by freezing the 
row or rows that contain the labels. This makes 
it easier to review and edit the existing data 
and to insert new data to the worksheet 
because you can always see the column labels.

If your worksheet also includes row labels, 
you can keep those labels in view as you 
horizontally scroll the worksheet by freezing 
the column or columns that contain the labels.

Freeze Rows 
or Columns
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Can I adjust the position of a 
frozen row or column?
Yes. Begin by unfreezing the panes: Click 
View, click Freeze Panes, and then 
click Unfreeze Panes. Excel unfreezes 
the panes and displays the split bar. 
Click and drag the split bar to the new 
location. Click View, click Freeze 
Panes, and then click Freeze Panes.

How do I unfreeze a row or 
column?
If you no longer require a row or 
column to be frozen, you can unfreeze 
it by clicking View, clicking Freeze 
Panes, and then clicking Unfreeze 
Panes. If you no longer want your 
worksheet split into two panes, click 
View and then click Split ( ).

Freeze Columns

1 Scroll the worksheet so that 
the column or columns that 
you want to freeze are visible.

2 Position  over the vertical 
split bar ( ).

  changes to .

3 Click and drag  and drop 
it on the right edge of the 
column you want to freeze.

• Excel splits the worksheet into 
two vertical panes.

4 Click the View tab.

5 Click Freeze Panes.

6 Click Freeze Panes.

• If you want to freeze just the 
first column, you can bypass 
Steps 1 to 3 and click the 
Freeze First Column 
command.

 Excel freezes the panes.
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2 Click the Home tab.

3 Click the Merge and 
Center .

4 Click Merge Cells.

1 Select the cells that you want 
to merge.

Merge Two or More Cells

You can create a single large cell by merging 
two or more cells. For example, it is common to 
merge some of the top row of cells to use as a 
worksheet title. Another common reason for 
merging cells is to create a label that applies to 

multiple columns of data. This can make your 
worksheet easier to read because it makes it 
clear that the label applies to multiple columns 
instead of just a single column.

Merge Two 
or More Cells
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How do I center text across multiple columns?
This is a useful technique for your worksheet titles or headings. You can center a 
title across the entire worksheet, or you can center a heading across the columns 
that it refers to. Follow Steps 1 to 3 and then click Merge & Center. Excel 
creates the merged cell and formats the cell with the Center alignment option. 
Any text you enter into the merged cell appears centered within the cell.

5 Type your text in the 
merged cell.

• Excel merges the selected cells 
into a single cell.
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2 Click the Home tab.

3 Click Copy ( ).

1 Select the range that includes 
the data you want to 
transpose.

Transpose Rows and Columns

You can use Excel’s Transpose command to 
easily turn a row of data into a column of data, 
or a column of data into a row of data. You can 

also transpose rows and columns together in a 
single command, which is handy when you 
need to restructure a worksheet.

Transpose Rows 
and Columns
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How do I know which cells to select?
The range you select before copying 
depends on what you want to transpose. 
If you want to transpose a single 
horizontal or vertical range of cells, then 
select just that range. If you want to 
transpose a horizontal range of cells and 
a vertical range of cells at the same time, 
select the range that includes all the cells, 
as shown in this section’s example.

Can I transpose range values as well 
as range labels?
Yes, Excel’s Transpose command works 
with text, numbers, dates, formulas, and 
any other data that you can add to a cell. 
So if you have a rectangular region of 
data that includes row labels, column 
labels, and cell values within each row 
and column, you can select the entire 
range and transpose it.

• Excel transposes the data and 
then pastes it to the worksheet.

4 Click where you want the 
transposed range to appear.

5 Click the Paste .

6 Click Transpose ( ).
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ChapterChapter 4444
   Working with 
Range Names
Y ou can make it easier to 
navigate Excel worksheets and 
build Excel formulas by 
applying names to your ranges. 

A range name is a text label that 
you apply to a single cell or to 
a range of cells. Once you have 
defined a name for a range, 
you can use that name in place 
of the range coordinates, which 
has several benefits. For 
example, range names are 
more intuitive than range coordinates, particularly in formulas; range names are 
more accurate than range coordinates; range names are easier to remember than 
range coordinates; and range names make it easier to navigate a worksheet.

This chapter explains range names and shows you how to define, edit, and use 
range names.
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2 Click the Formulas tab.

3 Click Define Name.

1 Select the range you want 
to name.

Define a Range Name

Before you can use a range name in your 
formulas or to navigate a worksheet, you must 
first define the range name. You can define as 
many names as you need, and you can even 
define multiple names for the same range.

You can create range names by hand, or you 
can get Excel to create the names for you 
automatically based on the existing text labels 
in a worksheet. For the latter, see “Use 
Worksheet Text to Define a Range Name.”

Define a 
Range Name
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Is there an easier way to define a 
range name?
Yes, you can follow these steps to bypass 
the New Name dialog box:

1 Select the range you want to 
name.

2 Click inside the Name box.

3 Type the name you want to use.

4 Press .

 Excel assigns the name to the range.

 The New Name dialog box 
appears.

4 Type the name you want to 
use into the Name text box.

Note: The first character of the 
name must be a letter or an 
underscore (_). The name cannot 
include spaces or cell references, 
and it cannot be any longer than 
255 characters.

5 Click OK.

 Excel assigns the name to the 
range.

• The new name appears in the 
Name box whenever the range 
is selected.

11

33

22
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2 Click the Formulas tab.

3 Click Create from 
Selection.

1 Select the range or ranges 
you want to name.

• Be sure to include the text 
labels you want to use for 
the range names.

Use Worksheet Text to Define a Range Name

If you have several ranges to name, you can 
speed up the process by getting Excel to create 
the names for you automatically based on the 
range’s text labels.
Text labels make a worksheet easier to read 
and understand, but in this section you see that 
they also make it easier to define range names. 

For example, if you have a column of sales data 
that has the label “Sales” on top, Excel can 
automatically apply the name “Sales” to that 
range. You can create range names from 
worksheet text when the labels are in the top 
or bottom row of the range, or the left or right 
column of the range.

Use Worksheet Text 
to Define a Range Name
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 The Create Names from 
Selection dialog box appears.

4 Select the setting or settings 
that correspond to where the 
text labels are located in the 
selected range (  changes 
to ).

 If Excel has activated a check 
box that does not apply to 
your data, click it (  changes 
to ).

5 Click OK.

 Excel assigns the text labels as 
range names.

• When you select one of the 
ranges, the range name 
assigned by Excel appears in 
the Name box.

Note: If the label text contains 
any illegal characters, such as a 
space, Excel replaces each of 
those characters with an 
underscore (_).

Is there a faster way to run 
the Create from Selection 
command?
Yes, Excel offers a keyboard 
shortcut for the command. 
Select the range or ranges you 
want to work with and then 
press + + . Excel 
displays the Create Names from 
Selection dialog box. Follow 
Steps 4 and 5 to create the 
range names.

Given a table with labels in the top row and left 
column, is there a way to automatically assign a 
name to the table data?
Yes. The table data refers to the range of cells that does 
not include the table headings in the top row and left 
column. To assign a name to the data range, type a 
label in the top left corner of the 
table. When you run the Create 
from Selection command on the 
entire table, Excel assigns the top 
left label to the data range, as 
shown here.
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• Excel selects the range.

Navigate Using the Name Box

1 Open the workbook that 
contains the range you 
want to work with.

2 Click the Name box .

3 Click the name of the range 
you want to select.

Navigate a Workbook Using Range Names

One of the big advantages of defining range 
names is that they make it easier to navigate 
a worksheet. You can choose a range name 
from a list and Excel automatically selects the 
associated range. This is much faster than 
scrolling through a workbook by hand, or by 

entering a cell or range reference into Excel’s 
Go To command.
Excel offers two methods for navigating a 
workbook using range names: the Name box 
and the Go To command.

Navigate a Workbook 
Using Range Names

06_577639-ch04.indd   7006_577639-ch04.indd   70 3/15/10   2:41 PM3/15/10   2:41 PM



71

Working with Range Names

CHAPTER

4
11

33

55

66

22

44

Is it possible to navigate to a named range in a 
different workbook?
Yes, but it is not easy or straightforward:

1 Follow Steps 1 to 4 on this page to display the 
Go To dialog box.

2 In the Reference text box, type the following:

 '[workbook]worksheet’!name

 Replace workbook with the file name of the workbook, worksheet with the 
name of the worksheet that contains the range, and name with the range 
name.

3 Click OK.

 The Go To dialog box appears.

5 Click the name of the range 
you want to select.

6 Click OK.

• Excel selects the range.

Navigate Using the Go To 
Command

1 Open the workbook that 
contains the range you want 
to work with.

2 Click the Home tab.

3 Click Find & Select.

4 Click Go To.

Note: You can also select the 
Go To command by pressing 

+ .

33
22

06_577639-ch04.indd   7106_577639-ch04.indd   71 3/15/10   2:41 PM3/15/10   2:41 PM



72

33

11
22

44

55 The Name Manager dialog 
box appears.

4 Click the name you want to 
change.

5 Click Edit.

1 Open the workbook that 
contains the range name you 
want to change.

2 Click the Formulas tab.

3 Click Name Manager.

Change a Range Name

You can change any range name to a more 
suitable or accurate name. This is useful if you 
are no longer satisfied with the original name 
you applied to a range, if the data changes and 
the original name is no longer suitable for the 
new data, or if you do not like the name that 

Excel generated automatically from the 
worksheet labels.
If you want to change the range coordinates 
associated with a range name, see the second 
Tip on the next page.

Change a 
Range Name

06_577639-ch04.indd   7206_577639-ch04.indd   72 3/15/10   2:41 PM3/15/10   2:41 PM



73

Working with Range Names

CHAPTER

4
66

77

99

Is there a faster method I 
can use to open the Name 
Manager dialog box?
Yes, Excel offers a shortcut key 
that enables you to bypass Steps 
2 and 3. Open the workbook 
that contains the range name 
you want to change, and then 
press + . Excel opens 
the Name Manager dialog box.

• The new name appears in the 
Name Manager dialog box.

8 Repeat Steps 4 to 7 to rename 
other ranges as needed.

9 Click Close.

 The Edit Name dialog box 
appears.

6 Use the Name text box to edit 
the name.

7 Click OK.

Can I assign a name to a different range?
Yes. If you add another range to your 
workbook and you feel that an existing name 
would be more suited to that range, you can 
modify the name to refer to the new range. 
Follow Steps 1 to 5 to open the Edit Name 
dialog box. Click inside the Refers to 
reference box, and then click and drag the 
mouse  on the worksheet to select the new 
range. Click OK.
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 The Name Manager dialog 
box appears.

4 Click the name you want 
to delete.

5 Click Delete.

1 Open the workbook that 
contains the range name you 
want to delete.

2 Click the Formulas tab.

3 Click Name Manager.

Note: You can also select the 
Name Manager command by 
pressing + .

Delete a Range Name

If you have a range name that you no longer 
need, you can use Excel’s Name Manager to 
delete it. This is a good practice, because you 
do not want to have unused range names in 
a workbook. Getting rid of unneeded range 
names reduces clutter in the Name Manager 

dialog box, and it also makes the Name box 
easier to navigate. It is also a good idea to 
delete unused range names because you may 
need to reuse the names for different ranges 
later on.

Delete a 
Range Name
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Is there a faster way to delete multiple range names?
Yes, you can delete two or more range names at once. First, follow Steps 1 to 3 
to display the Name Manager dialog box. Next, select the range names you 
want to delete: To select consecutive names, click the first name you want to 
delete, hold down , and then click the last name you want to delete; to 
select non-consecutive names, hold down  and click each name you want to 
delete. When you have selected the name you want to remove, click Delete and 
then click OK when Excel asks you to confirm the deletion.

• Excel deletes the range name.

7 Repeat Steps 4 to 6 to delete 
other range names as needed.

8 Click Close.

 Excel asks you to confirm the 
deletion.

6 Click OK.
66

88
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ChapterChapter 5555
Formatting Excel 
Ranges
Microsoft Excel 2010 offers many 
commands and options for 
formatting ranges, and you learn 
about most of them in this chapter. 
For text, you learn how to change 
the font, the font size, the text color, 
and the text alignment, as well as 
how to center text across columns 
and rotate text within a cell. You also 
learn how to change the background 
color, apply a number format, apply 
an AutoFormat and a style, change 
the column width and row height, 
add borders, and more.
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• Excel applies the font to the 
text in the selected range.

1 Select the range you want to 
format.

2 Click the Home tab.

3 To change the typeface, click 
 in the Font list and then 

click the typeface you want 
to apply.

Change the Font and Font Size

When you work in an Excel worksheet, you can 
add visual appeal to a cell or range by changing 
the font and font size.
In this section, the term font is synonymous 
with typeface, and both refer to the overall 
look of each character. By default, Excel offers 

nearly 200 different fonts in a wide variety of 
styles. Also, the font size is measured in points, 
where there are roughly 72 points in an inch. In 
some cases, formatting a range with a larger 
font size can make the range text easier to 
read.

Change the Font 
and Font Size
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In the Theme Fonts section of the Font 
list, what do the designations Body and 
Headings mean?
When you create a workbook, Excel 
automatically applies a document theme to 
the workbook, and that theme includes 
predefined fonts. The theme’s default font is 
referred to as Body, and it is the font used 
for regular worksheet text. Each theme also 
defines a Headings font, which Excel uses for 
cells formatted with a heading or title style.

• Excel applies the font size to 
the text in the selected range.

4 To change the font size, click 
 in the Font Size list and 

then click the size you want to 
apply.

• You can also type the size you 
want in the Size text box.

Can I change the default font 
and font size?
Yes. Click the File tab and then 
click Options to open the Excel 
Options dialog box. Click the 
General tab, click the Use this 
font , and then click the 
typeface you want to use as the 
default. Click the Font size  
and then click the size you prefer 
to use as the default. Click OK.
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444 To format the text as italic, 
click the Italic button ( ).

5 To format the text as 
underline, click the Underline 
button ( ).

• Excel applies the effects to the 
selected range.

6 Click the Font dialog box 
launcher ( ).

1 Select the range you want to 
format.

2 Click the Home tab.

3 To format the text as bold, 
click the Bold button ( ).

• Excel applies the bold effect 
to the selected range.

Apply Font Effects

You can improve the look and impact of text in 
an Excel worksheet by applying font effects to 
a range.
Excel’s font effects include common formatting 
such as bold, italic, and underline, which are 
available on the Ribbon for easy application. 
Excel also offers a dialog box tab that includes 

many more font effects, including special 
effects such as strikethrough, superscripts, 
and subscripts.
In most cases, you should not need to apply 
more than one or two font effects at a time. If 
you use too many effects, it can make the text 
difficult to read.

Apply Font 
Effects
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Are there any font-related keyboard shortcuts I can use?
Yes. Excel supports the following font shortcuts:

Press To

+ Toggle the selected range as bold

+ Toggle the selected range as italic

+ Toggle the selected range as underline

+ Toggle the selected range as strikethrough

8 To format the text as a 
superscript, click Superscript 
(  changes to ).

• To format the text as a 
subscript, click Subscript 
(  changes to ).

9 Click OK.

 Excel applies the font effects.

 The Format Cells dialog box 
appears with the Font tab 
displayed.

7 To format the text as 
strikethrough, click 
Strikethrough (  changes 
to ).
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4 Click a theme color.

• Alternatively, click one of 
Excel’s standard colors.

• Excel applies the color to the 
range text.

Select a Theme or Standard Color

1 Select the range you want to 
format.

2 Click the Home tab.

3 Click  in the Font Color 
list ( ).

Change the Font Color

When you build an Excel worksheet, you can 
add visual interest to the sheet text by 
changing the font color.
By default, each Excel workbook comes with a 
theme applied, and you can change the font 
color by applying one of the colors from the 

workbook’s theme. You learn more about 
workbook themes in Chapter 9.
You can also select a color from Excel’s palette 
of standard colors, or from a custom color that 
you create yourself.

Change the 
Font Color
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How can I make the best use of fonts in my documents?
• Do not use many different typefaces in a single document. Stick to one, or at 

most two, typefaces to avoid the ransom note look.
• Avoid overly decorative typefaces because they are often difficult to read.
• Use bold only for document titles, subtitles, and headings.
• Use italics only to emphasize words and phrases, or for the titles of books 

and magazines.
• Use larger type sizes only for document titles, subtitles, and, possibly, the 

headings.
• If you change the text color, be sure to leave enough contrast between the 

text and the background. In general, dark text on a light background is the 
easiest to read.

 The Colors dialog box appears.

5 Click the color you want 
to use.

• You can also click the Custom 
tab and then either click the 
color you want or enter the 
values for the Red, Green, and 
Blue components of the color.

6 Click OK.

 Excel applies the color to the 
selected range.

Select a Custom Color

1 Select the range you want to 
format.

2 Click the Home tab.

3 Click  in the Font Color 
list ( ).

4 Click More Colors.
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Align Text Horizontally

1 Select the range you want to 
format.

2 Click the Home tab.

3 In the Alignment group, click 
the horizontal alignment 
option you want to use:

 Click Align Text Left ( ) to 
align data with the left side of 
each cell.

 Click Center ( ) to align data 
with the center of each cell.

 Click Align Text Right ( ) to 
align data with the right side 
of each cell.

 Excel aligns the data 
horizontally within each 
selected cell.

• In this example, the data in 
the cells is centered.

Align Text Within a Cell

You can make your worksheets easier to read 
by aligning text and numbers within each cell. 
By default, Excel aligns numbers with the right 
side of the cell, and it aligns text with the left 
side of the cell.

You can also align your data vertically within 
each cell. By default, Excel aligns all data with 
the bottom of each cell, but you can also align 
text with the top or middle.

Align Text 
Within a Cell
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How do I format text so that it aligns 
with both the left and right sides of 
the cell?
This is called justified text, and it is useful if 
you have a lot of text in one or more cells. 
Select the range, click the Home tab, and 
then click the dialog box launcher ( ) in 
the Alignment group. The Format Cells 
dialog box appears with the Alignment tab 
displayed. In the Horizontal list, click  and 
then click Justify. Click OK to justify the cells.

How do I indent cell text?
Select the range you want to indent, click the 
Home tab, and then click the Alignment 
group’s dialog box launcher ( ). In the 
Alignment tab, click the Horizontal list  
and then click Left (Indent). Use the Indent 
text box to type the indent, in characters, 
and then click OK. You can also click the 
Increase Indent ( ) or Decrease Indent 
( ) button in the Home tab’s Alignment 
group.

Align Text Vertically

1 Select the range you want to 
format.

2 Click the Home tab.

3 In the Alignment group, click 
the vertical alignment option 
you want to use:

 Click Top Align ( ) to align 
data with the top of each cell.

 Click Middle Align ( ) to 
align data with the middle 
of each cell.

 Click Bottom Align ( ) to 
align data with the bottom of 
each cell.

 Excel aligns the data vertically 
within each selected cell.

• In this example, the text is 
aligned with the middle of 
the cell.
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2 Click the Home tab.

3 In the Alignment group, click 
the dialog box launcher ( ).

1 Select a range that consists of 
the text you want to work with 
and the cells across which you 
want to center the text.

Center Text Across Multiple Columns

You can make a worksheet more visually 
appealing and easier to read by centering text 
across multiple columns. This feature is most 
useful when you have text in a cell that you 

use as a label or title for a range. By centering 
the text across the range, it makes it easier to 
see that the label or title applies to the entire 
range.

Center Text Across 
Multiple Columns
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Is there an easier way to center text across multiple columns?
Yes, although it does require you to merge the selected cells into a single cell. 
(See Chapter 3 to learn more about merging cells.) Follow Steps 1 and 2 and 
then, in the Alignment group, click the Merge & Center button ( ). Excel 
merges the selected cells into a single cell and centers the text within that cell.

• Excel centers the text across 
the selected cells.

 Excel opens the Format Cells 
dialog box with the Alignment 
tab displayed.

4 Click the Horizontal  and 
then click Center Across 
Selection.

5 Click OK.
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 The Format Cells dialog box 
appears with the Alignment 
tab displayed.

5 Click an orientation marker.

• You can also use the Degrees 
spin box to type or click a 
degree of rotation. (See the 
Tip on the following page.)

1 Select the range containing 
the text you want to angle.

2 Click the Home tab.

3 Click Orientation ( ).

• If you want to use a 
predefined orientation, click 
one of the menu items and 
skip the rest of the steps.

4 Click Format Cell Alignment.

Rotate Text Within a Cell

You can add visual interest to your text by 
slanting the text upward or downward in the 
cell. You can also use this technique to make a 
long column heading take up less horizontal 
space on the worksheet.
Excel offers several predefined rotations, such 
as Angle Counterclockwise, which angles text 

upward at a 45-degree angle; or Rotate Text 
Up, which displays the text vertically with the 
letters running from the bottom of the cell to 
the top. You can also make cell text angle 
upward or downward by specifying the degrees 
of rotation.

Rotate Text 
Within a Cell
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How does the Degrees spin box work?
If you use the Degrees spin box to set the text orientation, you can set the text 
orientation to a positive number, such as 25, and Excel angles the text in an 
upward direction. If you set the text orientation to a negative number, such 
as –40, Excel angles the text in a downward direction.
You can specify values in the range from 90 degrees (which is the same as 
clicking the Rotate Text Up command in the Orientation menu) to –90 degrees 
(which is the same as clicking the Rotate Text Down command).

• Excel rotates the cell text.

• The row height automatically 
increases to contain the slanted 
text.

• You can reduce the column 
width to free up space and 
make your cells more 
presentable.

• You can click the vertical text 
area to display your text 
vertically instead of 
horizontally in the cell.

6 Click OK.
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4 Click a theme color.

• Alternatively, click one of 
Excel’s standard colors.

• Excel applies the color to the 
range text.

• To remove the background 
color from the range, click 
No Fill.

Select a Theme or Standard Color

1 Select the range you want to 
format.

2 Click the Home tab.

3 Click  in the Fill Color 
list ( ).

Add a Background Color to a Range

You can make a range stand out from the rest 
of the worksheet by applying a background 
color to the range. For example, many people 
apply a background color to the labels in a 
range, which makes it easier to differentiate 
the labels from the data.

Perhaps the easiest way to change the 
background color is by applying a color from 
the set of 60 predefined colors that come with 
the workbook’s theme. You c an also choose a 
color from Excel’s palette of standard colors, or 
from a custom color that you create yourself.

Add a Background 
Color to a Range
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Are there any pitfalls to watch out 
for when I apply background 
colors?
Yes. The biggest pitfall is applying a 
background color that clashes with the 
range text. For example, the default 
text color is black, so if you apply any 
dark background color, the text will be 
very difficult to read. Always use either 
a light background color with dark-
colored text, or a dark background 
color with light-colored text.

Can I apply a background that 
fades from one color to another?
Yes. This is called a gradient effect. 
Select the range, click the Home tab, 
and then click the Font group’s dialog 
box launcher ( ). Click the Fill tab 
and then click Fill Effects. In the Fill 
Effects dialog box, use the Color 1  
and the Color 2  to choose your 
colors. Click an option in the Shading 
styles section (  changes to ), and 
then click OK.

 The Colors dialog box appears.

5 Click the color you want to 
use.

• You can also click the Custom 
tab and then either click the 
color you want or enter the 
values for the Red, Green, and 
Blue components of the color.

6 Click OK.

 Excel applies the color to the 
selected range.

Select a Custom Color

1 Select the range you want 
to format.

2 Click the Home tab.

3 Click  in the Fill Color 
list ( ).

4 Click More Colors.
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2 Click the Home tab.

3 Click the Number Format .

4 Click the number format you 
want to use.

1 Select the range you want to 
format.

Apply a Number Format

You can make your worksheet easier to read by 
applying a number format to your data. For 
example, if your worksheet includes monetary 
data, you can apply the Currency format to 
display each value with a dollar sign and two 
decimal places.

Excel offers ten number formats, most of which 
apply to numeric data. However, you can also 
apply the Date format to date data, the Time 
format to time data, and the Text format to 
text data.

Apply a 
Number Format
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Is there a way to get more control over the 
number formats?
Yes. You can use the Format Cells dialog box to 
control properties such as the display of negative 
numbers, the currency symbol used, and how 
dates and times appear. Follow these steps:

1 Select the range you want to format.

2 Click the Home tab.

3 Click the Number group’s dialog box 
launcher ( ).

• For large numbers, you can 
also click Comma Style ( ).

• Excel applies the number 
format to the selected range.

• For monetary values, you can 
also click Accounting Number 
Format ( ).

• For percentages, you can also 
click Percent Style ( ).

5544

66

 The Format Cells dialog box appears 
with the Number tab displayed.

4 In the Category list, click the type of 
number format you want to apply.

5 Use the controls that Excel displays 
to customize the number format.

 The controls you see vary depending 
on the number format you chose in 
Step 4.

6 Click OK.

 Excel applies the number format.
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• Excel decreases the number of 
decimal places by one.

4 Repeat Step 3 until you get 
the number of decimal places 
you want.

Decrease the Number of Decimal 
Places

1 Select the range you want to 
format.

2 Click the Home tab.

3 Click the Decrease Decimal 
button ( ).

Change the Number of Decimal Places Displayed

You can make your numeric values easier to 
read and interpret by adjusting the number of 
decimal places that Excel displays. For example, 
you might want to ensure that all dollar-and-
cent values show two decimal places, while 
dollar-only values show no decimal places. 
Similarly, Excel often displays values with a 

large number of decimal places. If you do not 
require the extra decimals — for example, if 
the values are simple temperatures or interest 
rates — you can make them easier to read by 
reducing the number of decimals.
You can either decrease or increase the number 
of decimal places that Excel displays.

Change the Number of 
Decimal Places Displayed
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My range currently has values that display different numbers of decimal 
places. What happens when I change the number of decimal places?
In this situation, Excel uses the value that has the most displayed decimal places 
as the basis for formatting all the values. For example, if the selected range has 
values that display no, one, two, or four decimal places, Excel uses the value with 
four decimals as the basis. If you click Decrease Decimal, Excel displays every 
value with three decimal places; if you click Increase Decimal, Excel displays 
every value with five decimal places.

• Excel increases the number of 
decimal places by one.

4 Repeat Step 3 until you get 
the number of decimal places 
you want.

Increase the Number of Decimal 
Places

1 Select the range you want to 
format.

2 Click the Home tab.

3 Click the Increase Decimal 
button ( ).
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222 Click AutoFormat ( ).

Note: See Chapter 1 to learn 
how to add a button to the Quick 
Access Toolbar. In this case, you 
must add the QuickFormat 
button.

1 Select the range you want 
to format.

Apply an AutoFormat to a Range

You can save time when formatting your Excel 
worksheets by using the AutoFormat feature. 
This feature offers a number of predefined 
formatting options that you can apply to a 
range all at once. The formatting options 
include the number format, font, cell 
alignment, borders, patterns, row height, 
and column width.

The AutoFormats are designed for data in a 
tabular format, particularly where you have 
headings in the top row and left column, 
numeric data in the rest of the cells, and a 
bottom row that shows the totals for each 
column.

Apply an AutoFormat 
to a Range
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Is there a way to apply an AutoFormat 
without using some of its formatting?
Yes. Excel enables you to control all six 
formats that are part of each AutoFormat: 
Number, Font, Alignment, Border, Patterns, 
and Width/Height. Follow Steps 1 to 3 to 
choose the AutoFormat you want to apply. 
Click Options to expand the dialog box and 
display the Formats to apply group. 
Deselect the option for each format you do 
not want to apply (  changes to ), and 
then click OK.

• Excel applies the AutoFormat 
to the selected range.

 The AutoFormat dialog box 
appears.

3 In the Table format list, click 
the AutoFormat you want to 
use.

4 Click OK.

How do I remove an 
AutoFormat?
If you do not like or no longer 
need the AutoFormat you applied 
to the cells, you can revert to a 
plain, unformatted state. Select 
the range and then click  to 
display the AutoFormat dialog 
box. In the format list, click None, 
and then click OK. Excel removes 
the AutoFormat from the selected 
range.
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 An operator dialog box 
appears, such as the Greater 
Than dialog box shown here.

6 Type the value you want to 
use for your condition.

• You can also click the collapse 
dialog box button ( ) and 
then click in a worksheet cell.

 Depending on the operator, 
you may need to specify two 
values.

7 Click this  and then click the 
formatting you want to use.

• To create your own format, 
click Custom Format.

1 Select the range you want to 
work with.

2 Click the Home tab.

3 Click Conditional Formatting.

4 Click Highlight Cells Rules.

5 Click the operator you want to 
use for your condition.

Apply a Conditional Format to a Range

You can make a worksheet easier to analyze by 
applying a conditional format to a range. A 
conditional format is formatting that Excel 
applies only to cells that meet the condition 
you specify. For example, you can tell Excel to 
apply the formatting only if a cell’s value is 
greater than some specified amount.

When you set up your conditional format, you 
can specify the font, border, and background 
pattern, which helps to ensure that the cells 
that meet your criteria stand out from the other 
cells in the range.

Apply a Conditional 
Format to a Range
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Can I set up more than one 
condition for a single range?
Yes. Excel enables you to specify 
multiple conditional formats. For 
example, you could set up one 
condition for cells that are greater than 
some value, and a separate condition 
for cells that are less than some other 
value. You can apply unique formats to 
each condition. Follow Steps 1 to 8 to 
configure the new condition.

How do I remove a conditional 
format from a range?
If you no longer require a conditional 
format, you can delete it. Follow Steps 
1 to 3 to select the range and display 
the Conditional Formatting menu, and 
then click Manage Rules. Excel 
displays the Conditional Formatting 
Rules Manager dialog box. Click the 
conditional format you want to remove 
and then click Delete Rule.

• Excel applies the formatting to 
cells that meet your condition.

8 Click OK.
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2 Click the Home tab.

3 Click Cell Styles.

1 Select the range you want to 
format.

Apply a Style to a Range

You can reduce the time it takes to format your 
worksheets by applying Excel’s predefined 
styles to your ranges. Excel comes with more 
than 20 predefined styles for different 
worksheet elements such as headings, as well 

as two dozen styles associated with the current 
document theme.
Each style includes the number format, cell 
alignment, font typeface and size, border, 
and fill color.

Apply a Style 
to a Range
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Are there styles I can use to 
format tabular data?
Yes. Excel comes with a gallery of 
table styles that offer formatting 
options that highlight the first 
row, apply different formats to 
alternating rows, and so on. Select 
the range that includes your data, 
click the Home tab, and then click 
Format as Table. In the gallery 
that appears, click the table format 
you want to apply.

• Excel applies the style to the 
range.

 Excel displays the Cell Styles 
gallery.

4 Click the style you want to 
apply.

Note: If the style is not exactly 
the way you want, you can right-
click the style, click Modify, and 
then click Format to customize 
the style.

Can I create my own style?
Yes. This is useful if you find yourself 
applying the same set of formatting 
options over and over. By saving those 
options as a custom style, you can apply 
it by following Steps 1 to 4. Apply your 
formatting to a cell or range, and then 
select that cell or range. Click Home, 
click Cell Styles, and then click New 
Cell Style. In the Style dialog box, 
type a name for your style, and then 
click OK.
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2 Click the Home tab.

3 Click Format.

4 Click Column Width.

1 Click in any cell in the column 
you want to resize.

Change the Column Width

You can make a column of data easier to read 
by adjusting the column width. For example, if 
you have a large number or a long line of text 
in a cell, Excel may display only part of the cell 
value. To avoid this, you can increase the width 
of the column.

Similarly, if a column only contains a few 
characters in each cell, you can decrease the 
width to fit more columns on the screen.

Change the 
Column Width

07_577639-ch05.indd   10207_577639-ch05.indd   102 3/15/10   2:42 PM3/15/10   2:42 PM



103

Formatting Excel Ranges

CHAPTER

5
55

66

Is there an easier way to 
adjust the column width to fit 
the contents of a column?
Yes. You can use Excel’s AutoFit 
feature, which automatically 
adjusts the column width to fit the 
widest item in a column. Click any 
cell in the column, click Home, 
click Format, and then click 
AutoFit Column Width. 
Alternatively, move  over the 
right edge of the column heading 
(  changes to ) and then 
double-click.

 The Column Width dialog box 
appears.

5 In the Column width text 
box, type the width you 
want to use.

6 Click OK.

• Excel adjusts the column 
width.

• You can also move  over 
the right edge of the column 
heading (  changes to ) 
and then click and drag the 
edge to set the width.

Is there a way to change all the column 
widths at once?
Yes. Click  (or press + ) to select 
the entire worksheet, and then follow the 
steps in this section to set the width you 
prefer. If you have already adjusted some 
column widths and you want to change all 
the other widths, click Home, click Format, 
and then click Default Width to open the 
Standard Width 
dialog box. Type 
the new standard 
column width, and 
then click OK.
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2 Click the Home tab.

3 Click Format.

4 Click Row Height.

1 Select a range that includes at 
least one cell in every row you 
want to resize.

Change the Row Height

You can make your worksheet more visually 
appealing by increasing the row heights to 
create more space. This is particularly useful in 
worksheets that are crowded with text. By 
increasing the row heights, you add white 
space above each cell, which makes the text 
easier to read.

If you want to change the row height to 
display multiline text within a cell, you must 
also turn on text wrapping within the cell. See 
“Wrap Text Within a Cell” later in this chapter.

Change the 
Row Height
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appears.

5 In the Row height text box, 
type the height you want to 
use.

6 Click OK.

• Excel adjusts the row heights.

• You can also move  over the 
bottom edge of a row heading 
(  changes to ) and then 
click and drag the edge to set 
the height.

Is there a way to change all the row 
heights at once?
Yes. Click  (or press + ) to select 
the entire worksheet. You can then either 
follow the steps in this section to set the 
height by hand, or you can move  over 
the bottom edge of 
any row heading 
(  changes to ) 
and then click and 
drag the edge to 
set the height of all 
the rows.

Is there an easier way to 
adjust the row height to fit 
the contents of a row?
Yes. You can use Excel’s AutoFit 
feature, which automatically 
adjusts the row height to fit the 
tallest item in a row. Click in any 
cell in the row, click Home, click 
Format, and click AutoFit Row 
Height. Alternatively, move  
over the bottom edge of the row 
heading (  changes to ) and 
then double-click.

07_577639-ch05.indd   10507_577639-ch05.indd   105 3/15/10   2:42 PM3/15/10   2:42 PM



106

22

11

2 Click the Home tab.

1 Select the cell that you want to 
format.

Wrap Text Within a Cell

You can make a long cell entry easier to read 
by wrapping the text within the cell.
If you type more text in a cell than can fit 
horizontally, Excel either displays the text over 
the next cell if that cell is empty, or Excel 
displays only part of the text if the next cell 

contains data. To prevent Excel from showing 
only truncated cell data, you can format the cell 
to wrap text within the cell. In most cases, 
Excel increases the row height just enough so 
that it can display all the text given the cell’s 
current width.

Wrap Text 
Within a Cell
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 Excel turns on text wrapping 
for the selected cell.

• If the cell has more text than 
can fit horizontally, Excel 
wraps the text onto multiple 
lines and increases the row 
height to compensate.

3 Click Wrap Text ( ).

My text is only slightly bigger than the cell. 
Is there a way to view the entire text 
without turning on text wrapping?
Yes. There are several things you can try. For 
example, you can widen the column until you see 
all your text; see “Change the Column Width” 
earlier in this chapter.
Alternatively, you can try reducing the cell font 
size. One way to do this is to choose a smaller 
value in the Font Size list of the Home tab’s Font 
group. However, an easier way is to click the 
Alignment group’s dialog box launcher ( ) to 
open the Format Cells dialog box with the Alignment tab displayed. Click 
the Shrink to fit check box (  changes to ) and then click OK.

07_577639-ch05.indd   10707_577639-ch05.indd   107 3/15/10   2:42 PM3/15/10   2:42 PM



108

11

22

33
2 Click the Home tab.

3 Click the Borders .

1 Select the range that you want 
to format.

Add Borders to a Range

You can make a range stand out from the rest 
of your worksheet data by adding a border 
around the range. You can also use borders to 
make a range easier to read. For example, if 
your range has totals on the bottom row, you 
can add a double border above the totals. 

Borders are also useful if a worksheet has 
several ranges that appear close to each other. 
By surrounding each range with a border, you 
make it clearer that your worksheet consists of 
multiple, separate ranges.

Add Borders 
to a Range

07_577639-ch05.indd   10807_577639-ch05.indd   108 3/15/10   2:42 PM3/15/10   2:42 PM



109

Formatting Excel Ranges

CHAPTER

5

44

• Excel applies the border to the 
range.

4 Click the type of border you 
want to use.

How do I get my borders to stand out 
from the worksheet gridlines?
One way to make your borders stand out is 
to click the Borders , click Line Style, and 
then click a thicker border style. You can also 
click Line Color and then click a color that 
is not a shade of gray. However, perhaps 
the most effective method is to turn off the 
worksheet gridlines. Click the View tab, and 
then in the Show group click the Gridlines 
check box (  changes to ).

None of the border types is quite right 
for my worksheet. Can I create a 
custom border?
Yes. You can draw the border by hand. 
Click the Borders  and then click Draw 
Border. Use the Line Style and Line Color 
lists to configure your border. Click a cell 
edge to add a border to that edge; click 
and drag a range to add a border around 
that range. If you prefer to create a grid 
where the border surrounds every cell, click 
the Draw Border Grid command instead.
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Building 
Formulas and 
Functions
Are you ready to start creating 
powerful and useful worksheets 
by building your own formulas? 
This chapter explains formulas, 
shows you how to build them, 
and shows you how to 
incorporate Excel’s versatile 
worksheet functions into your 
formulas. You also learn useful 
formula techniques such as how 
to sum a row or column of 
numbers, how to create quick 
formulas using the AutoSum 
feature, how to use range names and range from other workbooks in your 
formulas, and how to move and copy formulas.
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To get the most out of Excel, you need to 
understand formulas so that you can perform 
calculations on your worksheet data. You need 
to know the components of a formula, you 

need to understand arithmetic and comparison 
formulas, and you need to understand the 
importance of precedence when building a 
formula.

Understanding 
Excel Formulas

Formulas
A formula is a set of symbols and values that perform some kind of calculation and 
produce a result. All Excel formulas have the same general structure: an equal sign (=) 
followed by one or more operands and operators. The equal sign tells Excel to interpret 
everything that follows in the cell as a formula. For example, if you type =5+8 into a 
cell, Excel interprets the 5+8 text as a formula, and displays the result in the cell (13).

Operands
Every Excel formula includes one or more operands, which are the data that 
Excel uses in the calculation. The simplest type of operand is a constant value, 
which is usually a number. However, most Excel formulas include references 
to worksheet data, which can be a cell address (such as B1), a range address 
(such as B1:B5), or a range name. Finally, you can also use any of Excel’s 
built-in functions as an operand.

Operators
In an Excel formula that contains two or more operands, each operand is 
separated by an operator, which is a symbol that combines the operands in 
some way, usually mathematically. Example operators include the plus sign 
(+) and the multiplication sign (*). For example, the formula =B1+B2 adds 
the values in cells B1 and B2.
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Arithmetic Formulas
An arithmetic formula combines numeric operands — 
numeric constants, functions that return numeric 
results, and fields or items that contain numeric 
values — with mathematical operators to perform a 
calculation. Because Excel worksheets primarily deal 
with numeric data, arithmetic formulas are by far the 
most common formulas used in worksheet 
calculations.

Comparison Formulas
A comparison formula combines numeric 
operands — numeric constants, functions that 
return numeric results, and fields or items 
that contain numeric values — with special 
operators to compare one operand with 
another. A comparison formula always 
returns a logical result. This means that if the 
comparison is true, then the formula returns 
the value 1, which is equivalent to the logical 
value TRUE; if the comparison is false, then 
the formula returns the value 0, which is 
equivalent to the logical value FALSE.

Operator Precedence
Most of your formulas include multiple 
operands and operators. In many cases, 
the order in which Excel performs the 
calculations is crucial. Consider the 
formula =3 + 5 ^ 2. If you calculate 
from left to right, the answer you get is 
64 (3 + 5 equals 8, and 8 ^ 2 equals 
64). However, if you perform the 
exponentiation first and then the 
addition, the result is 28 (5 ^ 2 equals 
25, and 3 + 25 equals 28). 

There are seven arithmetic operators you can 
use to construct arithmetic formulas:

Operator Name Example Result

+ Addition =10 + 5 15

– Subtraction =10 – 5 5

– Negation =–10 –10

* Multiplication =10 * 5 50

/ Division =10 / 5 2

% Percentage =10% 0.1

^ Exponentiation =10 ^ 5 100000

There are six operators you can use to construct 
comparison formulas:

Operator Name Example Result

= Equal to =10 = 5 0

< Less than =10 < 5 0

< = Less than or equal to =10 < = 5 0

> Greater than =10 > 5 1

> = Greater than or equal to =10 > = 5 1

< > Not equal to =10 < > 5 1

To solve this problem, Excel evaluates a formula according to 
a predefined order of precedence, which is determined by the 
formula operators:

Operator Operation Precedence

( ) Parentheses 1st

– Negation 2nd

% Percentage 3rd

^ Exponentiation 4th

* and / Multiplication and division 5th

+ and – Addition and subtraction 6th

= < < = > > = < > Comparison 7th
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3 Type or click an operand. For 
example, to reference a cell in 
your formula, click in the cell.

• Excels inserts the address of 
the clicked cell into the 
formula.

1 Click in the cell in which you 
want to build the formula.

2 Type =.

• Your typing also appears in 
the Formula bar.

Note: You can also type the 
formula into the Formula bar.

Build a Formula

You can add a formula to a worksheet cell 
using a technique similar to adding data to a 
cell. To ensure that Excel treats the text as a 
formula, be sure to begin with an equal sign 
(=) and then type your operands and 
operators.

When you add a formula to a cell, Excel displays 
the formula result in the cell, not the formula 
itself. For example, if you add the formula 
=C3+C4 to a cell, that cell displays the sum of 
the values in cells C3 and C4. To see the formula, 
click the cell and examine the Formula bar.

Build a 
Formula
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• Excel displays the formula 
result in the cell.

4 Type an operator.

5 Repeat Steps 3 and 4 to add 
other operands and operators 
to your formula.

6 Click  or press .

If Excel displays only the result of the 
formula, how do I make changes to the 
formula?
Excel displays the formula result in the cell, 
but it still keeps track of the original formula. 
To display the formula again, you have two 
choices: Click the cell and then edit the 
formula using the Formula bar, or double-
click the cell to display the original formula 
in the cell and then edit the formula. In both 
cases, press  when you finish editing 
the formula.

If I have many formulas, is there an easy 
way to view the formulas?
Yes. You can configure the worksheet to show 
the formulas instead of their results. Click File 
and then click Options to open the Excel 
Options dialog box. Click the Advanced tab, 
scroll to the Display options for this 
worksheet section, click the Show formulas 
in cells instead of their calculated results 
check box (  changes to ), and then click 
OK. You can also toggle between formulas and 
results by pressing + ‘ .
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To build powerful and useful formulas, you 
often need to include one or more Excel 
functions as operands. You need to understand 

the advantages of using functions, you need to 
know the basic structure of every function, and 
you need to review Excel’s function types.

Understanding 
Excel Functions

Functions
A function is a predefined formula that performs a specific task. For 
example, the SUM function calculates the total of a list of numbers, and 
the PMT (payment) function calculates a loan or mortgage payment. 
You can use functions on their own, preceded by =, or as part of a 
larger formula.

Function Advantages
Functions are designed to take you beyond the basic arithmetic and comparison 
formulas by offering two main advantages. First, functions make simple but 
cumbersome formulas easier to use. For example, calculating a loan payment requires 
a complex formula, but Excel’s PMT function makes this easy. Second, functions enable 
you to include complex mathematical expressions in your worksheets that otherwise 
would be difficult or impossible to construct using simple arithmetic operators.

Function Structure
Every worksheet function has the same basic structure: NAME(Argument1, 
Argument2, ...). The NAME part identifies the function. In worksheet 
formulas and custom PivotTable formulas, the function name always appears 
in uppercase letters: PMT, SUM, AVERAGE, and so on. The items that appear 
within the parentheses are the functions’ arguments. The arguments are the 
inputs that functions use to perform calculations. For example, the function 
SUM(A1,B2,C3) adds the values in cells A1, B2, and C3.
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Statistical Functions
The following table lists some common statistical functions:

Function Description

AVERAGE(number1,number2,...) Returns the average of the arguments

COUNT(number1,number2,...) Counts the numbers in the argument list

MAX(number1,number2,...) Returns the maximum value of the arguments

MEDIAN(number1,number2,...) Returns the median value of the arguments

MIN(number1,number2,...) Returns the minimum value of the arguments

MODE(number1,number2,...) Returns the most common value of the arguments

STDEV(number1,number2,...) Returns the standard deviation based on a sample

STDEVP(number1,number2,...) Returns the standard deviation based on an entire population

Financial Functions
Most of Excel’s financial functions use the following arguments:

Argument Description

rate The fixed rate of interest over the term of the loan or investment

nper The number of payments or deposit periods over the term of the loan or investment

pmt The periodic payment or deposit

pv The present value of the loan (the principal) or the initial deposit in an investment

fv The future value of the loan or investment

type The type of payment or deposit: 0 (the default) for end-of-period payments or deposits; 1 for beginning-
of-period payments or deposits

The following table lists some common financial functions:

Function Description

FV(rate,nper,pmt,pv,type) Returns the future value of an investment or loan

IPMT(rate,per,nper,pv,fv,type) Returns the interest payment for a specified period of a loan

NPER(rate,pmt,pv,fv,type) Returns the number of periods for an investment or loan

PMT(rate,nper,pv,fv,type) Returns the periodic payment for a loan or investment

PPMT(rate,per,nper,pv,fv,type) Returns the principal payment for a specified period of a loan

PV(rate,nper,pmt,fv,type) Returns the present value of an investment

RATE(nper,pmt,pv,fv,type,guess) Returns the periodic interest rate for a loan or investment
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 The Insert Function dialog box 
appears.

5 Click  and then click the 
category that contains the 
function you want to use.

6 Click the function.

7 Click OK.

1 Click in the cell in which you 
want to build the formula.

2 Type =.

3 Type any operands and 
operators you need before 
adding the function.

4 Click the Insert Function 
button ( ).

Add a Function to a Formula

To get the benefit of an Excel function, you 
need to use it within a formula. You can use a 
function as the only operand in the formula, or 
you can include the function as part of a larger 
formula.
In “Understanding Excel Functions,” you 
learned that Excel has many functions and that 

most functions take one or more arguments, 
but it is often difficult to remember a function’s 
arguments and the order in which they appear. 
To make it easy to choose the function you 
need and to add the appropriate arguments, 
Excel offers the Insert Function feature.

Add a Function 
to a Formula
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 The Function Arguments 
dialog box appears.

8 Click inside an argument box.

9 Click the cell that contains the 
argument value.

 You can also type the 
argument value.

0 Repeat Steps 8 and 9 to fill as 
many arguments as you need.

• The function result appears 
here.

! Click OK.

• Excel adds the function to the 
formula.

• Excel displays the formula result.

Note: In this example, the result 
appears in the parentheses to 
indicate a negative value. In loan 
calculations, money that you pay 
out is always a negative amount.

Note: If your formula requires 
any other operands and 
operators, press  and then 
type what you need to complete 
your formula.

Do I have to specify a value for 
every function argument?
Not necessarily. Some function 
arguments are required to obtain a 
result, but some are optional. In the 
PMT function, for example, the rate, 
nper, and pv arguments are required, 
but the fv and type arguments are 
optional. When the Function Arguments 
dialog box displays a result for the 
function, then you know you have 
entered all of the required arguments.

How do I calculate a monthly financial result 
if I only have yearly values?
This is a common problem. For example, if your 
loan payment worksheet contains an annual 
interest rate and a loan term in years, how do you 
calculate the monthly payment using the PMT 
function? You need to convert the rate and term to 
monthly values. That is, you divide the annual 
interest rate by 12, and you multiply the term by 
12. For example, if the annual rate is in cell B2, 
the term in years is in B3, and the loan amount is 
in B4, the function PMT(B2/12, B3*12, B4) 
calculates the monthly payment.

08_577639-ch06.indd   11908_577639-ch06.indd   119 3/15/10   2:43 PM3/15/10   2:43 PM



120

11

33

22

3 Use the mouse  to click and 
drag the row or column of 
numbers that you want to add.

• Excel adds a reference for the 
range to the formula.

1 Click in the cell where you 
want the sum to appear.

2 Type =sum(.

• When you begin a function, 
Excel displays a banner that 
shows you the function’s 
arguments.

Note: In the function banner, 
bold arguments are required, 
and arguments that appear in 
square brackets are optional.

Add a Row or Column of Numbers

You can quickly add worksheet numbers by 
building a formula that uses Excel’s SUM 
function. 
Adding a range of numbers is probably the 
most common worksheet calculation, so it 
is useful to know how to use Excel’s SUM 
function. Although you can use SUM to add 

individual cells or a rectangular range of cells, 
you will most often need to add a row or a 
column of data. In this case, when you use the 
SUM function in a formula, you can specify as 
the function’s argument a reference to either a 
row or a column of numbers.

Add a Row or 
Column of Numbers
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• Excel enters the formula.

• Excel displays the sum in the 
cell.

4 Type ).

5 Click  or press .

Can I use the SUM function to total 
rows and columns at the same time?
Yes, the SUM function works not only 
with simple row and column ranges, but 
with any rectangular range. After you 
type =sum(, use the mouse  to click 
and drag the entire range that you want 
to sum.

Can I use the SUM function to total only 
certain values in a row or column?
Yes. The SUM function can accept multiple 
arguments, so you can enter as many cells or 
ranges as you need. After you type =sum(, hold 
down  and either click each cell that you want 
to include in the total, or use the mouse  to click 
and drag each range that you want to sum.
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2 Click the Sum button ( ).

• If you want to use a function 
other than SUM, click the Sum 

 and then click the operation 
you want to use: Average, 
Count Numbers, Max, or Min.

1 Click in the cell where you 
want the sum to appear.

Note: For AutoSum to work, the 
cell you select should be below 
or to the right of the range you 
want to sum.

Build an AutoSum Formula

You can reduce the time it takes to build a 
worksheet as well as reduce the possibility of 
errors by using Excel’s AutoSum feature. By 
default, the AutoSum tool adds a SUM function 
formula to a cell and automatically adds the 

function arguments based on the structure of 
the worksheet data. However, you can also use 
AutoSum to quickly create simple formulas that 
use common functions, such as AVERAGE, 
COUNT, MAX, or MIN.

Build an AutoSum 
Formula
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• Excel adds a SUM function 
formula to the cell.

Note: You can also press 
+ =  instead of clicking .

• Excel guesses that the range 
above (or to the left) of the cell 
is the one you want to add.

 If Excel guessed wrong, select 
the correct range.

3 Click  or press .

• Excel displays the sum.

Is there a way to see the sum of a range 
without adding an AutoSum formula?
Yes. You can use Excel’s status bar to do this. 
When you select any range, Excel adds the 
range’s numeric values and displays the result on 
the right side of the status bar — for example, 
Sum: 75200. By default, Excel also displays the 
Average and Count. If you want to see a different 
calculation, right-click the result in the status bar 
and then click the operation you want to use: 
Numerical Count, Maximum, or Minimum.

Is there a faster way to add an 
AutoSum formula?
Yes. If you know the range you want to 
sum, and that range is either a vertical 
column with a blank cell below it or a 
horizontal row with a blank cell to its right, 
select the range (including the blank cell) 
and then click  or press + = . Excel 
populates the blank cell with a SUM 
formula that totals the selected range.
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3 Click Use in Formula.

• Excel displays a list of the 
range names in the current 
workbook.

4 Click the range name you want 
to use.

1 Click in the cell in which you 
want to build the formula, 
type =, and then type any 
operands and operators you 
need before adding the range 
name.

2 Click the Formulas tab.

Add a Range Name to a Formula

You can make your formulas easier to build, 
more accurate, and easier to read by using 
range names as operands. For example, the 
formula =SUM(B2:B10) is difficult to decipher 
on its own because you cannot tell at a glance 
what kind of data is in the range B2:B10. 
However, with the formula =SUM(Expenses), it 

is immediately obvious that the formula is 
adding a range of expense values.
If you are not sure what range names are or 
how to define a range name, see Chapter 4 to 
learn more about range names, including how 
to define names for ranges in Excel.

Add a Range Name 
to a Formula
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• Excel inserts the range name 
into the formula.

5 Type any operands and 
operators you need to 
complete your formula.

• If you need to insert other 
range names into your 
formula, repeat Steps 2 to 5 
for each name.

6 Click  or press .

 Excel calculates the formula 
result.

If I create a range name after I build my 
formula, is there an easy way to convert the 
range reference to the range name?
Yes. Excel offers an Apply Names feature that 
replaces range references with their associated 
range names throughout a worksheet. Click the 
Formulas tab, click the Define Name , and 
then click Apply Names to open the Apply 
Names dialog box. In the Apply names list, click 
the range name you want to use, and then click 
OK. Excel replaces the associated range 
references with the range name in each formula 
in the current worksheet.

Do I have to use the list of range 
names to insert range names into my 
formulas?
No. As you build your formula, you can 
type the range name by hand, if you 
know it. Alternatively, as you build your 
formula, click the cell or select the range 
that has the defined name, and Excel adds 
the name to your formula instead of the 
range address. If you want to work from a 
list of the defined range names, click an 
empty area of the worksheet, click 
Formulas, click Use in Formula, click 
Paste Names, and then click Paste List.
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2 Press +  until the 
worksheet you want to use 
appears.

1 Click in the cell in which you 
want to build the formula, 
type =, and then type any 
operands and operators you 
need before adding the range 
reference.

Reference Another Worksheet Range in a Formula

You can add flexibility to your formulas by 
adding references to ranges that reside in other 
worksheets. This enables you to take advantage 
of work you have done in other worksheets so 
you do not have to waste time repeating your 
work on the current worksheet.

You can even add references to ranges that 
reside in other workbooks, as described in the 
second Tip on the following page.

Reference Another Worksheet 
Range in a Formula
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3 Select the range you want to 
use.

4 Press +  until you 
return to the original 
worksheet.

• A reference to the range on 
the other worksheet appears in 
your formula.

5 Type any operands and 
operators you need to 
complete your formula.

6 Click  or press .

 Excel calculates the formula 
result.

Can I reference a range in another 
worksheet by hand?
Yes. Rather than selecting the other worksheet 
range with your mouse, you can type the 
range reference directly into your formula. 
Type the worksheet name, surrounded by 
single quotation marks (‘) if the name contains 
a space; type an exclamation mark (!); then 
type the cell or range address. Here is an 
example: ‘Expenses 2010’!B2:B10.

Can I reference a range in another 
workbook in my formula?
Yes. First make sure the workbook you want 
to reference is open. When you reach the 
point in your formula where you want to add 
the reference, click the Excel icon ( ) in the 
Windows taskbar, and then click the other 
workbook to switch to it. Click the worksheet 
that has the range you want to reference, and 
then select the range. Click  and then click 
the original workbook to switch back to it. 
Excel adds the other workbook range 
reference to your formula.
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Move a Formula

1 Click the cell that contains the 
formula you want to move.

2 Position  over any outside 
border of the cell.

  changes to .

3 Click and drag the cell to the 
new location.

  changes to .

• Excel displays an outline of the 
cell.

• Excel displays the address of 
the new location.

4 Release the mouse button.

• Excel moves the formula to the 
new location.

• Excel does not change the 
formula’s range references.

Move or Copy a Formula

You can restructure or reorganize a worksheet 
by moving an existing formula to a different 
part of the worksheet. When you move a 
formula, Excel preserves the formula’s range 
references.
Excel also enables you to make a copy of a 
formula, which is a useful technique if you 

require a duplicate of the formula elsewhere or 
if you require a formula that is similar to an 
existing formula. When you copy a formula, 
Excel adjusts the range references to the new 
location.

Move or Copy 
a Formula
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Copy a Formula

1 Click the cell that contains the 
formula you want to copy.

2 Press and hold .

3 Position  over any outside 
border of the cell.

  changes to .

4 Click and drag the cell to the 
location where you want the 
copy to appear.

• Excel displays an outline of the 
cell.

• Excel displays the address of 
the new location.

5 Release the mouse button.

6 Release .

• Excel creates a copy of the 
formula in the new location.

• Excel adjusts the range 
references.

Note: You can make multiple 
copies by dragging the bottom-
right corner of the cell. Excel fills 
the adjacent cells with copies of 
the formula. 

Why does Excel adjust the range references when I copy a formula?
When you make a copy of a formula, Excel assumes that you want that copy to reference 
different ranges than in the original formula. In particular, Excel assumes that the ranges you 
want to use in the new formula are positioned relative to the ranges used in the original 
formula, and that the relative difference is equal to the number of rows and columns you 
dragged the cell to create the copy.
For example, suppose your original formula references cell A1, and you make a copy of the 
formula in the cell one column to the right. In that case, Excel also adjusts the cell reference 
one column to the right, so it becomes B1 in the new formula.
If you do not want Excel to adjust a range reference, switch the reference to the absolute 
format. Double-click the cell that contains the formula you want to edit, select the cell 
reference you want to change, and then press .
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Manipulating 
Excel 
Worksheets
An Excel worksheet is where 
you enter your headings and 
data and build your formulas. 
You will spend most of your 
time in Excel operating within 
a worksheet, so you need 
to know how to navigate a 
worksheet as well as how to 
perform useful worksheet tasks, 
such as renaming worksheets; 
creating new worksheets; and 
moving, copying, and deleting 
worksheets. In this chapter you 
also learn how to change the 
gridline color, and how to 
toggle gridlines and headings 
on and off.
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You can use a few keyboard techniques that 
make it easier to navigate data after it is 
entered in a worksheet.
After you enter data into a cell, it is usually 
easiest to use your mouse to click in the next 

cell you want to work with. However, if you are 
entering data and your hands are already on 
the keyboard, then it is often faster to use the 
keyboard to navigate to the next cell.

Navigate a 
Worksheet

Keyboard Techniques for Navigating a Worksheet

Press To Move

Left one cell

Right one cell

Up one cell

Down one cell

Home To the beginning of the current row

Down one screen

Up one screen

+
One screen to the right

+
One screen to the left

+ Home To the beginning of the worksheet

+ To the bottom right corner of the used portion of the worksheet

+arrow keys In the direction of the arrow to the next non-blank cell if the current cell 
is blank, or to the last non-blank cell if the current cell is not blank
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5 If you want to edit the existing 
name, press either  or  to 
deselect the text.

6 Type the new worksheet name.

7 Press .

 Excel assigns the new name to 
the worksheet.

1 Display the worksheet you 
want to rename.

2 Click the Home tab.

3 Click Format.

4 Click Rename Sheet.

• You can also double-click the 
worksheet’s tab.

• Excel opens the worksheet 
name for editing and selects 
the text.

Rename a Worksheet

You can make your Excel workbooks easier to 
understand and navigate by providing each 
worksheet with a name that reflects the 
contents of the sheet.
Excel provides worksheets with generic names 
such as Sheet1 and Sheet2, but you can change 

these to more descriptive names such as Sales 
2010, Amortization, or Budget Data. You can 
use any combination of letters, numbers, 
and symbols in a worksheet name, but the 
maximum number of characters you can use 
in the name is 31.

Rename a 
Worksheet
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• Excel inserts the worksheet.

Note: You can also insert a 
blank worksheet by pressing 

+ .

Note: You can also create a new 
worksheet by clicking the Insert 
Worksheet button ( ).

Insert a Blank Worksheet

1 Open the workbook to which 
you want to add the 
worksheet.

2 Click the Home tab.

3 Click the Insert .

4 Click Insert Sheet.

Create a New Worksheet

Excel supports multiple worksheets in a single 
workbook, so you can add as many worksheets 
as you need for your project or model.
Each new Excel workbook comes with three 
worksheets, but it is not uncommon to require 
four or more worksheets in a workbook. In 

most cases, you will add a blank worksheet, 
but Excel also comes with several predefined 
worksheet templates that you can use. Note 
that there is no practical limit to the number 
of worksheets you can add to a workbook.

Create a New 
Worksheet
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 The Insert dialog box appears.

4 Click the Spreadsheet 
Solutions tab.

5 Click the type of worksheet 
you want to add.

• You can also click Templates 
on Office Online to download 
worksheet templates from the 
Web.

6 Click OK.

• Excel inserts the worksheet.

Insert a Worksheet from a 
Template

1 Open the workbook to which 
you want to add the 
worksheet.

2 Right-click a worksheet tab.

3 Click Insert.

How do I navigate from one worksheet to another?
Click the tab of the worksheet you want to use. Press

+  to move to the next worksheet, and

+  to move to the previous worksheet.

You can also click the following controls:

Move to the first worksheet.

Move to the previous worksheet.

Move to the next worksheet.

Move to the last worksheet.
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3 Click the Home tab.

4 Click Format.

5 Click Move or Copy Sheet.

• You can also right-click the tab 
and then click Move or Copy 
Sheet.

 The Move or Copy dialog box 
appears.

1 If you want to move the 
worksheet to another 
workbook, open that 
workbook and then return 
to the current workbook.

2 Click the tab of the worksheet 
you want to move.

Move a Worksheet

You can organize an Excel workbook and make 
it easier to navigate by moving your worksheets 
to different positions within the workbook.
Although you will most often move a 

worksheet to a different position within the 
same workbook, it is also possible to move a 
worksheet to another workbook.

Move a 
Worksheet
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6 If you want to move the sheet 
to another workbook, click the 
To book  and then click the 
workbook.

7 Use the Before sheet list to 
click a destination worksheet.

 When Excel moves the 
worksheet, it will appear to the 
left of the sheet you selected 
in Step 7.

8 Click OK.

• Excel moves the worksheet.

Is there an easier way to move a worksheet within the same workbook?
Yes. It is usually much easier to use your mouse to move a worksheet within the same 
workbook:

1 Move  over the tab of the 
worksheet you want to move.

2 Click and drag the worksheet 
tab left or right to the new 
position within the workbook.

  changes to .

• As you drag, an arrow shows 
the position of the worksheet.

3 When you have the worksheet positioned where you want it, drop the 
worksheet tab.

 Excel moves the worksheet.

33

22 11
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3 Click the Home tab.

4 Click Format.

5 Click Move or Copy Sheet.

• You can also right-click the tab 
and then click Move or Copy 
Sheet.

 The Move or Copy dialog box 
appears.

1 If you want to copy the 
worksheet to another 
workbook, open that 
workbook and then return 
to the current workbook.

2 Click the tab of the worksheet 
you want to copy.

Copy a Worksheet

Excel enables you to make a copy of a 
worksheet, which is a useful technique if you 
require a new worksheet that is similar to an 
existing worksheet. Rather than re-creating the 
new worksheet from scratch, you can make a 

copy of an existing worksheet and then edit 
the copy as needed.
Although you will most often copy a worksheet 
within the same workbook, it is also possible to 
copy the worksheet to another workbook.

Copy a 
Worksheet
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Is there an easier way to copy a worksheet within the same workbook?
Yes. It is usually much easier to use your mouse to copy a worksheet within the 
same workbook:

1 Move  over the tab of the worksheet you want to copy.

2 Hold down .

3 Click and drag the 
worksheet tab left or right.

  changes to .

• As you drag, an arrow shows the position of the worksheet.

4 When you have the worksheet positioned where you want it, drop 
the worksheet tab.

 Excel copies the worksheet.

6 If you want to copy the sheet 
to another workbook, click the 
To book  and then click the 
workbook.

7 Use the Before sheet list to 
click a destination worksheet.

 When Excel copies the 
worksheet, the copy will 
appear to the left of the sheet 
you selected in Step 7.

8 Click the Create a copy check 
box (  changes to ).

9 Click OK.

• Excel copies the worksheet.

• Excel gives the new worksheet 
the same name as the original, 
but with (2) appended.

Note: See "Rename a 
Worksheet" earlier in this chapter 
to learn how to edit the name of 
the copied worksheet.

44

33
11
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2 Click the Home tab.

3 Click the Delete .

4 Click Delete Sheet.

• You can also right-click the tab 
and then click Delete Sheet.

1 Click the tab of the worksheet 
you want to delete.

Delete a Worksheet

If you have a worksheet that you no longer 
need, you can delete it from the workbook. 
This reduces the size of the workbook, reduces 
clutter in the worksheet tabs, and makes the 
workbook easier to navigate.
It is important to note that you cannot undo a 
worksheet deletion. Therefore, it is always a 

good practice to check the worksheet contents 
carefully before proceeding with the deletion. 
If the worksheet contains any data you need 
but you still want to remove the worksheet, cut 
or copy the data and paste it into another 
worksheet.

Delete a 
Worksheet
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I have several worksheets I need to delete. Do I have to delete them 
individually?
No. You can select all the sheets you want to remove and then run the deletion. 
To select multiple worksheets, click the tab of one of the worksheets, hold down 

, and then click the tabs of the other worksheets.
If your workbook has many worksheets and you want to delete most of them, an 
easy way to select the sheets is to right-click any worksheet tab and then click 
Select All Sheets. Hold down , and then click the tabs of the worksheets 
that you do not want to delete.
After you have selected your worksheets, follow Steps 3 to 5 to delete all the 
selected worksheets at once.

 If the worksheet contains data, 
Excel asks you to confirm that 
you want to delete the 
worksheet.

5 Click Delete.

• Excel removes the worksheet.
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3 Click Options.

1 Click the tab of the worksheet 
you want to customize.

2 Click the File tab.

Change the Gridline Color

You can add some visual interest to your 
worksheet by changing the color that Excel uses 
to display the gridlines. The default color is 
blank, but Excel offers a palette of 56 colors 
that you can choose from.

Changing the gridline color also has practical 
value because it enables you to differentiate 
between the gridlines and the borders that you 
add to a range or a table.

Change the 
Gridline Color
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Can I change the gridline color for all the sheets in my workbook?
Yes. One method would be to follow the steps in this section for each worksheet 
in your workbook. However, an easier method is to first select all the sheets in 
the workbook. To do this, right-click any worksheet tab and then click Select All 
Sheets.
You can now follow Steps 2 to 8 to apply the new gridline color to all your 
worksheets. Once you have done that, right-click any worksheet tab and then 
click Ungroup Sheets to collapse the grouping.

 The Excel Options dialog box 
appears.

4 Click Advanced.

5 Scroll down to the Display 
options for this worksheet 
section.

6 Click the Gridline color .

7 Click the color you want to 
use.

8 Click OK.

• Excel displays the gridlines 
using the color you selected.
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• Excel turns off the gridline 
display.

Turn Gridlines On

• To turn the gridlines back on, 
click Gridlines (  changes 
to ).

Turn Gridlines Off

1 Click the tab of the worksheet 
you want to work with.

2 Click the View tab.

3 Click Gridlines (  changes 
to ).

Toggle Worksheet Gridlines On and Off

You can make your worksheet look cleaner and 
make the worksheet text easier to read by 
turning off the sheet gridlines. When you do 
this, Excel displays the worksheet with a plain 
white background, which often makes the 
worksheet easier to read.

If you find you have trouble selecting ranges 
with the gridlines turned off, you can easily 
turn them back on again.

Toggle Worksheet 
Gridlines On and Off
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• Excel turns off the headings.

Turn Headings On

• To turn the headings back on, 
click Headings (  changes 
to ).

Turn Headings Off

1 Click the tab of the worksheet 
you want to work with.

2 Click the View tab.

3 Click Headings (  changes 
to ).

22

33

11

Toggle Worksheet Headings On and Off

You can give yourself a bit more room to work 
by turning off the worksheet’s row headings — 
the numbers 1, 2, and so on to the left of the 
worksheet — and column headings — the 
letters A, B, and so on above the worksheet.

If you find you have trouble reading your 
worksheet or building formulas with the 
headings turned off, you can easily turn them 
back on again.

Toggle Worksheet 
Headings On and Off
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ChapterChapter 8888
Dealing 
with Excel 
Workbooks
Everything you do in Excel takes place 
within a workbook, which is the standard 
Excel file. This chapter shows you how to 
get more out of workbooks by creating new 
workbooks, either blank or from a template; 
saving and opening workbooks; arranging 
workbooks within the Excel window; and 
finding and replacing text within a 
workbook.
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2 Click New.

1 Click the File tab.

Create a New Blank Workbook

To perform new work in Excel, you need to first 
create a new, blank Excel workbook. Excel 
automatically creates a blank workbook each 
time you start the program, but for subsequent 
files you must create a new workbook yourself.

If you prefer to create a workbook based on 
one of Excel’s templates, see “Create a New 
Workbook from a Template.”

Create a New 
Blank Workbook
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• Excel creates the blank 
workbook and displays it 
in the Excel window.

3 Click Blank Workbook.

4 Click Create.

Is there a faster 
method I can use 
to create a new 
workbook?
Yes. Excel offers a 
keyboard shortcut 
for faster workbook 
creation. From the 
keyboard, press 

+ .

When I start Excel and then open an existing workbook, Excel 
often removes the new, blank workbook that it opened 
automatically. How can I prevent this?
Excel assumes that you want to use a fresh workbook when you start 
the program, so it opens a blank workbook for you automatically. 
However, if you do not make any changes to the blank workbook and 
then open an existing file, Excel assumes you do not want to use the 
new workbook, so it closes it. To prevent this from happening, make a 
change to the blank workbook before opening any existing file.
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2 Click New.

3 Click Sample templates.

• To use an Office Online 
template, click a category 
in the Office.com Templates 
section. Click the template 
you want to use, and then 
click Download.

1 Click the File tab.

Create a New Workbook from a Template

You can save time and effort by creating a new 
workbook based on one of Excel’s template 
files. Each template includes a working 
spreadsheet model that includes predefined 
labels and formulas, as well as preformatted 
colors, fonts, styles, and more.

Excel 2010 offers seven templates, including 
Expense Report, Loan Amortization, and 
Personal Monthly Budget. However, there are 
many more templates available through 
Microsoft Office Online.

Create a New Workbook 
from a Template
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• Excel creates the new 
workbook and displays it 
in the Excel window.

4 Click the template you want to 
use.

• A preview of the template 
appears here.

5 Click Create.

Can I create my own template?
Yes. If you have a specific workbook structure 
that you use frequently, you should save it as a 
template so that you do not have to re-create the 
same structure from scratch each time. Open the 
workbook, click File, and then click Save As. In 
the Save As dialog box, click the Save as type 

 and then click Excel Template. Type a File 
name and then click Save. To use the template, 
click File, click New, and then click My 
Templates.

Can I create a new workbook based 
on an existing workbook?
Yes. This is useful if you want to create a 
new workbook that is the same or similar 
to an existing file. Click File, click New, 
and then click New from Existing. In the 
New from Existing Workbook dialog box, 
click the existing workbook and then click 
Open.
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1 Click the File tab.

2 Click Save ( ).

 You can also click  in the 
Quick Access Toolbar, or you 
can press + .

 If you have saved the document 
previously, your changes are 
now preserved, and you can 
skip the rest of these steps.

 The Save As dialog box 
appears.

 If this is a new document that 
you have never saved before, 
the Save dialog box appears.

3 Click in the File name text box 
and type the name that you 
want to use for the document.

4 Select a folder in which to 
store the file.

5 Click Save.

 Excel saves the file.

Note: To learn how to save a 
workbook in an older Excel 
format, see Chapter 13.

Save a Workbook

After you create a workbook in Excel and make 
changes to it, you can save the document to 
preserve your work.
When you edit a workbook, Excel stores the 
changes in your computer’s memory, which is 

erased each time you shut down your 
computer. Saving the document preserves your 
changes on your computer’s hard drive, so to 
avoid losing your work, you should save a 
workbook as often as is practical.

Save a 
Workbook
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 The Open dialog box appears.

3 Select the folder that contains 
the workbook you want to 
open.

4 Click the workbook.

5 Click Open.

 The workbook appears in a 
window.

1 Click the File tab.

• You can click Recent to see 
a list of your recently used 
workbooks. If you see the file 
you want, click it and then skip 
the rest of these steps.

2 Click Open ( ).

 You can also press + .

Open a Workbook

To view or make changes to an Excel workbook 
that you have saved in the past, you can open 
the workbook in Excel.

If you have used the workbook recently, you 
can save time by opening the workbook from 
Excel’s Recent menu, which displays the most 
recent 22 files you worked with in Excel.

Open a 
Workbook
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3 Click Arrange All ( ).

 The Arrange Windows dialog 
box appears.

1 Open the workbooks you want 
to view.

2 Click the View tab.

Arrange Workbook Windows

You can view two or more workbooks at once 
by arranging the workbook windows within the 
main Excel window. This enables you to easily 
compare the contents of the workbooks. 
Arranging workbook windows also enables you 

to more easily copy or move data among 
workbooks.
Excel offers four view modes for arranging 
workbook windows: Tiled, Horizontal, Vertical, 
and Cascade.

Arrange Workbook 
Windows
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4 Click a view mode (  changes 
to ).

 Tiled arranges the workbooks 
evenly within the Excel 
window.

 Horizontal stacks the 
workbooks one above the 
other.

 Vertical displays the 
workbooks side by side.

 Cascade arranges the 
workbooks in an overlapping 
cascade pattern.

5 Click OK.

• Excel arranges the workbook 
windows.

 This example shows two 
workbooks arranged with the 
Horizontal view mode.

How do I return to viewing one 
workbook at a time?
Click the workbook you want to use, 
and then click the workbook window’s 
Maximize button ( ). This maximizes 
the workbook within the Excel window, 
so you only see that workbook. Excel 
also maximizes the other open 
workbooks, but you only see them if 
you switch to them.

Is it possible to view two different sections of 
a single workbook at the same time?
Yes. Excel enables you to create a second window 
for a workbook, and you can then arrange the two 
windows as described in this section. To create the 
second window, switch to the workbook you want 
to view, click the View tab, and then click New 
Window ( ). Follow Steps 1 to 4 to open the 
Arrange Windows dialog box and select a view 
option. Click the Windows of active workbook 
check box (  changes to ), and then click OK.
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 The Find and Replace dialog 
box appears.

4 Click in the Find what text 
box and type the text you 
want to find.

5 Click Find Next.

1 Click the Home tab.

2 Click Find & Select.

3 Click Find.

Note: You can also run the Find 
command by pressing + .

Find Text in a Workbook

If you need to find specific text in a workbook, 
you can save a lot of time by using Excel’s Find 
feature, which searches the entire workbook in 
the blink of an eye.
In a workbook that has only a small amount of 
data and just a few worksheets, you can usually 

find the data you want fairly quickly. However, 
in a large workbook with multiple sheets, it can 
be time-consuming to find specific text, so 
Excel’s Find feature can help.

Find Text in 
a Workbook
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• Excel selects the next cell that 
contains an instance of the 
search text.

Note: If the search text does not 
exist in the document, Excel 
displays a dialog box to let you 
know.

6 If the selected instance is not 
the one you want, click Find 
Next until Excel finds the 
correct instance.

7 Click Close to close the Find 
and Replace dialog box.

• Excel leaves the cell selected.

When I search for a particular term, 
Excel only looks in the current 
worksheet. How can I get Excel to 
search the entire workbook?
In Excel’s Find and Replace dialog box, click 
Options to expand the dialog box. Click the 
Within  and then click Workbook. This 
option tells Excel to examine the entire 
workbook for your search text.

When I search for a name such as Bill, 
Excel also matches the non-name bill. 
Is there a way to fix this?
In Excel’s Find and Replace dialog box, click 
Options to expand the dialog box. Select the 
Match case check box (  changes to ). 
This option tells Excel to match the search text 
only if it has the same mix of uppercase and 
lowercase letters that you specify in the Find 
what text box. If you type Bill, for example, 
the program matches only Bill and not bill.
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 The Find and Replace dialog 
box appears.

4 In the Find what text box, type 
the text you want to find.

5 In the Replace with text box, 
type the text you want to use 
as the replacement.

6 Click Find Next.

1 Click the Home tab.

2 Click Find & Select.

3 Click Replace.

Note: You can also run the 
Replace command by pressing 

+ .

Replace Text in a Workbook

With Excel’s Replace feature, you can quickly 
and easily substitute one bit of text with 
another throughout a workbook.
Do you need to replace a word or part of a 
word with some other text? If you have several 

instances to replace, you can save time and do 
a more accurate job if you let Excel’s Replace 
feature substitute the text for you.

Replace Text in 
a Workbook
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Is there a faster way to replace every instance of the search text with 
the replacement text?
Yes. In the Find and Replace dialog box, click Replace All. This tells Excel to 
replace every instance of the search text with the replacement text. However, 
you should exercise some caution with this feature because it may make some 
replacements that you did not intend. Click Find Next a few times to make sure 
the matches are correct. Also, consider clicking Options and then selecting the 
Match case check box (  changes to ), as described in “Find Text in a 
Workbook.”

• Excel selects the cell that 
contains the next instance of 
the search text.

Note: If the search text does not 
exist in the document, Excel 
displays a dialog box to let you 
know.

7 If the selected instance is not 
the one you want, click Find 
Next until Excel finds the 
correct instance.

8 Click Replace.

• Excel replaces the selected text 
with the replacement text.

• Excel selects the next instance 
of the search text.

9 Repeat Steps 7 and 8 until you 
have replaced all of the 
instances you want to replace.

0 Click Close to close the Find 
and Replace dialog box.
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Formatting Excel 
Workbooks
Excel offers several settings that enable 
you to control the look of a workbook. 
These include the workbook colors for 
things like text and borders; fonts that 
govern the look of headings and regular 
cell text; and special effects that you can 
apply to charts and graphic objects. You 
can also format workbook colors, fonts, 
and effects all at once by applying a 
workbook theme.
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3 Click Colors ( ).

1 Open or switch to the 
workbook you want to format.

2 Click the Page Layout tab.

Modify the Workbook Colors

You can give your workbook a new look by 
selecting a different color scheme. Each color 
scheme affects the workbook’s text colors, 
background colors, border colors, and more. 
Excel offers more than 20 color schemes.

To get the most out of Excel’s color schemes, 
you must apply styles to your ranges, as 
described in Chapter 5.

Modify the 
Workbook Colors
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Can I create my own color scheme?
Yes, by following these steps:

1 Click the Page Layout tab.

2 Click .

3 Click Create New Theme Colors.

4 For each theme color, click  and then click the 
color you want to use.

• The Sample area shows what your theme colors 
look like.

5 Type a name for the custom color scheme.

6 Click Save.

• Excel applies the color scheme 
to the workbook.

4 Click the color scheme you 
want to apply.

55
66

44
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3 Click Fonts ( ).

1 Open or switch to the 
workbook you want to format.

2 Click the Page Layout tab.

Set the Workbook Fonts

You can add visual appeal to your workbook by 
selecting a different font scheme. Each font 
scheme has two defined fonts: a heading font 
for the titles and headings, and a body font for 
the regular worksheet text. Excel offers more 
than 20 font schemes.

To get the most out of Excel’s font schemes, 
particularly the heading fonts, you must apply 
styles to your ranges, as described in Chapter 5.

Set the Workbook 
Fonts
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Can I create my own font scheme?
Yes, by following these steps:

1 Click the Page Layout tab.

2 Click .

3 Click Create New Theme Fonts.

4 Click the Heading font  and then click the 
font you want to use for titles and headings.

5 Click the Body font  and then click the font you want to use for regular sheet text.

• The Sample area shows what your theme fonts look like.

6 Type a name for the custom font scheme.

7 Click Save.

• Excel applies the heading font 
to the workbook’s headings.

• Excel applies the body font to 
the workbook’s regular text.

4 Click the font scheme you want 
to apply.

44

55
66

77
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3 Click Effects ( ).

1 Open or switch to the 
workbook you want to format.

2 Click the Page Layout tab.

Choose Workbook Effects

You can enhance the look of your workbook by 
selecting a different effect scheme. The effect 
scheme applies to charts and graphic objects, 
and each scheme defines a border style, fill 
style, and added effect such as a drop shadow 
or glow. Excel offers more than 20 effect 
schemes.

To get the most out of Excel’s effect schemes, 
you must apply a style to your chart, as 
described in Chapter 12.

Choose Workbook 
Effects
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• Excel applies the effect scheme 
to the workbook’s charts and 
graphics.

4 Click the effect scheme you 
want to apply.

Can I create a custom effect scheme?
No. Unlike with the color schemes and 
font schemes described earlier in this 
chapter, Excel does not have a feature 
that enables you to create your own 
effect scheme.

Why are all the effect schemes the same color?
The color you see in the effect schemes depends 
on the color scheme you have applied to your 
workbook. If you apply a different color scheme, as 
described in “Modify the Workbook Colors,” you 
will see a different color in the effect schemes. If 
you want to use a custom effect color, create a 
custom color scheme and change the Accent 1 
color to the color you want.
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3 Click Themes ( ).

1 Open or switch to the 
workbook you want to format.

2 Click the Page Layout tab.

Apply a Workbook Theme

You can give your workbook a completely new 
look by selecting a different workbook theme. 
Each theme consists of the workbook’s colors, 
fonts, and effects. Excel offers more than 20 
predefined workbook themes.

To get the most out of Excel’s workbook 
themes, you must apply styles to your ranges, 
as described in Chapter 5; and to your charts, 
as described in Chapter 12.

Apply a Workbook 
Theme
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Can I create my own workbook theme?
Yes, by following these steps:

1 Format the workbook with a color scheme, font scheme, and effect 
scheme, as described in the previous three sections.

2 Click the Page Layout tab.

3 Click .

4 Click Save Current Theme.

 The Save Current Theme 
dialog box appears.

5 Type a name for the custom theme.

6 Click Save.

• Excel applies the theme to the 
workbook.

4 Click the workbook theme you 
want to apply.

55 66
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ChapterChapter 10101010
Analyzing 
Excel Data
You can get more out of Excel by 
performing data analysis, which is the 
application of tools and techniques to 
organize, study, and reach conclusions 
about a specific collection of 
information.

In this chapter you learn how to sort and 
filter a range, apply data validation rules 
to a range, convert a range to a table, 
create a data table, and summarize data 
using subtotals.
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 The Sort dialog box appears.

4 Click the Sort by  and then 
click the field you want to use 
for the main sort level.

5 Click the Order  and then 
click a sort order for the field.

6 To sort on another field, click 
Add Level.

1 Click any cell in the range you 
want to sort.

2 Click the Data tab.

3 Click Sort ( ).

Sort a Range

You can make a range easier to read and easier 
to analyze by sorting the data based on the 
values in one or more columns.
You can sort the data in either ascending or 
descending order. An ascending sort arranges 

the values alphabetically from A to Z, or 
numerically from 0 to 9; a descending sort 
arranges the values alphabetically from Z to A, 
or numerically from 9 to 0.

Sort a 
Range
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• Excel adds another sort level.

7 Click the Then by  and then 
click the field you want to use 
for the sort level.

8 Click the Order  and then 
click a sort order for the field.

9 Repeat Steps 6 to 8 to add 
more sort levels as needed.

0 Click OK.

• Excel sorts the range.

Is there a faster way to sort a range?
Yes, as long as you only need to sort your range 
on a single column. First, click in any cell inside 
the column you want to use for the sort. Click 
the Data tab and then click one of the following 
buttons in the Sort & Filter group:

Click for an ascending sort.

Click for a descending sort.

How do I sort a range using the values 
in a row instead of a column?
Excel normally sorts a range from top to 
bottom based on the values in one or 
more columns. However, you can tell 
Excel to sort the range from left to right 
based on the values in one or more rows. 
Follow Steps 1 to 3 to display the Sort 
dialog box. Click Options to display the 
Sort Options dialog box, select the Sort 
left to right option (  changes to ), 
and then click OK.
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• Excel adds  to each field.

4 Click  for the field you want 
to use as the filter.

1 Click inside the table.

2 Click the Data tab.

3 Click Filter ( ).

Filter a Range

You can analyze table data much faster by 
filtering the data. Filtering a table means that 
you configure a field so that you only view the 
table records that you want to work with. One 
way to do this is to use the AutoFilter feature, 

which presents you with a list of check boxes 
for each unique value in a field. You filter the 
data by activating the check boxes for the 
records you want to see.

Filter a 
Range
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Can I create more sophisticated filters?
Yes, by following these steps:

1 Follow Steps 1 to 4.

2 Click Number Filters.

Note: If the field is a date field, 
click Date Filters; if the field is a 
text field, click Text Filters.

3 Click the filter you want to use.

• Excel filters the table to show 
only those records that have 
the field values you selected.

• Excel displays the number of 
records found.

• The field’s drop-down list 
displays a filter icon ( ).

7 To remove the filter, click 
Clear ( ).

• Excel displays a list of the 
unique values in the field.

5 Click the check box for each 
value you want to see 
(  changes to ).

6 Click OK.

44
22

33 55

4 Type the value you want to use, or use the list 
box to select a unique value from the field.

5 Click OK.
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 The Data Validation dialog box 
appears.

4 Click the Settings tab.

5 In the Allow list, click the type 
of data you want to allow in 
the cell.

6 Use the Data list to click the 
operator you want to use to 
define the allowable data.

7 Specify the validation criteria, 
such as the Maximum and 
Minimum allowable values 
shown here.

Note: The criteria boxes you see 
depend on the operator you 
chose in Step 6.

1 Click the cell you want to 
restrict.

2 Click the Data tab.

3 Click Data Validation ( ).

Set Data Validation Rules

You can make Excel data entry more efficient 
by setting up data entry cells to accept only 
certain values. To do this, you can set up a cell 
with data validation criteria that specify the 
allowed value or values.

Excel also lets you tell the user what to enter 
by defining an input message that appears 
when the user selects the cell.

Set Data Validation 
Rules
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8 Click the Input Message tab.

9 Make sure the Show input 
message when cell is 
selected check box is clicked 
( ).

0 Type a message title in the 
Title text box.

! Type the message you want to 
display in the Input message 
text box.

@ Click OK.

 Excel configures the cell to 
accept only values that meet 
your criteria.

• When the user selects the cell, 
the input message appears.

Can I configure the cell to display a message 
if the user tries to enter an invalid value?
Yes. Follow Steps 1 to 3 to open the Data 
Validation dialog box, and then click the Error 
Alert tab. Make sure the Show error alert after 
invalid data is entered check box is clicked 
( ), and then specify the Style, Title, and Error 
Message. Click OK.

How do I remove data validation from 
a cell?
If you no longer need to use data 
validation on a cell, you should clear the 
settings. Follow Steps 1 to 3 to display the 
Data Validation dialog box and then click 
Clear All. Excel removes all the validation 
criteria, as well as the input message and 
the error alert. Click OK.
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2 Click the Insert tab.

3 Click Table ( ).

Note: You can also choose 
the Table command by pressing 

+ .

1 Click a cell within the range 
that you want to convert to a 
table.

Convert a Range to a Table

You can apply Excel’s powerful table tools to 
any range by first converting that range to a 
table. In Excel, a table is a collection of related 
information with an organizational structure 
that makes it easy to add, edit, and sort data.

A table is a type of database where the data is 
organized into rows and columns: Each column 
represents a database field, and each row 
represents a database record.

Convert a Range 
to a Table
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 The Create Table dialog box 
appears.

• Excel selects the range that it 
will convert to a table.

• If you want to change the 
range, click , drag the 
mouse  over the new range, 
and then click .

4 Click OK.

 Excel converts the range to a 
table.

• Excel applies a table format to 
the range.

• The Table Tools contextual tab 
appears.

• AutoFilter drop-down lists 
appear in each field heading.

5 Click the Design tab to see 
Excel’s table design tools.

How do I add records to the table?
To add a record to the end of the table, click 
inside the table, press +  and then 

+  to move to the last field in the last 
record, and then press . To add a record 
within the table, right-click the record above 
where you want to insert the new record, 
click Insert, and then click Table Rows 
Above.

How do I convert a table back into a 
range?
If you no longer require the table tools, you 
can convert the table back into a regular 
range. Select any cell within the table, click the 
Design tab, and then click Convert to Range 
( ). When Excel asks you to confirm, click 
Yes. Excel removes the AutoFilter drop-down 
lists and hides the Table Tools contextual tab.
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2 Select the range that includes 
the input values and the 
formula.

3 Click the Data tab.

4 Click What-If Analysis ( ).

5 Click Data Table.

1 Type the input values:

 To enter the values in a 
column, start the column one 
cell down and one cell to the 
left of the cell containing the 
formula, as shown here.

 To enter the values in a row, 
start the row one cell up and 
one cell to the right of the cell 
containing the formula.

Create a Data Table

If you are interested in studying the effect a 
range of values has on the formula, you can set 
up a data table. This is a table that consists of 
the formula you are using, and multiple input 
values for that formula. Excel automatically 
creates a solution to the formula for each 
different input value.

Do not confuse data tables with the Excel 
tables that you learned about in “Convert 
a Range to a Table.” A data table is 
a special range that Excel uses to calculate 
multiple solutions to a formula.

Create a 
Data Table
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 The Data Table dialog box 
appears.

6 Specify the formula cell you 
want to use as the data table’s 
input cell:

 If the input values are in a 
column, enter the input cell’s 
address in the Column input 
cell text box.

 If you entered the input values 
in a row, enter the input cell’s 
address in the Row input cell 
text box.

7 Click OK.

• Excel displays the results.

What is what-if analysis?
The technique called what-if analysis is perhaps 
the most basic method for analyzing worksheet 
data. With what-if analysis, you first calculate a 
formula D, based on the input from variables A, 
B, and C. You then say, “What happens to the 
result if I change the value of variable A?”, “What 
happens if I change B or C?”, and so on.

When I try to delete part of the data 
table, I get an error. Why?
The data table results are created as an 
array formula, which is a special formula 
that Excel treats as a unit. This means that 
you cannot move or delete part of the 
results. If you need to work with the data 
table results, you must first select the 
entire results range.
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2 Click the Data tab.

3 Click Subtotal ( ).

1 Click a cell within the range 
you want to subtotal.

Summarize Data with Subtotals

When you need to summarize your data, Excel 
offers a feature that enables you to quickly and 
easily add subtotals to a range of data.
Although you can use formulas and worksheet 
functions to summarize your data in various 
ways, including sums, averages, counts, 

maximums, and minimums, if you are in a 
hurry, or if you just need a quick summary of 
your data, you can get Excel to do most of the 
work for you. The secret here is a feature called 
automatic subtotals, which are formulas that 
Excel adds to a worksheet automatically.

Summarize Data 
with Subtotals
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 The Subtotal dialog box 
appears.

4 Click the At each change in 
 and then click the column 

you want to use to group the 
subtotals.

5 In the Add subtotal to list, 
click the check box for 
the column you want to 
summarize (  changes to ).

6 Click OK.

• Excel calculates the subtotals 
and adds them into the range.

• Excel adds outline symbols to 
the range.

Do I need to prepare my worksheet to use 
subtotals?
Excel sets up automatic subtotals based on data 
groupings in a selected field. For example, if you 
ask for subtotals based on the Customer field, 
Excel runs down the Customer column and 
creates a new subtotal each time the name 
changes. To get useful summaries, then, you 
need to sort the range on the field containing 
the data groupings you are interested in.

Can I only calculate totals?
No. The word “subtotal” here is a bit 
misleading because you can summarize 
more than just totals. You can also count 
values, calculate the average of the values, 
determine the maximum or minimum 
value, and more. To change the summary 
calculation, follow Steps 1 to 4, click the 
Use function , and then click the 
function you want to use for the summary.
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Visualizing Data 
with Excel Charts
You can take a worksheet full of 
numbers and display them as a 
chart. Visualizing your data in 
this way makes the data easier 
to understand and analyze. To 
help you see your data exactly 
the way you want, Excel offers 
a wide variety of chart types, 
including pie charts, column 
charts, and stock charts. Excel 
also offers a large number of 
chart options that enable you to 
add chart titles and data labels, 
control the chart legend and 
gridlines, format the chart layout 
and style, change the chart type, 
and more.
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A chart is a graphic representation of 
spreadsheet data that uses columns, points, 
pie wedges, and other forms to represent 
numbers from a select range. As the data in 

the spreadsheet changes, the chart also changes 
to reflect the new numbers. To get the most 
out of charts, you need to familiarize yourself 
with the basic chart elements.

Examining Chart 
Elements

Category Axis
The axis (usually the X axis) that 
contains the category groupings.

Chart Title
The title of the chart.

Plot Area
The area bounded by the category 
and value axes. It contains the 
data points and gridlines.

Value Axis
The axis (usually the Y axis) that 
contains the data values.

Data Marker
A symbol that represents a 
specific data value. The 
symbol used depends on the 
chart type.

Data Series
A collection of related data 
values. Normally, the 
marker for each value in a 
series has the same pattern.

Data Value
A single piece of data. Also 
called a data point.

Gridlines
Optional horizontal and 
vertical extensions of the 
axis tick marks. These make 
data values easier to read.

Legend
A guide that shows the 
colors, patterns, and 
symbols used by the 
markers for each data series.
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Excel offers 11 different types of charts, 
including column charts, bar charts, line charts, 
and pie charts. The chart type you use depends 
on the type of data and how you want to 
present that data visually. Although you must 

select a particular chart type when you first 
construct your chart, you can quickly and easily 
change to a different chart type later on if you 
need to.

Understanding 
Chart Types

Chart Type Description

Area A chart that shows the relative contributions over time that each data series makes to the whole 
picture.

Bar A chart that compares distinct items or shows single items at distinct intervals. A bar chart is laid out 
with categories along the vertical axis and values along the horizontal axis.

Bubble A chart that is similar to an XY chart, except that there are three data series, and in the third series 
the individual plot points are displayed as bubbles (the larger the value, the larger the bubble).

Column A chart that, like a bar chart, compares distinct items or shows single items at distinct intervals. 
However, a column chart is laid out with categories along the horizontal axis and values along the 
vertical axis.

Doughnut A chart that, like a pie chart, shows the proportion of the whole that is contributed by each value in 
a data series. The advantage of a doughnut chart is that you can plot multiple data series.

Line A chart that shows how a data series changes over time. The category (X) axis usually represents a 
progression of even increments (such as days or months), and the series points are plotted on the 
value (Y) axis.

Pie A chart that shows the proportion of the whole that is contributed by each value in a single data 
series. The whole is represented as a circle (the “pie”), and each value is displayed as a proportional 
“slice” of the circle.

Radar A chart that makes comparisons within a data series and between data series relative to a center 
point. Each category is shown with a value axis extending from the center point.

Stock A chart that is designed to plot stock market prices, such as a stock’s daily high, low, and closing 
values.

Surface A chart that analyzes two sets of data and determines the optimum combination of the two.

XY A chart that shows the relationship between numeric values in two different data series. It can also 
plot a series of data pairs in XY coordinates. (Also called a scatter chart.)
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2 Click the Insert tab.

3 Click a chart type.

1 Select the data that you want 
to visualize in a chart.

• If your data includes headings, 
be sure to include those 
headings in the selection.

Create a Chart

You can create a chart from your Excel 
worksheet data with just a few mouse clicks. 
As shown in “Understanding Chart Types,” 
Excel comes with 11 main chart types. 
However, each of these types has several 
predefined varieties, so in all Excel offers more 
than 70 default chart configurations, which 

means there should always be a type that best 
visualizes your data.
Regardless of the chart type you choose 
originally, you can change to a different chart 
type at any time. See “Select a Different Chart 
Type” later in this chapter.

Create a 
Chart
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Is there a way to create a chart on a separate sheet?
Yes. You can use a special workbook sheet called a chart sheet. If you have not 
yet created your chart, select the worksheet data, right-click any worksheet tab, 
and then click Insert to display the Insert dialog box. Click the General tab, click 
Chart, and then click OK. Excel creates a new chart sheet and inserts the chart.

• Excel inserts the chart.

 The tasks in the rest of this 
chapter show you how to 
configure, format, and move 
the chart.

• Excel displays a gallery of 
configurations for the chart 
type.

4 Click the chart configuration 
you want to use.
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6 Click Axis Titles ( ).

7 Click Primary Horizontal Axis 
Title.

8 Click Title Below Axis.

• Excel adds the title.

9 Type the title.

0 Click .

! Click Primary Vertical Axis 
Title.

@ Click Rotated Title (not 
shown).

• Excel adds the title.

# Type the title.

1 Click the chart.

2 Click the Layout tab.

3 Click Chart Title ( ).

4 Click Above Chart.

• Excel adds the title.

5 Type the title.

Add Chart Titles

You can make your chart easier to read and 
easier to understand by adding one or more 
titles to the chart. For example, you can add a 
chart title, which is a title that appears at the 
top of the chart and is usually a word or short 
phrase that describes the chart data.

You can also add titles to the chart axes. The 
primary horizontal axis title is a title that 
appears below the chart’s category (X) axis; the 
primary vertical axis title is a title that appears 
the left of the chart’s value (Y) axis.

Add Chart 
Titles
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• Excel adds the labels to the 
chart.

1 Click the chart.

2 Click the Layout tab.

3 Click Data Labels ( ).

4 Click the position you want to 
use for the data labels.

Note: Remember that the 
position options you see depend 
on the chart type.

Add Data Labels

You can make your chart easier to read by 
adding data labels. A data label is a small text 
box that appears in or near a data marker and 
displays the value of that data point.
Excel offers several position options for the 
data labels, and these options depend on the 

chart type. For example, with a column chart 
you can place the data labels within or above 
each column, and for a line chart you can place 
the labels to the left or right, or above or 
below, the data marker.

Add Data 
Labels
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22
33

44
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• Excel moves the legend.

1 Click the chart.

2 Click the Layout tab.

3 Click Legend ( ).

4 Click the position you want to 
use for the legend.

Position the Chart Legend

You can change the position of the chart 
legend, which is a box that appears alongside 
the chart and serves to identify the colors 
associated with each data series in the chart. 
By default, the legend appears to the right of 
the chart’s plot area, but you might prefer a 
different location.

For example, you might find the legend easier 
to read if it appears to the left of the chart. 
Alternatively, if you want more horizontal room 
to display your chart, you can move the legend 
above or below the chart.

Position the 
Chart Legend
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6 Click .

7 Click Primary Vertical 
Gridlines.

8 Click the vertical gridline 
option you prefer.

• Excel displays the vertical 
gridlines.

Display Chart Gridlines

1 Click the chart.

2 Click the Layout tab.

3 Click Gridlines ( ).

4 Click Primary Horizontal 
Gridlines.

5 Click the horizontal gridline 
option you prefer.

• Excel displays the horizontal 
gridlines.

You can make your chart easier to read and 
easier to analyze by adding gridlines. 
Horizontal gridlines extend from the vertical 
(value) axis and are useful with area, bubble, 
and column charts. Vertical gridlines extend 
from the horizontal (category) axis and are 
useful with bar and line charts.

Major gridlines are gridlines associated with the 
major units: the values you see displayed on 
the vertical and horizontal axes; minor gridlines 
are gridlines associated with the minor units: 
values between each major unit.

Display Chart 
Gridlines
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• Excel adds the data table 
below the chart.

1 Click the chart.

2 Click the Layout tab.

3 Click Data Table ( ).

4 Click Show Data Table with 
Legend Keys.

• If you prefer not to display the 
legend keys, click Show Data 
Table.

Display a Data Table

You can make it easier for yourself and others 
to interpret your chart by adding a data table. 
A data table is a tabular grid where each row is 
a data series from the chart, each column is a 
chart category, and each cell is a chart data 
point.

Excel gives you the option of displaying the 
data table with or without legend keys, which 
are markers that identify each series.

Display a 
Data Table
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6 Click the chart style you want 
to use.

• Excel applies the style to the 
chart.

1 Click the chart.

2 Click the Design tab.

3 Click Quick Layout ( ).

4 Click the layout you want to 
use.

 Excel applies the layout.

5 Click the Chart Styles .

Change the Chart Layout and Style

You can quickly format your chart by applying 
a different chart layout and a different chart 
style. The chart layout includes elements such 
as the titles, data labels, legend, gridlines, and 
data table. Excel’s Quick Layouts feature 

enables you to apply these elements in 
different combinations with just a few mouse 
clicks.
The chart style represents the colors used by 
the chart data markers and background.

Change the Chart 
Layout and Style
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 The Change Chart Type dialog 
box appears.

4 Click the chart type you want 
to use.

1 Click the chart.

2 Click the Design tab.

3 Click Change Chart Type ( ).

Select a Different Chart Type

If you feel that the current chart type is not 
showing your data in the best way, you can 
change the chart type with just a few mouse 
clicks. For example, you might want to change 
a bar chart to a pie chart or a line chart to a 
stock chart.

As you will see in the Tips on the following 
page, you can also save yourself some work by 
configuring Excel with a new default chart 
type, and by saving the current chart type and 
chart formatting as a template that you can 
reuse later on.

Select a Different 
Chart Type
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• Excel applies the new chart 
type.

 Excel displays the chart type 
configurations.

5 Click the configuration you 
want to use.

6 Click OK.

Can I tell Excel to always use 
a particular chart type each 
time I create a new chart?
Yes, you can configure that chart 
type as the default type for new 
charts. Follow Steps 1 to 5 to 
open the Change Chart Type 
dialog box and select a chart 
type and configuration. Click the 
Set as Default Chart button, 
and then click OK.

Can I save the chart type and formatting so that I 
can reuse it later on a different chart?
Yes. You do this by saving your work as a chart template. 
Follow the steps in this section and in the previous few 
sections of this chapter to set the chart type, titles, labels, 
legend position, gridlines, layout, and style. Click the 
Design tab, click Save as Template ( ), type a name for 
the template, and then click Save. To reuse the template, 
follow Steps 1 to 3, click Templates, click your template, 
and then click OK.
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 Formatting 
Excel Charts
You use Excel charts to visualize worksheet data, and you can make these 
visualizations more eye-catching and more effective by formatting chart elements. 
In this chapter, you first learn 
the general technique for 
formatting any chart elements. 
In the rest of the chapter, 
you learn specific chart 
customization techniques, 
including formatting the chart 
background, customizing a 
chart element’s outline, 
applying special effects to a 
chart element, and applying a 
style to a chart element.
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 The Format dialog box appears 
for the object you selected. 
Here, it is the Format Chart 
Title dialog box.

4 Click a tab.

5 Change the formatting 
options.

6 Repeat Steps 4 and 5 to set 
other formatting options.

7 Click Close.

 Excel applies the formatting.

Format Chart Elements Using the 
Format Dialog Box

1 Click the chart element you 
want to format.

2 Click the Format tab.

• You can also select a chart 
element by clicking the Chart 
Title  and then clicking the 
object.

3 Click Format Selection ( ).

Format Chart Elements

You can customize the look of your chart by 
formatting the various chart elements. These 
elements include the axes, titles, labels, legend, 
gridlines, data series, plot area (the area where 
the chart data appears), and the chart area (the 
overall background of the chart).

You can format chart elements using either the 
Format dialog box or the Ribbon. The rest of 
the sections in this chapter provide you with 
more detail on using the Ribbon commands.

Format Chart 
Elements

14_577639-ch12.indd   20014_577639-ch12.indd   200 3/15/10   2:48 PM3/15/10   2:48 PM



201

Formatting Excel Charts

CHAPTER

12

22

33

11

2 Click the Format tab.

3 Use the Ribbon controls to 
change the formatting options.

Note: Not all of the Ribbon 
controls will be available for each 
chart element.

 Excel applies the formatting.

Format Chart Elements Using the 
Ribbon

1 Click the chart element you 
want to format.

Are there any formatting shortcuts I can use?
Yes. Excel offers several methods you can use to 
quickly open the Format dialog box. If you are 
using your mouse, position  over the element 
you want to format, and then double-click. From 
the keyboard, first click the chart element you 
want to format and then press + . You can 
also right-click the chart element and then click 
Format Element (where Element is the name of 
the element).

How do I know where to click to 
select a chart element?
The easiest way to be sure you are clicking 
the correct element is to position  over 
the object. If  is positioned correctly, a 
banner appears and the banner text 
displays the name of the chart element. 
If the banner does not appear, or if the 
banner displays a chart element name 
other than the one you want to format, 
move  until the correct banner appears.
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• Excel formats the element’s 
background with the color you 
selected.

Apply a Color Fill

1 Click the chart element you 
want to format.

2 Click the Format tab.

3 Click the Shape Fill .

4 Click the color you want to 
apply.

Customize a Chart Element Background

You can add visual interest to a chart element 
by customizing the element’s background, or 
what Excel calls the fill.
Most fills consist of a single color, but you can 
also apply a color gradient, a texture, or even a 
picture. However, you should be careful about 

the background you choose for certain chart 
elements. Since some chart elements — 
particularly the chart area, plot area, value axis, 
and category axis — display data, be sure to 
choose a background that does not make that 
data difficult to read.

Customize a Chart 
Element Background
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How do I use a picture as an element’s background?
Follow these steps:

1 Follow Steps 1 to 3.

2 Click Picture.

3 Click the folder that contains the image file.

4 Click the image file you want to use as the 
background.

5 Click Insert.

Apply a Texture Fill

1 Click the chart element you 
want to format.

2 Click the Format tab.

3 Click the Shape Fill .

4 Click Texture.

5 Click the texture you want to 
apply.

• Excel formats the element’s 
background with the texture 
you selected.

Apply a Gradient Fill

1 Click the chart element you 
want to format.

2 Click the Format tab.

3 Click the Shape Fill .

4 Click Gradient.

5 Click the gradient you want to 
apply.

• Excel formats the element’s 
background with the gradient 
you selected.

33

44

55
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5 Click the Shape Outline .

6 Click Weight.

7 Click the line thickness you 
want to apply.

1 Click the chart element you 
want to format.

2 Click the Format tab.

3 Click the Shape Outline .

4 Click the color you want 
to apply.

Set a Chart Element’s Outline

You can make a chart element stand out by 
customizing the element’s outline, which refers 
to the border that appears around the element, 
as well as to single-line elements, such as 
gridlines and axes.

You can customize the outline’s color, its 
weight — that is, its thickness — and whether 
the line is solid or consists of a series of dots or 
dashes.

Set a Chart 
Element’s Outline
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Can I display my chart with a rounded outline?
Yes. Follow these steps:

1 Click the chart border to select the chart area 
element.

2 Click the Format tab.

3 Click Format Selection ( ).

4 Click the Border Styles tab.

5 Click Rounded corners (  changes to ).

6 Click Close.

• Excel formats the element’s 
outline with the color, weight, 
and style you selected.

8 Click the Shape Outline .

9 Click Dashes.

0 Click the line style you want 
to apply.

66

44

55
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Add a Glow Effect

1 Click the chart element you 
want to format.

2 Click the Format tab.

3 Click the Shape Effects .

4 Click Glow.

5 Click the glow effect you want 
to apply.

• Excel formats the element with 
the glow you selected.

Add a Shadow Effect

1 Click the chart element you 
want to format.

2 Click the Format tab.

3 Click the Shape Effects .

4 Click Shadow.

5 Click the shadow effect you 
want to apply.

• Excel formats the element with 
the shadow you selected.

Add Effects to a Chart Element

You can make your chart elements more 
visually striking by customizing them with 
special effects.
For most chart elements, you can add one or 
more effects, including a shadow, glow, soft 

edges, or bevel. In all cases, however, make 
sure that the effects you apply do not make 
the element more difficult to read or to 
decipher, and that the effects you use do not 
distract the reader from the chart itself.

Add Effects to 
a Chart Element
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The shadow I selected is not very noticeable. How can I get a better shadow effect?
Excel offers several controls that enable you to manually adjust various aspects of the shadow. 
Follow Steps 1 to 4 in “Add a Shadow Effect” and then click Shadow Options. Either use the 
Size spin box to increase the size of the shadow, or use the Distance spin box to increase the 
space between the chart element and the shadow. Click Close when you are done.

Add a Bevel Effect

1 Click the chart element you 
want to format.

2 Click the Format tab.

3 Click the Shape Effects .

4 Click Bevel.

5 Click the bevel effect you want 
to apply.

• Excel formats the element with 
the bevel you selected.

Add a Soft Edges Effect

1 Click the chart element you 
want to format.

2 Click the Format tab.

3 Click the Shape Effects .

4 Click Soft Edges.

5 Click the soft edges effect you 
want to apply.

• Excel formats the element with 
the soft edges you selected.
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2 Click the Format tab.

3 Click the Shape Styles .

1 Click the chart element you 
want to format.

Apply a Style to a Chart Element

You can reduce the time it takes to format 
a chart element by applying a style to that 
element. Excel comes with more than 40 
predefined element styles, each of which is 
a collection of chart formatting features.
Each style includes one or more of the 
following formatting features: a background, 

which is usually either a solid color or a color 
gradient; an outline, which is usually a solid line 
with a color that matches or complements the 
background; and one or more special effects, 
such as a shadow or bevel.

Apply a Style to 
a Chart Element
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How do I remove a style from a chart element?
Unfortunately, Excel does not offer a simple method for removing a style. 
Instead, you must remove the background, outline, and effects individually. 
To begin, click the chart element you want to work with, and then click the 
Format tab.
For the background, click the Shap e Fill  and then click No Fill. For the 
outline, click the Shape Outline  and then click No Outline. For the special 
effects, click the Shape Effects , click Preset, and then click No Presets.

• Excel applies the style.

 Excel displays the Shape 
Styles gallery.

4 Click the style you want 
to apply.
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ChapterChapter 1113333
  Collaborating 
with Other 
People
Although you will most often 
create and edit an Excel 
workbook on your own, you 
may have some workbooks 
that require input from other 
people. For those times when 
you need to collaborate with 
other people on a workbook, 
Excel has the tools to get the 
job done.

In this chapter, you learn 
many ways to collaborate on 
a workbook, including adding 
comments to a cell, sharing a workbook, e-mailing a workbook, and even 
working on a spreadsheet online. You also learn ways to make collaboration safer 
by protecting any data you do not want changed, tracking whatever changes are 
made by others, and accepting or rejecting those changes.
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 Excel displays a comment 
balloon.

• Excel precedes the comment 
with your Excel user name.

4 Type your comment.

5 Click outside the comment 
balloon.

Add a Comment

1 Click the cell you want to 
comment on.

2 Click the Review tab.

3 Click New Comment ( ).

Note: You can also right-click 
the cell and then click Insert 
Comment.

Add a Comment to a Cell

If you have received a workbook from another 
person, you can provide feedback to that 
person by adding a comment to a cell in the 
workbook. A comment is often the best way to 
give feedback because it does not change 
anything on the worksheet itself.

Comments are attached to a particular cell, and 
Excel displays an indicator on any cell that has 
a comment. When you hover your mouse 
pointer over such a cell, Excel displays the 
comment in a balloon.

Add a Comment 
to a Cell
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Can I edit or remove a 
comment?
Yes. To edit an existing comment, 
click the cell that contains the 
comment, click the Review tab, 
click Edit Comment ( ) to open 
the comment in a balloon, and 
then edit the balloon text. To 
remove a comment, click the cell 
that contains the comment, click 
the Review tab, and then click 
Delete ( ).

View a Comment

1 Move the mouse  over 
the cell.

• Excel displays the comment 
in a balloon.

• In the Review tab, you can 
also click Next ( ) and 
Previous ( ) to run through 
the comments.

• In the Review tab, you can 
also click Show All Comments 
( ) to display every comment 
at once.

• Excel adds a comment 
indicator ( ) to the top 
right corner of the cell.

How do I change my Excel user name?
When collaborating, your user name is 
important because it tells other people 
who added the comments. If your current 
user name consists of only your first name 
or your initials, you can change it. Click 
File and then click Options to open the 
Excel Options dialog box. Click the 
General tab and then use the User name 
text box to edit the name. Click OK. Note, 
however, that this does not change your 
user name in any existing comments.
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Sheet dialog box.

4 Make sure the Protect 
worksheet and contents 
of locked cells check box 
is activated ( ).

5 Use the Password to unprotect 
sheet password box to type a 
password, if required.

1 Display the worksheet you 
want to protect.

2 Click the Review tab.

3 Click Protect Sheet ( ).

Protect a Worksheet’s Data

If you will be distributing a workbook to other 
people, you can enable Excel’s options for 
safeguarding worksheet data by activating 
the sheet’s protection feature. You can also 
configure the worksheet to require a password 
to unprotect it.

There are two main methods you can use to 
safeguard worksheet data: You can unlock 
only those cells that users are allowed to edit, 
and you can configure a range to require a 
password before it can be edited.

Protect a 
Worksheet’s Data
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When I protect a worksheet, no 
one can edit any of the cells. Is 
there a way to allow users to 
edit some of the cells?
Yes. This is useful if you have a 
data entry area or other range that 
you want other people to be able 
to edit, but you do not want them 
to alter any other part of the 
worksheet. First, unprotect the 
sheet if it is currently protected. 
Select the range you want to 
unlock, click Home, click Format, 
and then click Lock Cell to turn off 
that option for the selected range.

 If you specified a password, 
Excel asks you to confirm the 
password.

8 Type the password.

9 Click OK.

 If you want to make changes 
to a worksheet, click the 
Review tab, click Unprotect 
Sheet ( ), type the unprotect 
password, and then click OK.

6 Click the check box beside 
each action that you want to 
allow unauthorized users to 
perform (  changes to ).

7 Click OK.

When I protect a worksheet, can 
I configure a range to require a 
password before a user can edit the 
range?
Yes. First, unprotect the sheet if it is 
currently protected. Select the range you 
want to protect, click the Review tab, and 
then click Allow Users to Edit Ranges. 
In the Allow Users to Edit Ranges dialog 
box, click New to open the New Range 
dialog box. Type a title for the range, 
use the Range password box to type a 
password, and then click OK. When Excel 
prompts you to reenter the password, type 
the password and then click OK.
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 Excel displays the Protect 
Structure and Windows 
dialog box.

4 Click the Structure check box 
to protect the workbook’s 
structure (  changes to ).

5 Click the Windows check box 
to protect the workbook’s 
windows (  changes to ).

6 Type a password in the 
Password text box, if 
required.

7 Click OK.

1 Display the workbook you 
want to protect.

2 Click the Review tab.

3 Click Protect Workbook ( ).

Protect a Workbook’s Structure and Windows

You can prevent unwanted changes to a 
workbook by activating protection for the 
workbook’s windows and structure. You can 
also configure the workbook to require a 
password to unprotect it.
You should protect a workbook’s structure 
when you do not want others to perform 

actions such as adding or deleting worksheets; 
you should protect a workbook’s windows 
when you do not want others to perform 
actions such as splitting a window or freezing 
panes. See the Tips on the following page to 
learn what Excel does when you protect a 
workbook’s structure and windows.

Protect a Workbook’s 
Structure and Windows
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What happens when I protect 
a workbook’s structure?
Excel disables most worksheet-
related commands, including 
Insert Sheet, Delete Sheet, 
Rename Sheet, Move or Copy 
Sheet, Tab Color, Hide Sheet, 
and Unhide Sheet. Excel also 
prevents the Scenario Manager 
from creating a summary report.

 If you specified a password, 
Excel asks you to confirm it.

8 Type the password.

9 Click OK.

• If you protected the windows, 
Excel hides the window 
controls.

• If you protected the windows, 
Excel disables many window-
related commands on the 
View tab.

• If you protected the structure, 
Excel disables most sheet-
related commands on the 
sheet shortcut menu.

What happens when I protect a 
workbook’s windows?
Excel hides the window’s Close, Maximize, 
and Minimize buttons. If the workbook is 
not maximized, Excel also disables the 
window borders, which means the window 
cannot be moved, sized, or closed. Excel 
also disables the View tab’s New Window, 
Split, Freeze Panes, and View Side By Side 
commands when the window is active.
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 The Share Workbook dialog 
box appears.

4 Click the Editing tab.

5 Click the Allow changes 
by more than one user 
at the same time check 
box (  changes to ).

6 Click OK.

1 Display the workbook you 
want to share.

2 Click the Review tab.

3 Click Share Workbook ( ).

Share a Workbook with Other Users

You can allow multiple users to modify a 
workbook simultaneously by sharing the 
workbook. Once you have shared a workbook, 
other users can open the workbook via a 
network connection and edit the file at the 
same time.

When you share a workbook, Excel automatically 
begins tracking the changes made to the file. 
For more information on this feature, see “Track 
Workbook Changes” later in this chapter. Note, 
as well, that this task assumes you have saved 
the workbook in a folder that other people can 
access over the network.

Share a Workbook 
with Other Users
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How do I know if other people currently have 
the workbook open?
The Editing tab of the Share Workbook dialog box 
maintains a list of the users who have the workbook 
open. To see this list, follow these steps:

1 Display the shared workbook.

2 Click the Review tab.

3 Click .

 The Share Workbook dialog box appears.

4 Click the Editing tab.

• The Who has this workbook open now list displays the users who 
are currently editing the file.

5 Click OK.

 Excel tells you that it will now 
save the workbook.

7 Click OK.

 Excel saves the workbook and 
activates sharing.

• Excel displays [Shared] in the 
title bar.

 You and users on your network 
can now edit the workbook at 
the same time.

44

55
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 The Highlight Changes dialog 
box appears.

5 Click the Track changes while 
editing check box (  changes 
to ).

• Leave the When check box 
activated ( ) and leave All 
selected in the list.

• To learn more about the Who 
and Where options, see the 
Tips on the next page.

• Leave the Highlight changes 
on screen check box activated 
( ) to view the workbook 
changes.

6 Click OK.

1 Display the workbook you 
want to track.

2 Click the Review tab.

3 Click Track Changes ( ).

4 Click Highlight Changes.

Track Workbook Changes

If you want other people to make changes to a 
workbook, you can keep track of those changes 
so you can either accept or reject them (see 
“Accept or Reject Workbook Changes”). Excel’s 
Track Changes feature enables you to do this.
When you turn on Track Changes, Excel 
monitors the activity of each reviewer and 

stores that reviewer’s cell edits, row and 
column additions and deletions, range moves, 
worksheet insertions, and worksheet renames. 
When you open the workbook later on, you see 
all of these changes onscreen, along with the 
name of each person who made the change.

Track Workbook 
Changes
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Is there a way to avoid having my 
own changes highlighted?
Yes, you can configure the workbook 
to show every user’s changes but your 
own. Follow Steps 1 to 4 to open the 
Highlight Changes dialog box. Click 
the Who check box (  changes to ), 
click the Who , and then click 
Everyone but Me. Click OK to put the 
new setting into effect.

Can I track changes in just part of 
the worksheet?
Yes, you can modify this task so that 
Excel only tracks changes in a specific 
range. Follow Steps 1 to 4 to open the 
Highlight Changes dialog box. Click 
the Where check box (  changes 
to ), click inside the Where range 
box, and then select the range you 
want to track. Click OK to put the 
new setting into effect.

 Excel tells you it will now save 
the workbook.

7 Click OK.

 Excel activates the Track 
Changes feature.

• Excel shares the workbook and 
indicates this by displaying 
[Shared] beside the workbook 
name.

Note: See "Share a Workbook 
with Other Users" to learn more 
about workbook sharing.

15_577639-ch13.indd   22115_577639-ch13.indd   221 3/15/10   2:49 PM3/15/10   2:49 PM



222

22

11

55

33

44

 If your workbook has unsaved 
changes, Excel tells you it will 
now save the workbook.

5 Click OK.

 The Select Changes to Accept 
or Reject dialog box appears.

1 Display the workbook you are 
tracking.

2 Click the Review tab.

3 Click Track Changes ( ).

4 Click Accept/Reject Changes.

Accept or Reject Workbook Changes

After you turn on Excel’s Track Changes 
features (see “Track Workbook Changes”), you 
can then accept or reject the changes that other 
users make to the workbook.
Track Changes enables you to see exactly which 
parts of the workbook others have changed and 

who made each of those changes. Track 
Changes also enables you to accept those 
changes that you think are useful or accurate, 
as well as reject those changes that are not 
needed or that are incorrect.

Accept or Reject 
Workbook Changes
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What happens if I and another user 
make changes that affect the same cell?
In this situation, when you save the 
workbook, Excel displays the Resolve Conflicts 
dialog box, which shows the change you 
made as well as the change the other user 
made. If your change is the correct one, click 
Accept Mine; otherwise, click Accept Other. 
If there are multiple conflicts, you can save 
time by clicking either Accept All Mine or 
Accept All Others.

When I complete my review, should I 
turn off the tracking feature?
Unless you know that other people still 
require access to the workbook, you should 
turn off the tracking feature when your 
review is complete. To do this, click the 
Review tab, click , and then click 
Highlight Changes to open the Highlight 
Changes dialog box. Click the Track 
changes while editing check box 
(  changes to ), and the click OK.

• Leave the When check box 
activated ( ) and leave 
Not yet reviewed selected 
in the list.

• If you only want to review 
changes made by a particular 
user, click the Who check box 
(  changes to ), click the 
Who , and then click the 
user’s name.

6 Click OK.

 The Accept or Reject Changes 
dialog box appears.

• Excel displays the details of the 
current change.

7 Click an action for the change.

• Click Accept to leave the 
change in the workbook.

• Click Reject to remove the 
change from the workbook.

 Excel displays the next change.

8 Repeat Step 7 to review all the 
changes.

• You can also click Accept All 
or Reject All to accept or 
reject all changes at once.
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3 Click Save & Send.

4 Click Send Using E-mail.

 Excel displays the Send Using 
E-mail commands.

5 Click Send as Attachment.

1 Open the workbook you want 
to send.

2 Click the File tab.

Send a Workbook as an E-Mail Attachment

If you want to send an Excel workbook to 
another person, you can attach the workbook 
to an e-mail message and send it to that 
person’s e-mail address. The other person can 
then open the workbook in Excel after receiving 
your message.
Sharing a workbook via e-mail is useful in 
situations where the other user does not have 

access to your network. This enables the 
recipient to examine the workbook, make 
changes to it, and then send the workbook to 
you via e-mail. If you want the other user to 
make changes, consider activating Excel’s Track 
Changes feature, as described in “Track 
Workbook Changes.”

Send a Workbook as 
an E-Mail Attachment
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Are there any restrictions related to sending 
file attachments?
There is no practical limit to the number of 
workbooks you can attach to a message. However, 
you should be careful with the total size of the files 
you send. If you or the recipient has a slow Internet 
connection, sending or receiving the message can 
take an extremely long time. Also, many Internet 
service providers (ISPs) place a limit on the size of 
a message’s attachments, which is usually between 
2 and 5MB.

8 Click Send.

 Outlook sends the message.

 Outlook creates a new e-mail 
message.

• Outlook attaches the workbook 
to the message.

6 Type the address of the 
recipient.

7 Type your message text.

What can I do if the recipient does 
not have Excel?
If the other person does not use Excel, 
you can send the workbook in a 
different format. One possibility would 
be to save the workbook as a Web Page 
(see “Save Excel Data as a Web Page”). 
Alternatively, if your recipient can view 
PDF (Portable Document Format) files, 
follow Steps 1 to 4 to display the Send 
Using E-mail options, and then click 
Send as PDF.
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2 Click File.

3 Click Save As.

1 Open the workbook that 
contains the data you want to 
save as a Web page.

• If you want to save a 
worksheet as a Web page, click 
the worksheet tab.

• If you want to save a range as 
a Web page, select the range.

Save Excel Data as a Web Page

If you have an Excel range, worksheet, or 
workbook that you want to share on the Web, 
you can save that data as a Web page that you 
can then upload to your Web site. The other 
person will not be able to edit the data directly, 
but the user can at least examine the data and 
offer comments.

When you save a document as a Web page, 
you can also specify the title text that appears 
in the browser’s title bar and the keywords that 
search engines use to index the page.

Save Excel Data 
as a Web Page
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Can I save an Excel workbook to my Windows Live SkyDrive?
Yes. Follow these steps:

 The Save As dialog box 
appears.

4 Click the Save as type  
and then click Web Page.

5 Select the folder where you 
want to store the Web page 
file.

6 Click Change Title.

 The Enter Text dialog box 
appears.

7 Type the page title in the 
Page title text box.

8 Click OK.

9 Click Tags and then type one 
or more keywords, separated 
by semicolons.

0 Choose which part of the file 
you want to save as a Web 
page (  changes to ):

• Click Entire Workbook to 
save the whole workbook.

• Click Selection to save either 
the current worksheet or the 
selected cells.

! Click Save.

33

44

55
66

77

1 Sign in to your Windows 
Live account.

2 Open the workbook you 
want to share.

3 Click the File tab.

4 Click Save & Send.

5 Click Save to Web.

6 Click the Web 
folder you want to 
use.

7 Click Save As.

8 Click Save.
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 The Save As dialog box 
appears.

4 Select the folder in which to 
store the new workbook.

5 Click in the File name text box 
and type the name that you 
want to use for the new 
workbook.

6 Click the Save as type . 

1 Open the workbook you want 
to make compatible.

2 Click File.

3 Click Save As.

Make a Workbook Compatible with Earlier Versions of Excel

You can save an Excel workbook in a special 
format that makes it compatible with earlier 
versions of Excel. This enables you to share 
your workbook with other Excel users who do 
not have the most recent versions of the 
program.

If you have another computer that uses a 
version of Excel prior to Excel 2007, or if the 
people you work with use earlier Excel versions, 
those programs cannot read documents in the 
standard format used by Excel 2010 and Excel 
2007.

Make a Workbook Compatible 
with Earlier Versions of Excel
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Can people using Excel 2007 open 
my Office documents?
Yes. The file format used by both Excel 
2010 and Excel 2007 is the same. If 
you only work with people who use 
either or both of these Excel versions, 
then you should stick with the default 
file format — which is called Excel 
Workbook — because it offers many 
benefits in terms of Excel features.

8 Click Save.

 Excel saves the file using the 
Excel 97-2003 Workbook 
format.

7 Click the Excel 97-2003 
Workbook file format.

Which versions of Excel are compatible with the 
Excel 97-2003 Workbook file format?
For Windows, the Excel 97-2003 Workbook file 
format is compatible with Excel 97, Excel 2000, Excel 
XP, and Excel 2003. For the Mac, the Excel 97-2003 
Workbook file format is compatible with Excel 98, 
Excel 2001, and Office 2004. In the unlikely event 
that you need to share a document with someone 
using either Excel 5.0 or Excel 95, use the Microsoft 
Excel 5.0/95 Workbook file format instead.
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 Your Windows Live SkyDrive 
appears.

3 Click the folder that contains 
the workbooks you want to 
share.

1 Log on to your Windows Live 
account.

2 Click SkyDrive.

Collaborate on a Workbook Online

If you have a Windows Live account, you can 
use the SkyDrive online storage feature to store 
an Excel workbook in an online folder, and 
then allow other users to collaborate on that 
workbook using the Excel Web App.

To allow another person to collaborate with you 
on your online workbook, that person must 
have a Windows Live ID. If the person does not 
have a Windows Live ID, he or she can go to 
https://signup.live.com/ to register for a free 
account from Microsoft.

Collaborate on a 
Workbook Online
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How do I know when other people are 
also using a workbook online?
When you open a workbook using the Excel 
Web App, examine the lower right corner of 
the Excel screen. If you see 1 person editing, 
it means you are the only user who is working 
on the file. However, if you see 2 people 
editing, then it means another person is 
collaborating on the workbook with you. To see who it is, 
click the 2 people editing message (•), as shown here.

4 Click More.

5 Click Edit permissions.

 The folder’s Edit Permissions 
page appears.

6 Type the Windows Live e-mail 
address of the person you 
want to collaborate with.

7 Press .

• Windows Live adds the person 
to the list.

8 Click  here and then click 
Can add, edit details, and 
delete files.

9 Click Save.

 Windows Live prompts you 
to send a notification for the 
folder.

0 Type a message to the user.

! Click Send.

 Windows Live sends an e-mail 
message to the user. The user 
clicks the link in that message, 
logs on to Windows Live, and 
can then edit a workbook in 
the shared folder.
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Symbols
+ (addition operator), 113
, (comma), 29, 93
/ (division operator), 113
= (equal sign) in formulas, 4, 112, 114
= (equal-to operator), 113
^ (exponentiation operator), 113
> (greater-than operator), 113
>= (greater-than or equal-to operator), 113
< (less-than operator), 113
<= (less-than or equal-to operator), 113
* (multiplication operator), 113
- (negation operator), 113
( ) (parentheses, and operator precedence), 113
% (percentage operator), 113
+ (plus sign), 113
- (subtraction operator), 113

A
absolute cell reference format, 129
Accounting Number format, 93
active or current cell, 26
adding

background color to worksheet, 90–91
blank worksheet to workbook, 134–135
border to worksheet range, 108–109
chart to worksheet, 5, 188–189
column to worksheet, 48–49
command

to Quick Access Toolbar, 12–13
to Ribbon, 15

comment to cell, 212–213
data to cell, 4, 26–27
Excel icon to Windows 7 taskbar, 7
formula to cell, 4, 114–115
function to formula, 4, 118–119
group to existing Ribbon tab, 14–15
range name to formula, 64, 124–125
record to Excel table, 179
row to worksheet, 48–49
special effect to chart element, 206–207
tab to Ribbon, 14–15
text label to chart, 191
title

to chart, 186, 190
to chart axis, 190

worksheet
template to workbook, 135
to workbook, 134–135

addition
AutoSum feature, 122–123
Sum button, 5, 122–123
SUM function, 120–121, 122, 123

addition operator (+), 113
address, cell

absolute reference format, 129
defined, 24
relative reference format, 129

aligning text
within cell, 84–85
centering across columns, 61, 86–87

analysis of data
converting range to table for, 178–179
creating data table for, 180–181
defined, 170
filtering data for, 174–175
rules for data validation, 176–177
sorting data for, 172–173
summarizing data, 182–183

Apply Names feature, 125
applying

conditional formatting, 98–99
font effect, 80–81
formatting by using AutoFormat feature, 96–97
percentage number format, 93
range name by using Apply Names feature, 125
styles, predefined

to chart, 195, 208–209
to worksheet, 100–101

theme to workbook, 79, 168–169
area chart

description, 187
horizontal gridlines for, 193

arithmetic formula, 113
Arrange Windows dialog box, 154–155
array formula, 181
arrow keys, using to navigate worksheet, 132
ASCII code symbol, 33
attachment, e-mail, sending workbook as, 224–225
AutoComplete feature, 27
AutoFill feature

customizing, 45
invoking, 44

AutoFilter feature, 174–175
AutoFit feature, 103, 105
AutoFormat feature, 96–97
automatic subtotals feature, 182
AutosShape, style, applying to chart element, 208–209
AutoSum feature, 122–123
AVERAGE function, 4, 117
axis

category, 186, 193
formatting, 200–203
value, 186

B
background

adding color to ranges, 90–91
customizing chart element, 202–203

bar chart
description, 187
vertical gridlines for, 193

bevel effect, adding to chart element, 207
blank workbook, creating, 148–149
blank worksheet, adding to workbook, 134–135
body font, 79, 164, 165

16_577639-bindex.indd   23216_577639-bindex.indd   232 3/15/10   2:49 PM3/15/10   2:49 PM



233

formula, 4, 112–113
numbers, 28–29
text, 26–27
time of day, 30–31

filling series, 5, 44–45
formatting, 76–109
inserting special symbol, 32–33
locking, 214–215
merging, 60–61
multiple, calculating SUM, 120–121
new, inserting one or more into existing range, 50–51
nonadjacent

selecting cells, 40
totaling values, 121

protecting data, 214–215
range

adding up row or column using SUM function, 121
aligning text within cells, 84–85
applying style, 100–101
background color, adding, 90–91
border, adding, 108–109
column width, 102–103
converting to table, 178–179
copying, 46, 47
data and formatting from range, 52, 53
data in range but not formatting, 52–53
defined, 24, 38
deleting, 54–55
existing, inserting new cell into, 50–51
filling, 5, 42–45
filtering, 174–175
font and font characteristics, 78–83
formatting, 76–109
locking and unlocking, 214–215
moving, 46, 47
name, changing, 72–73
naming, 64–69
protecting data, 214–215
range name, 74–75
rectangular, 40
referencing in another workbook, 127
referencing in another worksheet, 126–127
row height, 104–105
saving data as Web page, 226–227
selecting, 40–41
sorting, 172–173
tracking changes, 221
transposing rows and columns, 63

rotating text within, 88–89
row

adding up numbers using SUM function, 120–121
changing height, 104–105
defined, 24
deleting, 55
as element of row-and-column spreadsheet format, 5
freezing and unfreezing, 58–59
hiding and unhiding, 56–57
merging cells to create title row, 60–61

bold, applying font effect, 80–81
border

adding to cells and ranges, 108–109
custom, creating, 109
selecting line style, 109

bubble chart
description, 187
horizontal gridlines for, 193

building formulas, 114–115

C
Cascade workbook view mode, 154, 155
category axis, 186, 193
cell

absolute or relative compared to mixed reference formats, 
129

active or current, 26
adding

background color, 90–91
border, 108–109
comment, 212–213
data to, 4, 26–27
formula, 4, 114–115

aligning text within, 84–85
applying style, 100–101
AutoComplete feature, 27
changing

column width, 102–103
font and font characteristics, 78–83
row height, 104–105

columns
adding up numbers using SUM function, 120–121
changing width, 102–103
defined, 24
deleting, 55
as element of row-and-column spreadsheet format, 5
freezing and unfreezing, 58–59
hiding and unhiding, 56–57
multiple, centering text across, 61, 86–87
new, inserting one or more in worksheet, 49
selecting, 41
toggling A–Z headings on and off, 145
transposing with rows, 62–63
width, changing, 102–103

copying and pasting using smart tags, 16–17
data validation rules for, 176–177
defined, 24
deleting

comment, 213
data and formatting, 37, 52, 53
data but not formatting, 36–37
formatting but not data, 37, 53

editing
comment in, 213
data, 4, 34–35

entering
data, 4, 26–31
date, 30–31
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formatting, 200–209
gridlines on, 186, 193, 200–203
inserting into worksheet, 188–189
list of types, 187
removing style effect, 209
saving as template, 197
selecting

chart type, 188–189
data for, 188

chart area
customizing background, 202–203
defined, 200
formatting, 200–201

chart categories, in chart data table, 194
chart legend

defined, 186
formatting, 200–203
positioning, 192

chart (data) series
in chart data table, 194
defined, 186
formatting, 200–203

chart sheet, defined, 189
chart title

adding
to axis, 190
to chart, 190

defined, 186
formatting, 200–203

closing Microsoft Excel, 7
collaborating on a workbook

accommodating earlier Excel version format, 228–229
cell comments, 212–213
online, 230–231
protecting

cell data, 214–215
structure, 216–217

saving data as Web page, 226–227
sending as e-mail attachment, 224–225
setup for, 218–219
tracking changes, 220–223

color
adding to background, 90–91
changing

workbook scheme, 162–163
for worksheet font, 82–83
for worksheet gridlines, 142–143

color scheme, 162–163
Colors dialog box, 91
column

adding up numbers using SUM function, 120–121
changing width, 102–103
defined, 24
deleting, 55
as element of row-and-column spreadsheet format, 5
freezing and unfreezing, 58–59
hiding and unhiding, 56–57

new, inserting one or more in worksheet, 48, 49
selecting, 41
toggling 1, 2, etc., headings on and off, 145
transposing with columns, 62–63

selecting
all cells, 41
range of cells, 40–41

unlocking, 214–215
viewing formula in, 115
wrapping text within, 106–107

cell address
absolute reference format, 129
defined, 24
relative reference format, 129

centering text across columns, 61, 86–87
changing

chart
layout, 195
type of, 196–197

color in worksheet, 82–83, 142–143, 162–163
column width, 102–103
editing

cell data, 4, 34–35
comment in cell, 213
formula, 115

Excel user name, 213
font

characteristics of, 78–83
scheme for, 164–165

range name, 72–73
row height, 104–105
Track Changes feature

accepting or rejecting change, 222–223
Everyone but Me option, 221
limiting task to specific range, 221
resolving change conflict, 223
tracking workbook changes, 220–221
turning off, 223
turning on, 220

width, column, 102–103
chart

adding
special effect to element, 206–207
title, 186, 190

applying style, 195, 208–209
changing

layout, 195
type, 196–197

clicking on element to select, 201
creating

as part of worksheet, 188–189
on separate sheet, 189

customizing
element background, 202–203
element outline, 204–205

defined, 5, 186
element, defined, 186
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Excel options, 20–21
formatting

adding to new row or column, 48, 49
by applying AutoFormat feature, 96–97
chart element, 200–209
clearing from cell, 37, 52, 53
conditional, 98–99
date and time, 30, 31
deleting along with data, 37, 52, 53
filling range without copying, 43
keeping when deleting cell data, 37, 52–53
number, 92–95
predefined, 96–97
workbook, 160–169
worksheet range, 76–109
wrapping text within cell, 106–107

Quick Access Toolbar, 12–13
Ribbon, 14–15
worksheet style, 101

D
data analysis

converting range to table for, 178–179
creating data table for, 180–181
defined, 170
filtering data for, 174–175
rules for data validation, 176–177
sorting data for, 172–173
summarizing data, 182–183

data label
adding to chart, 191
defined, 191

data marker
defined, 186
label for, 191

data point
in chart data table, 194
defined, 186
labeling, 191

data series
in chart data table, 194
defined, 186
formatting, 200–203

data table
comparison with Excel table, 180
creating for use with formula, 180–181
defined, 180
displaying in chart, 194

data type, 25
data validation rules, 176–177
data value, defined, 186
database, spreadsheet as, 5
date

description of data type, 25
entering into cell, 30–31
filtering, 175
formatting options, 30, 31

decimal place, controlling display, 94–95

multiple, centering text across, 61, 86–87
new, inserting one or more in worksheet, 49
selecting, 41
toggling A–Z headings on and off, 145
transposing with rows, 62–63

column chart
description, 187
horizontal gridlines for, 193

comma (,), 29, 93
command, Excel

adding
to Quick Access Toolbar, 12–13
to Ribbon, 15

removing
from Quick Access Toolbar, 13
from Ribbon, 15

comment
adding to cell, 212–213
editing in cell, 213
removing from cell, 213

comparison formula, 113
conditional format

applying, 98–99
defined, 98
multiple, specifying, 99
removing, 99

copying
cell, using smart tag, 16–17
formula, 128, 129
range, 46, 47
worksheet, 138–139

COUNT function, 117
Create Names from Selection dialog box, 69
Create Table dialog box, 179
creating

chart
as part of worksheet, 188–189
on separate sheet, 189

data table, 180–181
PDF file from workbook, 225
range name

automatically, 68–69
manually in New Name dialog box, 66–67

template, 151
title row for worksheet, 60–61
workbook

based on existing workbook, 151
new, blank, 148–149
from template, 150–151

worksheet
based on existing worksheet, 138–139
new, blank, 134–135
from template, 135

Currency format, 92
customizing

AutoFill feature, 45
chart element

background, 202–203
outline, 204–205
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Excel Options dialog box

changing Excel user name, 213
customizing

Excel, 20–21
Quick Access Toolbar, 12–13
Ribbon, 14–15

ways to open, 21
exiting Microsoft Excel, 7
exponentiation operator (^), 113

F
File tab, 8
Fill Effects dialog box, 91
filling of range

AutoFill feature, 44
by creating custom AutoFill list, 45
customized series of values, 45
same data, 42–43
standard series of values, 5, 44–45
without copying original cell’s formatting, 43

fills
adding background color to worksheet range, 90–91
customizing chart element background, 202–203

filtering data, 174–175
financial function, 117
financial symbol, inserting, 32–33
Find and Replace dialog box

finding text, 156–157
replacing text, 158–159

finding text in workbook, 156–157
font

applying effect, 80–81
changing

color, 82–83
default, 79
size, 78–79
typeface, 78–79
workbook scheme, 164–165

creating new workbook scheme, 165
font scheme, defined, 164
foreign character, inserting, 32–33
formatting. See also customizing

adding to new row or column, 48, 49
by applying AutoFormat feature, 96–97
chart element, 200–209
clearing from cell, 37, 52, 53
conditional, 98–99
date and time, 30, 31
deleting along with data, 37, 52, 53
filling range without copying, 43
keeping when deleting cell data, 37, 52–53
number, 92–95
predefined, 96–97
workbook, 160–169
worksheet range, 76–109
wrapping text within cell, 106–107

default buttons, Quick Access Toolbar, 12
default configuration, Ribbon, restoring, 15
default font, changing, 79
Degrees spin box, 88, 89
deleting

cell, 54–55
data from, 36–37
data from range, 52–53

cell formatting
along with data, 37, 52, 53
while keeping data, 37, 53

column, 55
command

from Quick Access Toolbar, 13
from Ribbon, 15

comment in cell, 213
conditional format, 99
range, 54–55
range name, 74–75
row, 55
style effect from chart, 209

displaying
data table in chart, 194
decimal places, 94–95
gridlines

on chart, 193
on worksheet, 144

row and column headings, 145
division operator (/), 113
doughnut chart, defined, 187
drop-down galleries, 11

E
editing. See also changing

cell data, 4, 34–35
comment in cell, 213
formula, 115

effect scheme, choosing, 166–167
e-mail attachment, sending workbooks as, 224–225
entering into cell

data, 4, 26–31
date, 30–31
formula, 4, 112–113
numbers, 28–29
text, 26–27
time of day, 30–31

equal sign (=) in formula, 4, 112, 114
equal-to operator (=), 113
error message alert, 177
Excel. See also specific topics

adding icon to Windows 7 taskbar, 7
commands, 12–13, 15
description, 4–5
quitting, 7
starting, 6–7
version file format compatibility, 228–229
window, 7, 8–9
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H
heading

font for, 79, 164, 165
row and column

toggling 1, 2, etc., on and off, 145
toggling A–Z on and off, 145

height, changing row, 104–105
hiding

selected row or column, 56–57
unhiding row or column, 57

Highlight Changes dialog box, 220–221
Horizontal workbook view mode, 154, 155

I
image, as chart element background, 203
indenting cell text, 85
inserting

chart into worksheet, 188–189
column into worksheet, 48–49
new cell into existing worksheet range, 50–51
nonkeyboard symbol into cell, 32–33
row into worksheet, 48–49

IPMT function, 117
italic, applying font effect, 80–81

J
justifying cell text, 85

K
keyboard shortcuts and techniques

creating
new workbook, 149
range name, 69

entering symbol, 33
font-related, 81
navigating worksheet, 132
range

deleting, 55
selecting, 41

L
label (title)

chart
adding to axis, 190
adding to chart, 190
defined, 186
formatting, 200–203

column
creating range names based on, 68–69
freezing, 58–59
unfreezing, 59

data label, 191
range name

adding to formula, 64, 124–125
Apply Names feature, 125
basing on text label, 68–69

Formula bar
adding data to cell, 4, 26
defined, 4
editing data in cell, 4, 34–35

formulas
absolute cell reference in, 129
adding

to cell, 4, 114–115
function to, 4, 118–119
range name to, 64, 124–125

array-type, 181
building, 114–115
copying, 128, 129
defined, 4, 112
description, 112–113
editing, 115
entering in cell, 4, 112–113
moving, 128
referencing range

in another workbook, 127
in another worksheet, 126–127

relative cell reference in, 129
viewing

formula in cell, 115
result in cell, 114

freezing worksheet row or column, 58–59
Full Screen view, 19
Function Arguments dialog box, 119
functions

adding to formula, 4, 118–119
advantages of, 116
defined, 4, 116
description of, 116–117
financial, 117
listing of, 4, 118
statistical, 117
structure of, 116

FV function, 117

G
galleries, Ribbon, 10–11
glow effect, adding to chart element, 206
Go To dialog box, 71
gradient effect, 91, 202, 203
greater-than operator (>), 113
greater-than or equal-to operator (>=), 113
gridlines

on chart
defined, 186
displaying, 193
formatting, 200–203

on worksheet
changing color, 142–143
toggling on and off, 144
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converting

back to range, 179
range to, 178–179

defined, 178
formatting tabular data, 101
in spreadsheet, described, 5

Microsoft Windows Live
collaborating on workbooks online, 230–231
saving Excel workbooks to SkyDrive, 227

MIN function, 117
minus sign (-), 113
MODE function, 117
moving

formula, 128
range, 46, 47
worksheet, 136–137

multiplication operator (*), 113

N
Name Manager dialog box

changing range name, 72–73
deleting range name, 74–75

naming
range, 64–69
renaming

range, 72–73
worksheet, 133

worksheet, 133
navigating

between workbooks, using range name, 71
within worksheet

keyboard shortcuts and techniques, 132
range name, 70–71

between worksheets, using keyboard shortcuts and 
techniques, 135

negation operator (-), 113
new worksheet, creating, 134–135
nonadjacent cells

selecting, 40
totaling, 121

Normal view, 18, 19
NPER function, 117
numbers

adding up row or column using SUM function, 120–121
decimal place in, 94–95
description of data type, 25
entering into cell, 28–29
filtering, 175
formatting in cell, 92–95
including symbol in, 29
repeating, 29

O
online workbook collaboration, 230–231
opening

cell for editing, 34, 35
Excel Options dialog box, 21

benefits, 64–65
changing, 72–73
creating, 66–67, 68–69
defined, 64
defining, 66–67
deleting, 74–75
ease of use, 64
navigating between workbooks, 71
navigating within worksheet, 70–71

row
creating range names based on, 68–69
freezing, 58–59
unfreezing, 59

text label
adding to chart, 191
creating range name based on, 68–69

worksheet, merging cells to create, 60–61
legend, chart

defined, 186
formatting, 200–203
positioning, 192

less-than operator (<), 113
less-than or equal-to operator (<=), 113
line

page break, previewing, 18, 19
wrapping text within cell, 106–107

line chart
description, 187
vertical gridlines for, 193

Live Preview feature, 11
locking and unlocking cells, 214–215

M
marker, data

defined, 186
label for, 191

mathematical symbol, inserting, 32–33
MAX function, 117
maximizing window, 155
MEDIAN function, 117
merging cells, 60–61
message, error, 177
Microsfot Windows 7

adding Excel icon to taskbar, 7
starting Microsoft Excel, 6–7

Microsoft Excel
adding icon to Windows 7 taskbar, 7
commands, 12–13, 15
description, 4–5
quitting, 7
starting, 6–7
version file format compatibility, 228–229
window, 7, 8–9

Microsoft Excel table. See also data table
adding record to, 179
assigning name to table data, 69
comparison with data table, 180
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protecting
workbook structure, 216–217
worksheet data, 214–215

PV function, 117

Q
Quick Access Toolbar

adding command to, 12–13
customizing, 12–13
default buttons, 12
defined, 8
increasing available space on, 13
moving below Ribbon, 13
Redo button, 12
removing command from, 13
Undo button, 12, 35

quick filter, 175
quitting Microsoft Excel, 7

R
radar chart, defined, 187
range

adding
background color, 90–91
border, 108–109

adding up row or column using SUM function, 121
aligning text within cells, 84–85
applying style, 100–101
changing

column width, 102–103
font and font characteristics, 78–83
name, 72–73
row height, 104–105

converting to table, 178–179
copying, 46, 47
defined, 24, 38
deleting, 54–55

data and formatting from range, 52, 53
data in range but not formatting, 52–53
range name, 74–75

existing, inserting new cell into, 50–51
filling

AutoFill feature, 44
by creating custom AutoFill list, 45
customized series of values, 45
same data, 42–43
series of data values, 44–45
standard series of values, 5, 44–45
without copying original cell’s formatting, 43

filtering, 174–175
formatting, 76–109
locking and unlocking, 214–215
moving, 46, 47
naming, 64–69
protecting data, 214–215
rectangular, 40
referencing

in another workbook, 127
in another worksheet, 126–127

Excel program, 6–7
new worksheet, 134–135
workbook, 153

operand
in Excel formula, 112
function as, 116–117

operators
arithmetic, 113
in comparison formula, 113
defined, 112
order of precedence, 113
symbol, nonkeyboard, inserting, 32–33

orientation, rotating text within cell, 88–89
outline (border)

adding to cells and ranges, 108–109
custom, creating, 109
selecting line style, 109

P
page break, previewing, 18, 19
Page Layout view, 18
parentheses, and operator precedence, 113
password-protecting worksheet, 214–215
pasting

copying
cell, using smart tag, 16–17
formula, 128, 129
range, 46, 47
worksheet, 138–139

moving
formula, 128
range, 46, 47
worksheet, 136–137

PDF file, creating from workbook, 225
percentage

applying number format, 93
entering directly into cell, 29

percentage operator (%), 113
picture, as chart element background, 203
pie chart, defined, 187
pinning Excel icon to Windows 7 taskbar, 7
plot area

defined, 186
formatting, 200–203

plus sign (+), 113
PMT function, 4, 116, 117, 119
point, data

in chart data table, 194
defined, 186
labeling, 191

pop-up help, 21
positioning chart legend, 192
PPMT function, 117
preview

enabling Live Preview feature, 11
page break, 18, 19
turning Live Preview feature off, 11
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removing command from, 15
restoring default configuration, 15
as source of commands for Quick Access Toolbar, 13

rotation, slanting text within cell, 88–89
row

adding up numbers using SUM function, 120–121
changing height, 104–105
defined, 24
deleting, 55
as element of row-and-column spreadsheet format, 5
freezing and unfreezing, 58–59
height, changing, 104–105
hiding and unhiding, 56–57
merging cells to create title row, 60–61
new, inserting one or more in worksheet, 48, 49
selecting, 41
toggling 1, 2, etc., headings on and off, 145
transposing with columns, 62–63

S
Save button on Quick Access Toolbar, 12
saving

Excel data as Web page, 226–227
workbook

in Excel 2010 format, 152
in format compatible with earlier Excel 

version, 228–229
scheme, workbook

color, 162–163
effect, 166–167
font, 164–165

searching for text in workbook, 156–157
securing worksheet data, 214–215
selecting

all cells, 41
chart element, 201
chart type, 188–189
column for displaying sum in status bar, 5, 123
data for chart, 188
keyboard techniques for, 41
nonadjacent cells, 40
range of cells, 40–41

sending workbook as e-mail attachment, 224–225
series

chart (data)
in chart data table, 194
defined, 186
formatting, 200–203

filling automatically, 5, 44–45
shadow effect, adding to chart element, 206, 207
shape style, applying to chart element, 208–209
sharing workbook. See collaborating on a workbook
sheet, chart, 189. See also worksheet
SkyDrive, saving Excel workbook to, 227
smart tag, 16–17
soft edges effect, adding to chart element, 207
sorting worksheet range, 172–173
special symbol, inserting, 32–33

saving data as Web page, 226–227
selecting, 40–41
sorting, 172–173
tracking changes, 221
transposing rows and columns, 63

range name
adding to formula, 64, 124–125
Apply Names feature, 125
basing on text label, 68–69
benefits, 64–65
changing, 72–73
creating

automatically, 68–69
manually in New Name dialog box, 66–67

defined, 64
defining, 66–67
deleting, 74–75
ease of use, 64
navigating

between workbooks, 71
within worksheet, 70–71

RATE function, 117
Redo button, on Quick Access Toolbar, 12
reference format for cell address

absolute or relative, 129
defined, 24

relative cell reference format, 129
removing

cell, 54–55
data from, 36–37
data from range, 52–53

cell formatting
along with data, 37, 52, 53
while keeping data, 37, 53

column, 55
command

from Quick Access Toolbar, 13
from Ribbon, 15

comment from cell, 213
conditional format, 99
range, 54–55
range name, 74–75
row, 55
style effect from chart, 209

renaming
range, 72–73
worksheet, 133

replacing text in workbook, 158–159
Ribbon

adding
command to, 15
new group to existing tab, 14–15
new tab to, 14–15

customizing, 14–15
defined, 8, 9
description, 9
formatting chart element, 200, 201, 202–203
galleries in, 10–11
moving Quick Access Toolbar below, 13

16_577639-bindex.indd   24016_577639-bindex.indd   240 3/15/10   2:49 PM3/15/10   2:49 PM



241

template
creating

new workbook from, 150–151
new worksheet from, 135

new, creating, 151
saving chart as, 197

text
aligning within cell, 84–85
centering across multiple columns, 61, 86–87
description of data type, 25
entering into cell, 26–27
filtering, 175
formatting within cell, 84–85
label

adding to chart, 191
columns (See title, column)
creating range name based on, 68–69
rows (See title, row)

replacing in worksheet, 158–159
rotating within cell, 88–89
searching worksheet for, 156–157
ways to view without wrapping, 107
wrapping within cell, 106–107

theme, workbook, 79, 82, 90, 168–169
Tiled workbook view mode, 154, 155
time and date

description of data type, 25
entering into cell, 30–31
filtering, 175
formatting options, 30, 31

title
chart

adding to axis, 190
adding to chart, 190
defined, 186
formatting, 200–203

column
creating range names based on, 68–69
freezing, 58–59
unfreezing, 59

data label, 191
range name

adding to formula, 64, 124–125
Apply Names feature, 125
basing on text label, 68–69
benefits, 64–65
changing, 72–73
creating, 66–67, 68–69
defined, 64
defining, 66–67
deleting, 74–75
ease of use, 64
navigating between workbooks, 71
navigating within worksheet, 70–71

row
creating range names based on, 68–69
freezing, 58–59
unfreezing, 59

spreadsheet overview, 2, 4–5. See also worksheet
Start menu, Windows, 6–7
starting

cell for editing, 34, 35
Excel Options dialog box, 21
Excel program, 6–7
new worksheet, 134–135
workbook, 153

statistical function, 117
status bar

defined, 8
displaying sum of selected range, 5, 123
Edit indicator, 34

STDEV function, 117
STDEVP function, 117
stock chart, defined, 187
strikethrough, applying font effect, 80–81
style

customizing for worksheet data, 101
deleting style effect from chart, 209
for formatting tabular data, 101
predefined

applying to chart, 195, 208–209
applying to worksheet, 100–101
removing effect from chart, 209

subgalleries, 11
subscript, applying font effect, 80–81
subtotal, summarizing data by using, 182–183
subtraction operator (-), 4, 113
Sum button, 5, 122–123
SUM function, 120–121, 122, 123. See also AutoSum feature
summarizing data, 182–183
superscript, applying font effect, 80–81
surface chart, defined, 187
symbol, nonkeyboard, inserting, 32–33

T
tab, Ribbon, 14–15
tab, worksheet

defined, 24
renaming, 133

table, data
comparison with Excel table, 180
creating for use with formula, 180–181
defined, 180
displaying in chart, 194

table, Excel
adding record to, 179
assigning name to table data, 69
comparison with data table, 180
converting

back to range, 179
range to, 178–179

defined, 178
formatting tabular data, 101
in spreadsheet, described, 5

tabular data, formatting, 96, 101
taskbar, Windows 7, adding Excel icon to, 7
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viewing

multiple workbooks within, 154–155
two sections of single workbook within, 155

worksheet elements, 24
Windows Live

collaborating on workbooks online, 230–231
saving Excel workbooks to SkyDrive, 227

Windows 7
adding Excel icon to taskbar, 7
starting Microsoft Excel, 6–7

Wingdings font, 33
workbook. See also worksheet

adding
blank worksheet to, 134–135
worksheet template to, 135

applying theme to, 79, 168–169
changing

color scheme, 162–163
font scheme, 164–165

choosing effect scheme, 166–167
collaborating on

accommodating earlier Excel version format, 228–229
cell comments, 212–213
online collaboration, 230–231
protecting cell data, 214–215
protecting structure, 216–217
saving data as Web page, 226–227
sending as e-mail attachment, 224–225
setup for, 218–219
tracking changes, 220–223

copying worksheet within, 138, 139
creating

based on existing workbook, 151
from template, 150–151

defined, 24, 146
deleting worksheet, 140–141
formatting, 160–169
moving worksheet within, 136, 137
multiple

arranging windows for viewing, 154–155
copying range between, 47
copying worksheet between, 139
moving range between, 47
moving worksheet between, 137
navigating between by using range name, 71

navigating between worksheets in, 135
new, blank, creating, 148–149
online collaboration using Windows Live SkyDrive, 

230–231
opening, 153
protecting structure and windows, 216–217
referencing range between, 127
replacing worksheet text, 158–159
saving

data as Web page, 226–227
in Excel 2010 format, 152
in format compatible with earlier Excel version, 228–229

text label
adding to chart, 191
creating range name based on, 68–69

worksheet, merging cells to create, 60–61
title bar, 8
toggling

row and column headings on and off, 145
worksheet gridlines on and off, 144

tool tab, 15
total, with Sum button, 5, 122–123
Track Changes feature

accepting or rejecting change, 222–223
Everyone but Me option, 221
limiting task to specific range, 221
resolving change conflict, 223
tracking workbook changes, 220–221
turning off, 223
turning on, 220

transposing rows and columns, 62–63

U
underline, applying font effect, 80–81
undoing

cell edit, 35
data deletion, 37, 53
worksheet deletion, 140

unfreezing row or column, 59
unhiding hidden row or column, 57
unlocking cells, 214–215
user name, in Excel, changing, 213

V
validation rules for data, 176–177
value axis, 186
Vertical workbook view mode, 154, 155
view options, Excel window, 18–19
viewing

formula
in cell, 115
result of, in cell, 114

preview
Live Preview feature, 11
page break, 18, 19

workbooks
multiple, arranging windows for viewing, 154–155
single, separate sections in separate windows, 155

W
Web page, saving Excel data as, 226–227
Webdings font, 33
what-if analysis, 181
width, changing cell, 102–103
window, Excel

basic elements, 8
Full Screen view compared to, 19
view options, 18–19
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inserting
new cell into existing range, 50–51
new row or column, 48–49

moving
range between, 47
within a workbook, 136, 137
between workbooks, 137

navigating
within same sheet by using range name, 70–71
between sheets, 135

new, creating, 134–135
overview, 2, 4–5
page break, 19
protecting data, 214–215
referencing range between, 126–127
renaming, 133
replacing text, 158–159
rotating text within cell, 88–89
saving data as Web page, 226–227
searching for text, 156–157
selecting

all cells, 41
range of cells, 40–41

sorting range, 172–173
tabs

defined, 24
renaming, 133

toggling headings A–Z and 1, 2, etc., on and off, 145
transposing rows and columns, 62–63

wrapping text within cell, 106–107

X
XY charts, defined, 187

searching for text, 157
sending as e-mail attachment, 224–225
tracking changes, 220–223
viewing second section in separate window, 155
window elements, 8, 24
worksheet tabs, 24, 133

worksheet. See also workbook
adding

background color, 90–91
chart to, 5, 188–189
row or column to, 48–49
to workbook, 134–135

aligning text within cells, 84–85
applying style, 100–101
centering text across multiple columns, 61, 86–87
changing

column width, 102–103
font and font characteristics, 78–83
row height, 104–105

collaborating on, 212–231
copying

range between, 47
within a workbook, 138, 139
between workbooks, 139

defined, 2, 8, 24
deleting from workbook, 140–141
editing cell data, 4, 34–35
entering data into cell, 4, 26–31
filtering data, 174–175
formatting overview, 160–169
freezing row or column, 58–59
gridlines on, 142–143, 144
hiding row or column, 56–57
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