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Intermediate Excel covers the following topics: 

 Multiple Sheets 
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 Scenario Manager 

 If() Statements 
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Navigating Multiple Sheets  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Group Sheets 
When you group sheets, anything you do on one sheet happens in the same cell on other sheets in the group.  This 
includes formatting, typing, editing, and deleting.  The tabs of grouped sheets appear white. 
 
 
 
 
 
 
 
 
 
 
 
 
Ungroup Sheets 
To ungroup sheets, either click a tab not in the group or hold Control while clicking sheets in the group. 
 
 

Rename a Sheet 
Double click the 
sheet tab, type a 
name, then press 
Enter. 

Scroll to Sheets 
Click the sheet 
scroll arrows or 
use Control Page 
Up/Down. 

List of Sheets 
Right click a 
scroll arrow to 
get a list of 
sheets. 

Move / Copy a Sheet 
Click & drag a tab 
horizontally to move it.  
(Hold Control while 
dragging to copy it.) 

Insert a Sheet 
Right click a tab and select Insert… 

Move / Copy Sheet to another Workbook 
Right click a tab and select Move or Copy.... 

Delete a Sheet 
Right click a tab and select Delete. 

Non-Contiguous Sheets 
To group sheets that are non-adjacent: 
hold down Control while clicking their 
tabs. 

Contiguous Sheets 
To group adjacent sheets: click the 
leftmost tab in the group, then hold 
Shift and click the rightmost tab in the 
group. 
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Formulas between Sheets (Same File) 

Formulas between separate sheets in the same file are fairly straight forward: simply specify the name of the sheet and 
the cell address separated by an explanation mark (!): 

 =SheetName!CellAddess  
 

Examples: 
 

Formula Effect 

=Sheet2!B3 Returns the value in cell B3 of Sheet2. 

=Sheet2!B3+Sheet3!G12 Adds the value in B3 on Sheet2 to the value in G12 on Sheet3. 

=Sum(Sheet2!B3,Sheet3!G12) Adds the value in B3 on Sheet2 to the value in G12 on Sheet3. 

=Sum(Sheet1:Sheet3!C3) 
Adds the value in C3 of sheet1 to the value in C3 of sheet2 to the value in C3 
of Sheet3.  (In other words, adds all the C3s together from Sheet1 through 
Sheet3.) 

=Sum(Sheet2:Sheet3!B2:B4) The sum of B2,B3, & B4 in Sheet2 plus the sum of B2, B3, & B4 in Sheet3.  

 
 
 
 
 
 
 

Handling Spaces and other Special Characters in Sheet Names 
If a sheet name contains a space, starts with a number, or contains special characters (aside from an underscore), you 
must enclose the sheet name in single quotes. 
 

Formula Effect 

='Tax Table'!B3 Returns the contents in cell B3 of the Tax Table sheet. 

='Tax Table'!B3+'Emp Rate'!G12 
Adds the value in B3 of the Tax Table sheet to the value in G12 of 
the Emp Rate sheet. 

=Sum('Tax Table'!B3,'Emp Rate'!G12) 
Adds the value in B3 of the Tax Table sheet to the value in G12 of 
the Emp Rate Sheet. 

=Sum('Qtr 1:Qtr 4'!C3) 
Adds the C3s from the Qtr1 sheet through the Qtr4 sheet.  (i.e. 
Qtr!1+ Qtr!2+Qtr!3+Qtr4) 

=Sum('Qtr 1:Qtr 4'!B2:B3) 
This adds all the B2s and B3s together from the four quarter 
sheets. (i.e. 'Qtr 1'!B2+'Qtr 1'!B3+'Qtr 2'!B2+'Qtr 2'!B3+'Qtr 
3'!B2+'Qtr 31'!B3+'Qtr 4'!B2+'Qtr 4'!B3) 

 
 
 
 
 
 
 
 
 

Note that if you are new to Excel, the colon ( : ) is a range separator and is used to separate the 
beginning point from the ending point.  For example, B2:B4 means include cells B2, B3, and B4. 
Sheet1:Sheet3 means include Sheet1, Sheet2, and Sheet3.  
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Exercise: Summing Four Sheets 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 

In this exercise, we would like to sum the sales figures 
for our four parks (Anaheim, Orlando, Paris, and 
Toyko) and place their totals in Sheet 5.  Specifically, 
we will sum the numbers in B6:D9 on Sheet1, Sheet2, 
Sheet3, and Sheet4 and display their totals in B6:B9 on 
Sheet5. 
 
We will demonstrate two different formulas you can 
utilize. 

Approach 1: Using Basic Math 
This method will use simply math with no functions.  It would 
be a desirable method if our figures across the different 
sheets did not align or we wanted to mix mathematical 
operators. 
 
1. Open the file:  Excel2010_Intermediate.xlsx 
2. On Sheet5, click in cell B6.   

(We will sum up all the Mouse Ears sold in January.) 
2. Type the formula below and press Enter. 
 

=Sheet1!B6+Sheet2!B6+Sheet3!B6+Sheet4!B6 
 
3. Copy B6 to fill the remaining blank cells (B6:D9). 



© Marshall School of Business  Wayne Wilmeth Excel-Intermediate_07.docx 7/17/12  Page 6 of 36 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Approach 2: Using the Sum() Function Across Multiple Sheets 
If your data is structured the same on all sheets involved and you wish to perform only a single mathematical 
operation then, then you can save yourself some typing by using a function such as Sum().   
(Note that it is no accident that our 5 sheets are structured the same.  Users often design their sheets with 
what we are about to do in mind.  The more sheets involved, the more useful it becomes.)  

1. Open:  Excel2010_Intermediate.xlsx 
2. On Sheet5, click in cell B6.   

(We will sum up all the Mouse Ears 
sold in January.) 

2. Type the formula below and press 
Enter. 

 

=Sum(Sheet1:Sheet4!B6) 
 
3. Copy B6 to fill the remaining blank cells 

(B6:D9). 

TIP:  Approach 1 Using Point and Click 
If you would like to use point and click to get the result in B6 then follow the instructions 
below exactly.  (i.e. don't press enter until you are told to.) 
 
1. On Sheet5 click cell B6. 
2. Type the equals symbol:  = 
3. Click Sheet1 then cell B6 and type a plus sign: + 
4. Click Sheet2 and then cell B6 and type another plus sign:  + 
5. Click Sheet3 and then cell B6 and type another plus sign:  + 
6. Click Sheet4 and then cell B6 and press ENTER. 

TIP:  Approach 2 Using Point and Click 
If you would like to use point and click to get the result in B6 then follow the instructions below exactly.   
1. On Sheet5 click cell B6. 
2. Type the following:  =Sum( 
3. Click Sheet1 and then cell B6. 
4. Hold down your SHIFT key on your keyboard and click the tab for Sheet4. 
5. Press ENTER. 

TIP:  Approach 2 Using Your Keyboard 
If you would like to use keyboard navigation to get the result in B6 then follow these instructions:   
1. On Sheet5 arrow to cell B6 and type:  =Sum( 
2. Press Control Page Up to go to Sheet1. 
3. Arrow to cell B6 and press the period ( . )on your keyboard.  
4. Press Control Shift Page Down until you get to Sheet4. 
5. Arrow to cell B6 and press ENTER. 
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Formulas between Files (Linking) 

Linking allows you to create formulas between completely separate workbooks (i.e. files).   Because linking uses a 
formula, when the data in the file you are linking to changes, the formula will update. The basic grammar of linking is: 
 

=[FileName]SheetName!CellAddress 
 
Examples 

Files in Same Folder:     =[4Parks.xlsx]Sheet1!$E$10   
Files on Different Drive or Folder:  ='N:\Documentation\Excel\Intermediate Excel\[4Parks.xlsx]Sheet1'!$E$10 

  
 

Exercise:  Creating Links Using Point and Click 
If you know the full path to the file you wish to link to you can type it; however, it is typically much faster to open the file 
you are linking to and use the point and click method to create the link formula.  In this example, we wish to display 
each park's grand total (E10) from Excel2010_Intermediate.xlsx in a separate 
file. 
 
1. Open the file Excel2010_Intermediate.xlsx 
2. From the menu, click "File – New – Blank Workbook - Create" to create a 

new file. 
3. In the new file, create the table shown to the right. 
4. Click in cell B2 of the new file. 
5. Type an equals sign (=). 
6. Click Excel on the Windows Task Bar and then click Excel2010_Intermediate.xlsx. 
 
 
 
 
 
 
 
7. Click "Sheet1" (or whatever you renamed it to). 
8. Click cell E10. 
9. Press Enter. 
 
 
 
 
 
 
 
 
 
10. Use the same technique as above to get the totals for the other parks. 
  
 
Issue:  Point and Click Method Not Working! 
For whatever reason, the point and click method does not work if you opened the second file in Excel by starting Excel a 
second time through Window's Start menu.  (i.e. "Start – All Programs – MS Office – Excel").  Therefore, when opening 
the second file, be sure to either double click it or open it using Excel's "File" menu. 
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Avoiding Broken Links 
The linking formula refers to content on a specific sheet, in a specific file, in a specific location.  If you change any of 
these things your formula will return an error.  Therefore, to avoid broken links: 
 

 Don't change the name of a sheet containing the cell you are linking to. 

 Don't change the name of the file containing the cell you are linking to. 

 Don't change the location to the file containing the cell you are linking to. 
 
Note that there are times Excel can adjust your links for you.  It tries to use relative paths (even though it may be listing 
the entire path) and can sometimes adjust but to be on the safe side, follow the three rules above and you shouldn't 
encounter any issues. 
 
 

Updating Links 
When the workbook containing the linking formula and the workbook it is linking to are both open, links update 
automatically.  When you open a file containing links, Excel will ask you weather you wish to update the links of not. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
If there are problems with any of the links, you will get 
the message to the right.  Clicking "Edit Links" opens 
the window below. 
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Range Names 

Range Names allow you to give a cell or group of cells a name of your choosing.  These names can then be used in 
formulas and dialogue boxes.  There are several reasons why you may wish to use range names: 

 More Meaningful – Naming a cell "Total" or "COGS" is a little easier to remember than D25 or G9. 

 Easier when Working between Multiple Sheets – For the reason above, range names make it easier to work 
across multiple sheets. 

 Shorter Formulas – Typing Sum(Data) is a little shorter than typing Sum(B7:G14). 

 Absolute Addresses – Range Names are absolute.  This can help to avoid copy errors. 
 

 

Naming Guidelines 
When naming cells, there are a few rules you will need to be familiar with: 

 Must begin with a Letter - The first letter of the range name must be a letter or underscore. 

 Allowable Characters -  Remaining name characters can be letters, numbers, periods, and the underscore.  Other 
special characters  and spaces are not allowed. 

  No Cell Address Names – Range names cannot have the same name as a cell address (“A1” for example). 

 Single Letter Names – Range names can be one letter long but you cannot use “R” or “C”. 

 Max Characters – The maximum number of characters allowed is 255. 

 Not Case Sensitive – Range named cells are not case sensitive. 

 Duplicate Range Names Same Sheet – You cannot use the same range name more than once on the same sheet.  
However, there is an exception:  if you hold down Control while initially naming non-adjacent cells then you can 
use the same name in the same sheet. 

 Duplicate Range Names on Different Sheets – You can use the same range names on separate sheets; however, 
this can become problematic when performing calculations across different sheets using the these names. 

 Multiple Names for a Range – You can give a cell or range of cell multiple range names. 
 

Functional Guidelines 
 Name Deletion Error – If you use a range names in formulas and later delete the range name, any formulas 

which used the name will display an error..  

 Deleting a Sheet – If you delete a sheet that contains range names, the range names are also deleted. 
 

Methods of Naming Ranges 
There are two methods of creating named ranges but the end result is the same.  
 

Naming Ranges by Typing in the "Name" Box 
This is useful when naming a block of cells. 
 
a. Highlight the cell(s) you wish to name. 
b. Click in the Names box. 
c. Type a name for the range and press ENTER. 
 
 

Naming Ranges by Using Existing Text 
This method allows you to name cells using the text adjacent to 
the cells as the names.  The text can be to the left, right, above, or 
below the cells you wish to name.  The images to the right show 
using the text in cells A2:A5 to name the adjacent cells in B2:B5 
(i.e. B2 will be named USA, B3 will be named Canada, etc.).  It is 
under "Formulas – Create from Selection". 
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Example 1: Using the Name Box to Name Blocks of Cells 
In this example we will name blocks of data in the 4Parks.xlsx file. 
 
1. Open the Excel2010_Intermediate file. 
2. On the sheet for the Anaheim park, 

highlight B6:D9. 
3. Click in the Name box. 
4. Type Cal and press Enter.  
5. Repeat the procedure above to name 

the cells on the remaining four sheets 
as follows: 

 
Orlando Park: name B6:B9  Florida 
Tokyo Park:    name B6:B9  Japan 
Paris Park:    name B6:B9  France 

 

 
If you would like to see if this worked, click the drop down arrow in the upper right 
corner of the Name box.  Any names you have created will be listed.  Further, clicking 
one of the names will take you to the range. 
 
 
 
 
 

6. Go to a blank sheet (sheet 6 for example). 
7. Create the spreadsheet shown. 
 
8. Type the formulas shown below to get each park's total. 
 
 
 
 
 
 
 
 
 
 

9. If you would like to get the grand total of all parks, try this:   =SUM(Cal,Florida,Japan,France) 

 
  
 
 
 
 
 
 
 

TIP:  Use “Tab” to Apply a Selected Range Name 
As you type a range name Excel will display a list of 
existing names and formulas.  To select a name from 
the list, arrow down to highlight it and then press TAB. 
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Example 2: Using Existing Text to Name Ranges 
Being that most users will label the cell that contains a value, this method allows you to name value cells using the 
already existing labels.  In this example, we will name cell B1 "Cost" and cell B2 "Quantity". 
 
Naming the Cells 
1. Go to any blank sheet. 
2. Create the spreadsheet show. 
3. Highlight cells A2:B2. 
4. Click the "Formulas" tab. 
5. Click "Create from Selection". 

 
 
6. Verify that "Left Column" is checked.  (This means that Excel will use the 

labels in the left column to name the cells on the right.) 
7. Click "OK". 
 
Using the Names in a Formula 
8. Click in cell B3. 

9. Type the following and press enter:   =Cost*Quantity 
 
 
 
 
 
 
 

 

Example 3: Name Multiple Cells and Use Intersection Formulas 
In this example we will give the same cell two different names and 
extract a value from the intersection of these two ranges. 
 
1. On any blank sheet, create the spreadsheet shown. 
2. Highlight A1:E3. 
3. Click the "Formulas" tab then "Create from Selection" then "OK". 

 
 
 
 
 
 
 
 
 
 

If you place a space between two intersecting ranges in a formula, Excel will return the value in the intersecting cell. 
 

4. To get Sales in the 3rd Quarter, in a blank cell type: =Qtr_3  Sales (or =Sales  Qtr_3) 

Or the Costs in the second quarter:      =Qtr_2  Costs (or =Costs  Qtr_2) 

Note the underscores in the quarters.  Because range names cannot have spaces, Excel places an underscore where 
spaces are when creating the names.  

Names were created as follows: 
Qtr_1: B2:B3 
Qtr_2: C:C3 
Qtr_2: D2:D3 
Qtr_3: E2:E3 
Sales: B2:E2 
Costs: B3:E3 
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Example 3: Range Names and Absolute Addresses 
When you range name a cell and later use its range name in a formula, the cell’s address is absolute.  This means that if 
you copy the formula to another cell, the parts of the formula that use range names rather than actual cell address will 
not shift. 
 
Example: Range Names Working for Us 
1. Create the spreadsheet shown. 
2. Highlight A2:B6. 
3. Press Control + Shift + F3 
 (or "Formulas – Create from Selection") 

 
 
 
 
 
4. Verify that "Left Column" is selected and click "OK". 
 Excel created the following names: 
   
  
 
 

 
5. In cell B6 try the following to get the Total:  

=Sum(USA:UK)         Note that it did not work. 
=Sum(USA,Canada,Mexico,UK)    This does work. 
=USA+Canada+Mexico+UK     This works too. 

 

6. In C2 type:   =B2/Total 
7. Copy C2 down to B5. 

 
In this case, range names work in our favor.  When we copy the 
formula in cell C2 down, we want to keep dividing by B6 (the “Total”) 
to get each country’s percent of sales. 
 
 
 
 
 

 
 
 

USA  B2 
Canada  B3 
Mexico  B4 
UK  B5 
Total   B6 
 

When specifying the 
Country, be sure to use 
the actual cell address 
(i.e. B2) and not its 
range name (i.e. USA). 
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Example: Range Names Working Against Us 
In the example below we want to add ten dollar to each sale. 

  
 
1. In D2 type the following:   =USA+10 
 
 
 
 
 
 
 
 
 
2. Copy D2 down to D5. 
  
 
 
 
 
 
 
Note that you are getting the same answers.  This is 
because range names are absolute and the country 
stayed "USA".   
 
 
 
 
 
 
To make this formula workable, you would have to use 
the cell’s real address rather than its range name. 
 
3. In D2 type:  =B2+10 
4. Copy D2 down to D5. 
 
You should now be getting the correct answers. 
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Viewing / Editing / Deleting Range Names 
This section covers show to view and manage your range names.  Note that if you delete a range name, any formulas 
using the name you deleted will return an error. 
 
1. Click the "Formulas" tab and then the "Name Manager" button. 
 
You will see a list of all of your named ranges. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Print Range Names 
To print a list of range names and the cells they refer to: 
 
1. Click on a blank sheet. 
2. Click the “Formulas” tab. 
3. Click “Use in Formula” then “Paste names…”. 
4. Click “Paste List”. 
5. Print the sheet the names are pasted to.  
 
 
 
 
 

Delete a Name 
Clicking Delete will delete any selected 
range names on the list.  (Hold Control or 
Shift to select multiple items.) 

Edit 
Click Edit to change the 
name of the selected range 
or the cells in the range. 

New 
New is an additional 
method of creating a 
range name. 

Edit 
You can also redefine the cells 
included in a range here.  

Filter 
Use this to control which 
range names are displayed.  
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Using Named Constants 
A Range Name doesn’t have to refer to a cell address; it can also contain a constant.  For example, if you create a name 
called “LATax” and define it as =.0875, then in a formula you could type:  =10*LATax and excel would return 10.875. 
 
Defining the Constant  
1. Click the “Formulas” menu tab. 
2. Click “Define Name”  (or “Name Manager” then “New”). 
3. Type a “Name” for your constant (e.g. “LATax”). 
4. Select the Scope the name will work within (i.e. a specific 

sheet only or all sheets in the Workbook). 

5. In “Refers to”, type:   =.0875 
6. Click “OK”. 
 
Using the Constant 
1. In a blank cell type:  =10*LATax 

Or create this spreadsheet: 
 
In either case you should get 0.875 
(Meaning the taxes on $10 in LA 
County would be .875 cents.) 
 
 

Using Named Formulas  (Relative) 
When you create a named relative formula, the formulas will grab cells relative to the position of where you are typing 
the formula and how you initially created the named formulas.  The examples below should explain this more clearly. 
 
We wish to create a formula that will multiply the contents of 
the cell above the current position of the cursor by a tax rate 
and then return that result plus the contents of the cell above 
the current position of the cursor (i.e. Price + Taxes). 
 
Creating the Named Formula 
1. Create the spreadsheet shown. 
2. Click in cell B2.  (This is important.) 
3. From the “Formulas” menu tab click “Define Name”.  
4. Type a “Name”.  (This will be used to invoke the formula.) 
5. At “Scope”, specify if the name can be used throughout any 

sheet in the workbook or just on a specific sheet. 
6. Type any desired “Comment”. 

7. In “Refers to:”, type:   =B1*.0875+B1 

8. Click “OK”. 
 
Our formula always grabs the value located one cell above the 
cursor’s current position and substitutes this where the “B1” is 
in our formula.  It does this because when we created our 
formula, our cursor was one cell below the cell we referred to in our formula.  The B1 is just a placeholder not a fixed 
address. 
 
1. Place your cursor in cell B2 and type:  =LATotal  (Excel should return 10.875) 
2. Type 100 in cell C5. 
3. Click one cell below C5 and type: =LATotal  (Excel  should return 108.75) 
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Using Named Abbreviations 
Range name formulas can also be text formulas.  This technique allows you create a short range name that returns a 
long phrase.  For example, you might create a range name called “USC” that returns “University of Southern California”. 
 
Creating the Name 
1. From the “Formulas” menu tab click “Define Name”.  
2. In the “Name” box, type the letters you wish to use as an 

abbreviation.  In this example we typed:  USC 
(You will be typing this name to invoke the full phrase so keep it 
short.) 

3. If desired, type some comments. 
4.  In “Refers to”, type an equals sign and then the phrase you wish to 

return enclosed in quotes.  For example: 

  =”University of Southern California” 
5. Click “OK” then click “Close”.  
 
Using the Name 
To use the named formula, simply type the name you assigned it proceeded by an equals sign and press enter.   
For example:  =USC 
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Goal Seek 

Under the right circumstances, Goal Seek allows you to force a formula to return a desired outcome by changing one of 
the cells used in the formula.  For example,  
 

Rate x Hours = Gross Pay 
$10 x 8hrs = $80 

 
If you wanted Gross Pay to equal $100 rather than $80, you could tell Excel to change either the Rate or the Hours to 
return $100 and it would do the algebra for you. 
 

Characteristics of Goal Seek 
 The cell you are setting to a specific value must contain a formula (e.g. Gross Pay) 

 The cell you allow Excel to change to achieve your goal must contain a value and must be included in the 
formula (e.g. Rate or Hours). 

 Goal Seek can only change one data cell. (e.g.  It can change either Rate or Hours but not both.) 
 
 

Goal Seek Example 1: Finding Overtime Hours  
In this example we wish to know how many 
overtime hours we must work to make our gross 
pay equal to $100 rather than $80. 
 
1. Create the spreadsheet shown to the right. 
 (Gross Pay should be 80.) 
2. Click in cell B5. 
3. Click the “Data” tab. 
 

 
 
 
4. Click “What-If Analysis”. 
5. Click “Goal Seek…”. 
 
 

 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 

6. “Set Cell” is the goal cell and should be B5. 
7. “To Value” is your numeric goal; type 100 
8. “By changing Cell” contains the Overtime Hours and thus the value you 

will change to achieve your goal.  Specify B4. 
9. Click “OK” then “OK” again to keep the answer. 
 
Your Overtime Hours should be 1.333 and your Gross Pay should be $100. 
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Goal Seek Example 2: Finding Loan Amount 
In this example we are considering 
taking out a loan for $500K at 3.9% 
Yearly Interest for 30 Years.  Using the 
formula below we discover that our 
Monthly Payment will be $2,358.34.  
Unfortunately, we can only afford 
$1,750 per month.  What is the largest 
loan amount we can take out? 
 
 
1. Create the spreadsheet above. 

2. In B4 type: =PMT(B2/12,B3*12,B1)   

3. Click in cell B4. 
4.  Click the “Data” tab. 
5. Click “What-If Analysis”. 
6. Click “Goal Seek…”. 
 
 
 
 
 
 
 
 
 
 
 
 
10. Click “OK” and then “OK” again to keep the solution. 
 
 
Your monthly payment should go to -
$1,750 and your Loan Amount should 
have gone to $371,023.53 so you 
could achieve your goal. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7. “Set Cell” is our Monthly Payment and should be B4. 

8. “To Value” is our goal and is negative 1750 

9. “By Changing cell” is the cell we are changing to 
achieve our goal (Loan Amount) and should be B1. 
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Solver 

Solver is similar to Goal Seek in that Excel will return your desired outcome by changing data cells; however, it is much 
more powerful than Goal Seek.  Unlike Goal Seek, Solver can change multiple cells to achieve your desired outcome (e.g. 
you can change both Rate and Hours), utilize constraints (e.g. Overtime Hours can’t be greater than 16.)  It can also 
return a minimum and maximum value.   
 
 

Characteristics of Solver 
 The cell you are setting to a specific value, minimizing,  or maximizing, must contain a formula (e.g. Gross Pay) 

 The cell(s) you allow Excel to change to achieve your goal must be included in the formula (e.g. Rate or Hours).  
Unlike Goal Seek, it can contain a value or a formula.  Note that the formula will be overwritten with a value.) 

 You cannot use Solver across multiple sheets. 
 
 

Loading the Solver Add-in 
Solver comes with Excel but it is an “Add-in” and you may have to add it to your menu.  To check: 
1. Click the “Data” tab.   
2. If you see the “Solver” button on the far right then you are good; otherwise, proceed to step 3. 
3. If you don’t see Solver, then click the “File” tab. 
4. Click “Options” in the lower left. 
5. Click “Add Ins”.  
 
6. Click “Go”. 
 

 
 
7. Check the “Solver Add-in”. 
8. Click “OK”. 
 
Note that you may have to restart Excel to make the Solver button 
appear under the Data tab. 
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Solver Exercise Part 1 - Building our Model 
Our company manufactures two types of golf bags:  Standard and Deluxe.  We make $9 profit off of every Standard bag 
and $15 profit off of every Deluxe bag.  For now, demand is much higher than the number of golf bags we can produce.  
We are constrained by the number of hours each of our departments can work per month.  
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
1. Estimating the Number of bags:    

a. Go to the "Solver" sheet.  
b. In cells C9 and C10 type 10 and 10.   

 
(Note that we don’t have to have anything here but it makes creating our formulas 
less error prone if we have a starting point for the estimated number of bags we are 
making.) 

 
 
 
 

Production Characteristics 
The top two rows show the number of hours it takes one bag to go 
through each department.  For example, it takes a standard bag .7 hours 
in Cutting and Dying, .5hrs in Sewing, 1 hr. in Finishing and .10 hours in 
Inspection and Packaging.  The second row shows the same information 
for Deluxe bags. 

Max Hours per Month 
This row shows the 
maximum hours per 
month each 
department can work.  

Profit per Bag 
This is the 
amount of 
profit we make 
off of each bag.   

Actual Production Hours 
We will use this area to 
calculate the total number 
of hours it takes in each 
department to make a 
given number of bags.   

Bags per Month 
These two cells will 
contain the number of 
Standard and Deluxe 
bags we will be making 
per month.  They are 
our variable cells.   

Total Profit 
We will multiple our Profit 
by the Number of Bags 
made to get our total 
profit.  This is the cell we 
wish to maximize.   
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2. Calculate the Departmental Hours for All Bags: 
 We wish to multiply the number of Standard bags made 

by how long it takes a Standard bag in Cutting and dying 
and then copy right.   

 
 a. In cell D9 type the following and press enter: 

  =$C9*D3 
 
 Note that the $ in front of the C is there so the number of 

bags does not shift right when we copy.  We did not put it 
in front of the 9 because we wish to copy down later and 
we do what that to shift. 

 
 b. Copy D9 to E9, F9, and G9. 
 
 
 
 
 
 
 
 c. Copy D9 to D19, E9 to E10, F9 to F10, and G9 to G10. 
 
 
  
 
 
 
 
 
3. Calculate the Profits 
 We will now multiply our number of bags by the amount of profit we make per bag. 
 
 a. In cell H9 type the following and press enter: =B9*C9 
  This is the total profit for Standard bags. 
 
 
 
 
 
 
 
 b. Copy cell H9 down to cell H10. 
  This is the total profit for Deluxe bags. 
 
 c. Click in cell H11 and type: =H9+H10 
  This is our total profit and the cell we wish to maximize. 
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4. Sum Total Number of Bags made and Hours for Each Department: 
 a. Highlight C11 through G11. 
 
 
 
 
 
 
 
  b. On your keyboard, press   Alt  =   (or click Autosum) 
 
 
 
 
 
 
 
 
 

Solver Exercise Part 2 – Using Solver to Maximize Profit 
Our model is now complete.  If you change the number of bags being made (C9 & C10), the total profit should change 
(H11) as do the number of hours each department works (D11:G11).  We need to tell Solver about the following: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Set Objective Cell 
This contains our total profit 
and is the cell we are 
attempting to maximize.  It 
contains a formula that 
includes the number of bags 
being made. 

Variable Cells 
These cells contain the 
number Standard and 
Deluxe bags we are 
making.  Solver will be 
adjusting the contents of 
these cells to maximize 
our profit. 

Constraint Cells 
These cells contain the total 
number of hours each 
department works given the 
number of bags being made.  
Each one must be less than the 
Max hours given in the table 
above.  

Constraint Cells 
These cells contain the maximum number of hours each department 
can work per month.  They are used in part of our constraint. 
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3. Set Objective 
This is the cell we are 
attempting to maximize 
and should be H11. 

4. To: 
Select “Max”. 

5. Set Variable Cells 
These are the cells 
solver is allowed to 
change to 
maximize our 
profit.  Select 
C9:C10. 

6. Set Constraints 
These are our hourly 
constraints that 
prevent us from 
making unlimited 
bags.   
a. Click the “Add” 

button and see 
below. 

 
1. Click in cell H11. 
2. Click the “Data” tab and then “Solver”.   
 
 

 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
 

6b. Specify that  
D11 <=D5  

 
6c. Click “Add”. 
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6d. Specify that  
E11 <=E5  

 
6e. Click “Add”. 

6f. Specify that  
F11 <=F5  

 
6g. Click “Add”. 

6h. Specify that  
G11 <=G5  

 
6i. Click “Add”. 

6j. Specify that Cell 
Reference has 
C9:C19. 

6k.  Set the operator 
to “int”.   
(This prevents 
numbers with 
decimals.) 

 
6l. Click “OK”. 
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9. Click “Solve”. 
 
 
10. Solver should find a solution.  To 

keep the solution click “OK”. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7. Make Unconstrained Variables Non-Negative 
Checking this specifies that all decision variable cells without stated lower limits should be given 
lower limits of zero. 

8. Select a Solving Method: Select Simplex LP (GRG Nonlinear works too) They are described below: 
Simplex LP – Use this for linear models.  (Linear models create straight lines.  If your equations 
contain no exponents, logs, or absolute values then it is probably a linear model.) 
GRG Nonlinear Engine – Use this for smooth nonlinear models.  (Nonlinear functions often involve 
variables that are raised to a power or multiplied or divided by other variables.  They may also use 
transcendental functions such as exp, log, sine and cosine. 
Evolutionary – Select the Evolutionary engine for non-linear models that are not smooth. 
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Scenario Manager 

Scenario Manger allows you to take multiple snapshots of your data that you can save and return to at any time.  You 
can also display the different snapshot scenarios in a side-by-side comparison.  Note that you cannot use Scenario 
Manager with values across multiple sheets.  In this example, we will compare different car purchase options.   
 
1. Create the spreadsheet shown below. 

 
 

About the Changing Cells 
When using Scenario Manager, you name a scenario, specify the 
cells whose values you will be changing, and then specify the values.  
In most cases, your changing cells will always contain values or 
labels but not formulas.  (The changing cells can contain formulas 
but because Scenario Manager will replace the formulas with values 
or labels and thus your model may no longer be useful.) 
 
In our example, our changing cells are all of our value cells and are 
indicated in the image to the right.  We will be changing Auto Model, 
Price, Down Payment, Yearly Rate, and Loan Years. 
 
2. Click the “Data” tab in the menu. 
3. Click “What-If Analysis” then “Scenario Manager…”. 
 
 
 
 
 

4. Click the “Add” button to create a new scenario.   
5. Type a name for your first scenario in “Scenario name”. 
 (BMW 325i in this example.) 
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9. Click the floating expand button to return  
to the dialogue box.  

We now need to specify the cells whose content 
we will be changing. 
 
6. Click the collapse button for “Changing Cells”. 
7. Click cell B1. 
8. Hold Control and click B2, B5, B7, and B8.  

The dialogue box shown to the right will open.  It is in this 
box that you will type your new values for the cells 
indicated.   
 
10. Click “OK” to accept the existing values. 

You have just created your first scenario.  You can 
create more by clicking the “Add” button and then 
switch between the different scenarios by selecting 
the scenarios from the list and then clicking “Show”. 
 
However, in the image above you will notice that cell 
addresses are listed.  Using Scenario Manager will be 
easier if we replace those with more descriptive 
labels.  We can do this by assigning range names to 
the changing cells. 
 
11. Click “Close” to close Scenario Manager. 
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Using Range Names 
We will assign range names to B1, B2, B5, B7, and B8 using 
the labels to their lefts. 
 
12. Highlight the ranges as shown:  A1:B2, A5:B5, A7:B8 

(Hold Control to select multiple non-adjacent cells.)  
 (Note that it doesn’t look like A7 is selected but it is.) 
 
13. Click the “Formulas” menu tab. 
14. Click “Create From Selection”. 
 
15. Check only “Left column” and then click “OK”. 
 
 
 
 
 
 
 
 
 
 
 
Creating More Scenarios 
Now that we have created range names, making more 
scenarios will be easier. 
 
16. Click the “Data” menu tab. 
17. Select “What-if Analysis” and then “Scenario Manager”.  
18. Click the “Add” button to create another scenario.  
19. Type a name for the new scenario (e.g. Lexus ES). 
 
Note that there is no need to change the Changing Cells.  We 
will use the same changing cells as our first scenario. 
 
20. Click “OK”. 
 
(Note the display of labels rather than cell addresses.) 
 
21. Input the Lexus data: 
 Auto Model: Lexus ES, Price: 40000, Down Payment: 4500, 

Yearly Rate: .025, Loan Years: 4 
 
At this point you can click “Add” to make more scenarios or you 
can click “OK” to view all of your scenarios. 
 
22. Click “OK”. 
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Switching Between Scenarios 
To make your spreadsheet display the data saved in a scenario, there are two steps: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Edit a Scenario 
a. Click the name of the scenario. 
b. Click the “Edit” button. 
 

Delete a Scenario 
a. Click the name of the scenario. 
b. Click the “Delete” button. 
 

Display Scenarios Side-by-Side 
To display your scenarios side-by-side: 
1. Open Scenario Manager (Data – What-if Analysis – Scenario Manager). 

2. Click the “Summary” button.  
3. Click the collapse button for “Results Cell” and select “B9.  (This will be displayed below all of our scenarios.)  
4. Click “OK”.  
 
 
 
 
 
 
 
 
 
 
 
 

a. Click the name of 
the scenario 
whose data you 
wish to display. 

b. Click “Show”. 
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Excel will display your changing cells and the results cells for each scenario in a side-by-side comparison. 
 

 
Note that our Yearly Rate for Lexus ES displays as 3% but it is really 2.5%.  This can be easily changed with formatting. 
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IF() Statements 

“If” logic allows a formula to return different results based upon whether a condition is true or false.  For example, you 
can have a formula that divides a loan amount by 2 but only if the loan amount is greater than 10,000.  While there are 
several methods of creating “If” logic in Excel, this section covers how to create “If” logic using Excel’s IF() function.   
 
The IF() function is made up of three parts:  A Condition section that contains an equation that evaluates to either true 
or false; a True section whose content is only returned if the Condition was true; and a False section whose content is 
only returned if the Condition  was false.  For example:  If Loan Amount is greater than 10,000, then return the Loan 
Amount/2; otherwise, return zero.  The syntax of an IF() statement is below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Example 1: Returning Values or Cell Addresses 
In this example, we have a list of our employee’s names and their total hours for the day.  Of their total hours, we wish 
to list anything less than or equal to 8 hours in column C and any overtime hours in column D. 
 
1. In cell C2 type: 

 =IF(B2>8,8,B2) 
2. Copy the formula down. 
 You shouldn’t have any value in 

column C greater than 8. 
 
To get Overtime hours: 
3. In cell D2 type: 

 =IF(B2>8,B2-8,0) 

4. Copy the formula down.  You 
should have any remaining 
overtime hours. 

 
IF(B2>8,8,B2) This states that if what is in B2 is greater than 8, then return an 8; otherwise, return what is in cell 

B2. 
IF(B2>8,B2-8,0) This states that if what is in B2 is greater than 8, then subtract 8 from B2; otherwise, return zero. 

Condition 
This is an equation that produces 
either a True or False result.  It can use 
cell addresses, values, labels, formulas, 
range names, and functions.  

Examples: 
A2>=B10 
A2<100 
Average(B1:B10)<500 
B3=”Leased” 

 G1<>H6 
 A1+G6*(100*F9)=1000 
 IsBlank(A1) 
 AND(B1>5,G10=”Sold”,F4>20) 
 

=IF(Condition,True,False) 

True 
If the Condition evaluates to True, the 
code in this section is returned.  It can 
contain a label, value, cell address, 
formula, function, or range name.  

Examples: 
“VIP” 
100 
A10 
B3-B9*10 
Average(A1:A10) 

 
 

False 
If the Condition evaluates to False, the 
code in this section is returned.  It can 
also contain a label, value, cell 
address, formula, function, or range 
name.  

Examples: 
“VIP” 
100 
A10 
B3-B9*10 
Average(A1:A10) 
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Example 2: Returning Text or Using Text as a Criteria 
When referring to a cell containing text or you wish to return text (except for cell addresses), the text must be enclosed 
in quotes.  In this example, we wish to subtract 10k from the list price of any address in Zone “A”.  All other prices should 
be listed as “Not on Sale”. 

 
 
  
 
 
 
 
 
 
 

1. Go to the “If_Text” sheet. 

2. in cell D2 type: =IF(C2="A",B2-10000,"Not on Sale") 

3. Press Enter and copy the formulas down. 
 
This states:  If the Zone (C2) is "A", then subtract 10,000 from the List Price (B2); otherwise, return "Not on Sale". 
 
 
 

Example 3: Nesting Functions 
Any of the three sections of an IF() function can contain functions.  In this example, if the profit of a move is greater than 
the average profit we wish to return the word "Buy"; otherwise, we wish to return the word "Lease".  When doing this 
one, be sure to make the average range absolute or you will get the wrong answers. 
 
 
 
 
 
 
 
 
 
 
 
 
 
1. Go to the “If_Avg” sheet. 

2. in cell C2 type: =IF(B2>Average(B$2:B$10),"Buy","Lease") 

3. Press Enter and copy the formulas down. 
 
 

Alternative Solution:   Range Name Profit Area B2:B10 
Try this again but first give B2:B10 the range name of:  Profit 
It has the advantage of not having to worry about the absolute addresses. 
 

The new formula would be: =IF(B2>Average(Profit),"Buy","Lease") 
 
 

Don't type a comma when typing 
the 10,000.  IF() will think you are 
going to the next section. 
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Example 4: Nested If Statements 
A single IF() statement allows for two possible outcomes, but what if there are more possibilities?  In this example if an 
address is in Zone A, we wish to knock 10K of the list price; Zone B gets 5K knocked off the list price, and any other zone 
gets 1K knocked off the list price.  These are three possible outcomes.  To solve this, we will use nested IF() statements. 

 
A nested IF() statement involves placing an additional IF() functions either in the True or False section of the first IF() 
function.  (I see the second IF() function placed in the False section the most often.  This allows you to create multiple 
possibilities but you can also place it in the True section.  Placing the second IF() in the True section is one method of 
creating an "AND" condition; however, I find using the AND() function a less confusing approach.) 
 
1. Go to the "Nested_If" sheet. 

2. In D2 type: =IF(C2="A",B2-10000,IF(C2="B",B2-5000,B2-1000)) 

3. Press Enter and copy the formula down. 
 
  
 
 
 
 
 
 
 
 
 
 
 
What is important to understand about the formula above is that the second IF() statement is in false section of the first 
if statement and therefore only gets read if the first if statement is false.  In English, this would read: 

If the Zone is A, then subtract 10K from the List price; otherwise, if the Zone is B, subtract 
5K from the list price; otherwise, subtract 1K from the list price. 

 
Here is an example that assigns an A, B, C, D or F to students based on a standard curve: 

=IF(B2<60,"F",IF(B2<70,"D",IF(B2<80,"C",IF(B2<90,"B","A")))) 
Going the other way also works.  

=IF(B2>89,"A",IF(B2>79,"B",IF(B2>69,"C",IF(B2>59,"D","F")))) 
 
What is important to understand is that Excel reads from left to right and stops reading the 
statement as soon as it finds a match.  You can nest up to 7 IF() statements but if you find 
yourself using any more than three you might wish to consider using VLookup() or an array 
function.  

=IF(C2="A",B2-10000,IF(C2="B",B2-5000,B2-1000)) 

Condition 2 Condition 2 
True 

Condition 2 
False 

Condition 1 Condition 1 
True 

Condition 1 
False 
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Example 4: Nesting IF() to Create an "AND" Condition 
As mentioned above, you can create an "AND" condition by placing the second IF() statement within the "True" section 
of the first IF() statement.  In the example below, if a movie made over 75 million AND it was released after June 1, 1993, 
we wish to purchase it; otherwise, we wish to lease it.  To accomplish this with nested IF() statements, you would: 
 
1. Click the "IF_Nested_AND()" sheet. 

2. In D2 type:  =IF(B2>75000000,IF(C2>DATE(1993,6,1),"Purchase","Lease"),"Lease") 
3. Press Enter and copy down. 
 

 
 

=IF(B2>75000000,IF(C2>DATE(1993,6,1),"Purchase","Lease"),"Lease") 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Example 5: Using AND() to Create Multiple Conditions: 
AND() is a fairly simple function to use:  You give it multiple conditions and if every one of them is true, it returns true 
but if any one of them is false, it returns false.  Because AND() returns either True or False, you can place it in the 
Condition section of an IF() statement to determine whether IF()'s true or false section will activate. 

Syntax of the AND() Function:    =AND(Condition1,Condition2,Condition3, …) 
Syntax in an If() Statement using AND():   =IF(AND(Condition1,Condition2,Condition3,…),True,False) 

 
Here is the same example as above but this time we are using AND() in the condition section of our IF() statement: 
 

=IF(AND(B2>75000000,C2>DATE(1993,6,1)),"Purchase","Lease") 
 
 
 
 
 
 
 

Condition 1 

Condition 1 
True 

Condition 1 
False 

Condition 2 Condition 2 
True 

Condition 2 
False 

You may find this fairly complicated.  
For this reason, I almost always use the 
"AND()" function to create an if() 
statement with multiple conditions. 

IF() Condition Section 

Result when 
AND() returns 

True. 

Result when 
AND() returns 

False. 

AND() Condition 1 AND() Condition 2 
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Example 6: "OR" Conditions 
To create an "OR" condition in an IF() statment, use the "OR()" function.  Like AND(), it returns either "True" or "False" 
but for OR() to return true, only one of its conditions has to be true.  OR() only returns false when all of its conditions are 
false. 
 
Syntax of the OR() Function:    =OR(Condition1,Condition2,Condition3,…) 
Syntax in an IF() Statement Using OR(): =IF(OR(Condition1,Condition2,Condition3,…),True,False) 
 
In this example we wish to display "Domestic" if the MFG is Ford or Chrysler and "Foreign" if the MFG is anyone else. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
1. Go to the "IF_OR()" sheet. 

2. In C2 type:  =IF(OR(A2="Ford",A2="Chrysler"),"Domestic","Foreign")  
3. Press enter and copy down.  
 

=IF(OR(A2="Ford",A2="Chrysler"),"Domestic","Foreign") 
 
 
 
 
 

IF() Condition Section 

Result when 
OR() returns 

True. 

Result when 
OR() returns 

False. 

OR() Condition 1 OR() Condition 2 


