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Hi,

My name is Puneet . I’m a 26 years old guy from India.

I’m on a mission.

And, my mission is to help people & learn 
Microsoft Excel.

So, that’s why I am helping people who want to learn 
Microsoft Excel. 

I have founded ExcelChamps to reach more & more 
people.

I have created this E-Book with love, for people who 
want to drive their skills to next level. 

With

Puneet Gogia

Read My Story

ExcelChamps ©

http://excelchamps.com/blog/about-us/


Super Useful 
Excel Shortcuts
80 Daily Use Excel Keyboard Shortcuts



Basic

Key Description

Ctrl + Up Arrow Move to the top end.

Ctrl + Down Arrow Move to the down end.

Ctrl + Right Arrow Move to the Right end.

Ctrl + Left Arrow Move to the Left end.

Ctrl + C Copy

Ctrl + V Paste

Ctrl + X Cut

Ctrl + S Save

Ctrl + P Print

Ctrl + F4 Save As

Ctrl + Z Undo last action

Ctrl + Y Redo last action

Ctrl + A Select All

Ctrl + Spacebar Select Entire Column

Shift + Spacebar Select Entire Row

Delete Delete

F2 Edit Cell

Esc Close Edit Mode

F1 Help

Menu Option Right Click Menu

Quick Tip: Try to use as more as shortcut keys you can.
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Formatting

Key Description

Ctrl + B Bold

Ctrl + I Italic

Ctrl + U Underline

Ctrl + ! Open Format Menu

Ctrl + Shift + @ Format As Time Value

Ctrl + Shift + # Format As Date Value

Ctrl + Shift + $ Format As Time Value

Ctrl + Shift + % Format As Percentage Value

Alt H O I / A Adjust Cell Width to content

Alt H B A Apply Border

Alt H F C Change Font Color

Alt H H Change Cell Color

Alt H A C Align text To Center

Alt H M C Merge Cell

Alt H W Wrap Text

Alt H F F Change Font Style

Alt H F S Change Font Size

Alt H L N Add Conditional Formatting

Alt H T Format as Table

Alt H J Style Cell

Quick Tip: Replace your 10 most used options with shortcuts.
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Insert & Layout

Key Description

Alt N V Insert Pivot Table

Alt N T Insert Table

Alt N P Insert Picture

Alt N S H Insert Shape

Alt N S C Insert Charts

Alt N I Insert Hyperlink

Alt N X Insert Text Box

Alt N J Insert Object

Alt N U Insert Symbol

Alt N H Insert Header & Footer

Alt N V Insert Pivot Table

Alt W V F Hide/Unhide Formula Bar

Alt W V H Hide/Unhide Heading

Alt W V G Hide/Unhide Gridlines

Alt W Q C Change Zoom

Alt W F F Freeze Panel

Alt W F I Page Break View

Alt W F C Custom View

Alt W F P Page Layout View

Alt W A Arrange Windows

Quick Tip: Make your fingers learn shortcut keys.

ExcelChamps ©



Data & Formulas

Key Description

Shift + F3 Insert Function

Alt M R Recently Used Functions

Alt M I Financial Functions

Alt M L Logical Functions

Alt M T Text Functions

Alt M E Date & Time Functions

Alt M O Lookup Functions

Alt M G Math & Trig Functions

Alt M Q More Functions

Alt + = Auto Sum

Alt M N Name Manager

Alt D F F Add Filters

Alt A V V Insert Data Validation

Alt A M Remove Duplicates

Alt A R A Refresh All

Alt A E Text to Column

Alt A G Group Rows & Columns

Alt A U Ungroup Rows & Columns

Alt A B Add Sub Total

Alt A S S Sort

Quick Tip: Try to locate shortcut keys by pressing alt key..
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Amazing
Excel Tips

30 useful tips for productivity



Watch Window

Use watch window to track important 

cells in your workbook.

You can add all those important cells in watch 

window to track them on real time. 

How to

1. Go to Formula Tab -> Watch Window -> Add

Watch.

2. Select the cell you want to add to watch window.

Once you add a cell into watch window it will 

show you following details.

1. Workbook name.

2. Worksheet name.

3. Cell name (If given).

4. Cell address.

5. Cell value.

6. Cell formula.

ExcelChamps ©
Related Tip: How To Use Watch Window

http://excelchamps.com/blog/2016/02/watch-window-in-excel/


Format Painter

Use format painter to copy formatting 

from one section of your worksheet to 

another.

How to

1. Select the cell or a range from where you want

to copy format.

2. Go to Home -> Clipboard -> Format Painter.

3. Once you click on the format painter, your

mouse pointer will change icon.

4. Now, you can select the cell or range on which

you want to paste that format.

When you click on format painter 

button it will simply copy a cell & when 

to select another cell it will apply 

formatting on it.
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Related Tip: How To Use Format Painter

http://excelchamps.com/blog/2016/02/how-to-use-format-painter-in-excel/


Fill Justify

The single core motive to use fill justify 

in excel is to merge the data from 

multiple cells into a single cell.

How to

1. First of all, make sure that the column in which

your text is captured is wide enough to store the

entire text into a single cell.

2. Now, select all the cell in which text is stored.

3. Go to Home Tab -> Editing Group -> Fill ->

Justify.

4. Now, your pre-selected data of multiple cells is

converted into a single cell.

If you have any other idea to merge text 

into one cell, leave it.

Using fill justify is a better option.
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Related Tip: How To Use Fill Justify

http://excelchamps.com/blog/2016/02/use-fill-justify-in-excel/


Sort Columns

Sorting columns in excel mean sorting 

data from left to right [horizontal 

direction].

How to

1. Select the data you want to sort.

2. Go to Data Tab → Sort & Filter → Click on Sort

Button. Now, you will get a pop-up window.

3. Click on options button → Select sort left to right

& click Ok.

4. Now select the row on the basis of which you

want to sort your data & click OK.

This is useful when you have to streamline 

your data columns or you want to arrange 

them in alphabetic order.
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Related Tip: How To Sort Columns in Excel

http://excelchamps.com/blog/2016/08/quickly-sort-columns-in-excel/


Undo Redo Buttons

You can use undo and redo buttons 

from quick access toolbar which has a 

list of activities you have done.

How to

1. Go to File Tab → Options → Quick Access Toolbar

→ Select UNDO & REDO command from “Choose

commands from”.

2. Add both the commands to your quick access

toolbar.

3. Click Ok.

And, you can undo or redo to a 

particular activity by using 

these buttons.
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Related Tip: How To Undo & Redo Buttons

http://excelchamps.com/blog/2016/09/use-undo-redo-button-for-corrections/


Flash Fill

It is like a copy cat, which can do the 

things in the same pattern in which you 

are doing.

How to

1. Go to Home Tab -> Editing -> Fill -> Flash Fill.

2. You can also add flash fill option to the quick

access toolbar for your convenience.

3. To activate automatic flash fill option. Go to File -

> Options -> Advance -> Editing Options -> Tick

Mark automatically flash fills.

You just have to do that 

operation once & Flash Fill do it 

for the rest.
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Related Tip: How To Use Flash Fill

http://excelchamps.com/blog/2016/01/how-to-use-flash-fill-in-excel/


Image In Cell Comment

This is a very useful feature of the cell 

comment. You can add images to 

describe the content of the cell.

How to

1. Open format comment option, go to color & lines

option.

2. Click on the color drop down menu & then click

on fill effects.

3. Select picture tab and click on select picture to

add the picture.
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Related Tip: 4 Quick Tips To Customize a Cell Comment

http://excelchamps.com/blog/2015/12/customize-cell-comment-in-excel/


Add Secondary Axis

You can add a secondary axis to your 

chart to show more than one data 

values.

How to

1. Select the data series for which you want to add

a secondary axis.

2. Right Click on it & Go to Format Data Series →

Series Option → Activate Secondary Axis.

3. Now, you have a two scales in your chart.
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Related Tip: How To Add Secondary Axis

http://excelchamps.com/blog/2016/02/add-secondary-axis-in-excel-chart/


Excel Camera Tool

Like a normal camera, this camera

captures the picture of cell range.

How to

1. From your quick access toolbar, click on the

down arrow.

2. You’ll get a drop-down menu. Click on more

commands.

3. Now, In excel options select all commands from

“Choose Commands From”.

4. Select Camera from the list & add it to the quick

access toolbar. Click OK.

Excel Camera Tool help you to copy

a range & create a Live Picture of that

range. You can paste that range anywhere

in your worksheet.

ExcelChamps ©

Related Tip: How To Use Excel Camera Tool 

http://excelchamps.com/blog/2016/06/use-excel-camera-tool/


In-Built Data Entry Form

Microsoft Excel is loaded with a built-in

data entry form.

How to

1. Select Your Data & Press Alt + D + O

You can use this form to

enter your data into worksheet very easily.

Before you use this entry form, the first

thing you have to do is to activate this form
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Related Tip: How To Use Default Data Entry Form

http://excelchamps.com/blog/2015/12/excel-data-entry-form/


Print Titles

You can use “Print Title” option to 

print some specific data at the top

of each page you print.

How to

1. Go to -> Page Layout -> Sheet ->

2. Add Print Area in print area input box which you 

want print.

3. In Rows To Repeat At Top add the row area 

which you want to print at top of every page.

4. In Columns To Repeat At Left add the column 

area which you want to print at left of every 

page

5. Click Ok.

You can select a range of cells for 

this to print.
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Create a Cell Message

You can create a cell message for some 

specific cells.

How to

1. Go to Data tab -> Data Tools.

2. In Data Validation

3. Click input message

4. Enter Title & Message

5. Click OK

Whenever user select those cell, it will pop-up 

a message which you have specified.
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Multiply With Paste Special

You can use paste special operators to 

perform some one-time calculations 

[Add, Subtract, Multiply, Divide]

How to

1. Select the cell in which you have your %age 

of increment(I have used 1.2 for increasing 

the tariff by 20%) & copy it.

2. Now, select the entire range on which you 

want to apply the calculation.

3. Use shortcut key [Alt + E + S] to get the 

paste special dialog box.

4. Go to Operation, select the “multiply” 

option, click okay.

For example, You have a data table with call 

tariff rates from India to other countries.

Due to some hike in costing you have to 

increase your tariff rates by 20%. You can 

use  here paste special operations to 

multiply.
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Related Tip: Multiply With Paste Special

http://excelchamps.com/blog/2016/02/multiply-in-excel-using-paste-special/


Change Display Units

How to

1. Select chart axis your chart & open format 

“Format Axis” options.

2. In axis options, go to “Display Units” where 

you can select unit for your axis values.

If you are dealing with the large 

number in your excel chart, you 

can change the units for your 

axis values.
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Hide Empty Gap in Chart

How to

1. Right, click on your chart & select “Select 

Data”.

2. In select data window, click on “Hidden and 

Empty Cell”.

3. Select your desired option from “Show 

Empty Cell as”.

Let’s say if you have a chart with 

monthly sales in which Jun has 

no amount & cell is empty.

You can use following options for that empty 

cell.

1. Show gap for the empty cell.

2. Use zero.

3. Connect data points with the line.
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Insert Picture in Chart

How to

1. Select data bar in your chart.

2. Go to Fill & Line. In “Fill” option, select picture 

& texture fill.

3. In “Insert Picture From” click on file to select 

an image.

4. Select “Stack” after that.

It has a limited use but it’s pretty 

cool to use an image in your 

chart.
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Copy Chart Formatting

How to

1. Right-click on the chart from which you want 

to copy the chart formatting.

2. Click on the copy.

3. Right-click on the other chart on which you 

want to apply/paste the formatting.

4. Go to Home tab -> Clipboard -> Paste -> 

Paste Special.

5. Now, you have a pop-up window. Select 

formats.

6. Click OK

Let’s say, with your extreme efforts, you have 

formatted a chart. And, you realize that you 

have more charts to format.

It’s a pain. But, I have a super quick solution.
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Related Tip: How To Copy Chart Formatting

http://excelchamps.com/blog/2016/08/copy-chart-formatting-to-another-excel-chart/


Auto Format Option

How to

1. Go to File → Options → Quick Access Toolbar →

Select AutoFormat from the list.

2. Add to the Quick access toolbar.

3. Select your data.

4. Click on the auto format button in quick access 

toolbar.

5. Select the format you want.

6. Click OK.

AutoFormat is a very handy & powerful 

tool to apply some quick formats to 

your data.

You just have to select a format to apply & 

Excel will apply a pre-designed format to your 

data.
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Related Tip: How To Use Auto Format

http://excelchamps.com/blog/2016/02/use-auto-format-feature-in-excel/


Smooth Lines In Line Chart

How to

1. Select data line in your chart & right click on it.

2. Select “Format Data Series”.

3. Go To Fill & Line -> Line -> Tick “Smoothed 

Line”.

If you love to use line chart then you are 

awesome but it would be more awesome if you 

use a smooth line in the chart.

This will give a smart look to your chart.
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Show Data for Hidden Cells

How to

1. Select your chart & right click on it.

2. Go to -> Select Data -> Hidden and empty 

cells.

3. From the pop-up window, tick mark “Show 

data in hidden rows & columns”.

When you hide a cell from the data 

range of your chart, it will also hide 

from the chart as well.

And, if you want not to hide data values from 

your chart even a cell is hidden, just follow 

these steps.
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Highlight Duplicates

How to

1. Select the data -> Go to Home Tab.

2. In Styles -> Click Conditional Formatting.

3. In Highlight Cell Rules -> Select Highlight 

Duplicate Values.

Easiest way to highlight duplicate values is by 

using Conditional Formatting.
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Change Local File Location

How to

1. Go to File -> Options-> Save -> Default Local 

File Location. 

2. Enter new path you want to set as default.

3. Click OK.

Want to open same location every time 

when you save your file?  

ExcelChamps ©



Highlight Top / Bottom 10

How to

1. Select your data. 

2. Go to Home -> Style -> Conditional Formatting 

-> Top/Bottom Rules.

3. Select the option you want to apply.

You can use conditional formatting to 

highlight top 10 or bottom 10 values.
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Freeze Panel 23

How to

1. Go to View Tab -> Windows -> Freeze Panel. 

2. You have three option to freeze.

1. One is to free first column of the 

worksheet. 

2. Second is to freeze first row.

3. Third is to freeze rows & columns bases on 

the current selection.

Working with large data sets?

Then it’s must to freeze headings.
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Add a Hyperlink

How to

1. Select the cell on which you want to add the 

hyperlink.

2. Right click & select Add Hyperlink. Now, you 

get a pop-up window.

3. Add the address of the location into address 

bar & you can also add ScreenTip to show a 

message on mouse hover.

4. Click OK.

Using a hyperlink you can link a cell with a 

specific webpage, file or a place in your 

workbook.  
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Group Dates In Pivot Table

How to

1. Select any of the cells which has a date in it.

2. Right click on it & select group.

3. You will get a pop-up window to group dates.

4. Select “Month” in the group by option.

5. Click OK.

Grouping dates in pivot table will allow you to 

combine dates in the form of months, 

quarters, years. 

And, the best part of this option is you 

don’t have to put those extra columns in 

your source data.
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Related Tip: How To Group Dates In Pivot Table

http://excelchamps.com/blog/2016/06/how-to-group-dates-in-pivot-table/


Goal Seek

How to

1. Go to Data Tab → What If Analysis → Goal 

Seek.

2. Use shortcuts key Alt + T + G.

3. Set Cell – Cell in which you want the desired 

result.

4. To Value – Value you want as a result.

5. By Changing Cell – Cell in which you want 

alteration to come up with the result equals to 

the “To Value”.

By using goal seek you can find a 

possible input or value to get the 

desired result.

In simple words, If you know what actual 

result value you want, you can use goal seek to 

find the best input value for getting it.
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Related Tip: How To Use Goal Seek

http://excelchamps.com/blog/2015/11/goal-seek-in-excel-how-to/


Delete Blank Cells

How to

1. Press CTRL+G to open the Go To Dialog Box

2. Go to > Special > Blanks.

3. Select cells, rows or columns.

4. Click OK.

If you have blank cells in your data & 

you want to delete them you can 

It by using go to special option.
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Text To Speech

How to

1. Click on File -> Options -> Customize Ribbon.

2. Select "Main Tab"  from the drop-down option.

3. Now, Select the home tab, add a new group.

4. Rename the new group with "Speech". And, 

Choose 'Commands Not In Ribbon" from 

"Chose Commands From" option.

5. Now, Select all 5 commands starting with 

"Speak" & add them to the new group. Click 

OK.

6. Now, You have a new group with 5 options in 

your home tab.

Text-To-Speech In Excel is an 

option allows you to make 

excel speak what you have 

typed in your spreadsheet.
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Related Tip: How To Use Text To Speech

http://excelchamps.com/blog/2015/11/text-to-speech-in-excel/


Speed-O-Meter

How to

1. Go to Insert -> Store -> Search for Gauge 

Chart & Install it.

2. It will give you a cool gauge chart which looks 

like a speed-o-meter.

Microsoft has introduced a nice app feature 

in excel 2013. You can download lots of useful 

charts from the app store. 
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Fortunately, we also have 

a Speed-O-Meter on app 

store & it’s free. So, before 

using it, you have to 

download it in your excel 

application. 

Related Tip: How To Create Gauge Chart

http://excelchamps.com/blog/2015/12/gauge-chart-in-excel/


Other Bonus Stuff
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Free Templates

• Excel Expense Tracking Template

• Daily Sales Report Template

• Excel Gantt Chart Template

• Excel Inventory Management Template

101 Excel Functions With Examples & 

Downloadable Samples Files

http://excelchamps.com/blog/2016/10/one-page-excel-expense-tracking-template/
http://excelchamps.com/blog/2016/09/daily-sales-report-template/
http://excelchamps.com/blog/2016/09/excel-gantt-chart-template-project-managers/
http://excelchamps.com/blog/2016/08/excel-inventory-management-template-user-forms-vba/
http://excelchamps.com/blog/excel-functions/


20 Ready 
To Use 

VBA Codes



1. Create a Backup of a Current Workbook

Sub FileBackUp()

ThisWorkbook.SaveCopyAs Filename:=ThisWorkbook.Path & _

"\" & Format(Date, "mm-dd-yy") & " " & _

ThisWorkbook.name

End Sub

2. Close All Workbooks at Once
Sub CloseAllWorkbooks()

Dim wbs As Workbook

For Each wbs In Workbooks

wbs.Close SaveChanges:=True

Next wb

End Sub

3. Hide All but the Active Worksheet

Sub HideWorksheet()

Dim ws As Worksheet

For Each ws In ThisWorkbook.Worksheets

If ws.Name <> ThisWorkbook.ActiveSheet.Name Then

ws.Visible = xlSheetHidden

End If

Next ws

End Sub

4. Unhide All Hidden Worksheets

Sub UnhideAllWorksheet()

Dim ws As Worksheet

For Each ws In ActiveWorkbook.Worksheets

ws.Visible = xlSheetVisible

Next ws

End Sub

5. Delete All but the Active Worksheet

Sub DeleteWorksheets()

Dim ws As Worksheet

For Each ws In ThisWorkbook.Worksheets

If ws.name <> ThisWorkbook.ActiveSheet.name Then

Application.DisplayAlerts = False

ws.Delete

Application.DisplayAlerts = True

End If

Next ws

End Sub



6. Copy Active Worksheet Into a New Workbook

Sub CopyWorksheetToNewWorkbook()

ThisWorkbook.ActiveSheet.Copy _

Before:=Workbooks.Add.Worksheets(1)

End Sub

7. Protect All Worksheet Instantly

Sub ProtecAllWorskeets()

Dim ws As Worksheet

Dim ps As String

ps = InputBox("Enter a Password.", vbOKCancel)

For Each ws In ActiveWorkbook.Worksheets

ws.Protect Password:=ps

Next ws

End Sub

8. Convert All Formulas Into Values

Sub ConvertToValues()

Dim MyRange As Range

Dim MyCell As Range

Select Case MsgBox("You Can't Undo This Action. " & "Save 

Workbook First?", vbYesNoCancel, "Alert")

Case Is = vbYes

ThisWorkbook.Save

Case Is = vbCancel

Exit Sub

End Select

Set MyRange = Selection

For Each MyCell In MyRange

If MyCell.HasFormula Then

MyCell.Formula = MyCell.Value

End If

Next MyCell

End Sub



9. Remove Spaces from Selected Cells

Sub RemoveSpaces()

Dim myRange As Range

Dim myCell As Range

Select Case MsgBox("You Can't Undo This Action. " & "Save 

Workbook First?", _

vbYesNoCancel, "Alert")

Case Is = vbYes

ThisWorkbook.Save

Case Is = vbCancel

Exit Sub

End Select

Set myRange = Selection

For Each myCell In myRange

If Not IsEmpty(myCell) Then

myCell = Trim(myCell)

End If

Next myCell

End Sub

10. Highlight Duplicates from Selection Spaces 
from Selected Cells

Sub HighlightDuplicateValues()

Dim myRange As Range

Dim myCell As Range

Set myRange = Selection

For Each myCell In myRange

If WorksheetFunction.CountIf(myRange, myCell.Value) > 1 

Then

myCell.Interior.ColorIndex = 36

End If

Next myCell

End Sub



11. Hide All Pivot Table Subtotals

Sub HideSubtotals()

Dim pt As PivotTable

Dim pf As PivotField

On Error Resume Next

Set pt = 

ActiveSheet.PivotTables(ActiveCell.PivotTable.name)

If pt Is Nothing Then

MsgBox "You must place your cursor inside of a PivotTable."

Exit Sub

End If

For Each pf In pt.PivotFields

pf.Subtotals(1) = True

pf.Subtotals(1) = False

Next pf

End Sub

12. Refresh All Pivot Tables

Sub RefreshAllPivotTables()

Dim ws As Worksheet

Dim pt As PivotTable

For Each ws In ThisWorkbook.Worksheets

For Each pt In ws.PivotTables

pt.RefreshTable

Next pt

Next ws

End Sub

13. Resize All Charts in a Worksheet

Sub Resize_Charts()

Dim i As Integer

For i = 1 To ActiveSheet.ChartObjects.Count

With ActiveSheet.ChartObjects(i)

.Width = 300

.Height = 200

End With

Next i

End Sub



14. Highlight the Active Row and Column

Private Sub Worksheet_BeforeDoubleClick(ByVal Target As 

Range, Cancel As Boolean)

Dim strRange As String

strRange = Target.Cells.Address & "," & _

Target.Cells.EntireColumn.Address & "," & _

Target.Cells.EntireRow.Address

Range(strRange).Select

End Sub

15. Save selected range as a PDF

Sub SaveAsPDF()

Selection.ExportAsFixedFormat Type:=xlTypePDF, 

OpenAfterPublish:=True

End Sub

16. Create a Table of Content

Sub TableofContent()

Dim i As Long

On Error Resume Next

Application.DisplayAlerts = False

Worksheets("Table of Content").Delete

Application.DisplayAlerts = True

On Error GoTo 0

ThisWorkbook.Sheets.Add Before:=ThisWorkbook.Worksheets(1)

ActiveSheet.Name = "Table of Content"

For i = 1 To Sheets.Count

With ActiveSheet

.Hyperlinks.Add _

Anchor:=ActiveSheet.Cells(i, 1), _

Address:="", _

SubAddress:="'" & Sheets(i).Name & "'!A1", _

ScreenTip:=Sheets(i).Name, _

TextToDisplay:=Sheets(i).Name

End With

Next i

End Sub



18. Active Workbook in an Email

Sub Send_Mail()

Dim OutApp As Object

Dim OutMail As Object

Set OutApp = CreateObject("Outlook.Application")

Set OutMail = OutApp.CreateItem(0)

With OutMail

.to = "Sales@FrontLinePaper.com"

.Subject = "Growth Report"

.Body = "Hello Team, Please find attached Growth Report."

.Attachments.Add ActiveWorkbook.FullName

.display

End With

Set OutMail = Nothing

Set OutApp = Nothing

End Sub

19. Insert a Linked Picture

Sub TopTen()

Selection.FormatConditions.AddTop10

Selection.FormatConditions(Selection.FormatConditions.Count

).SetFirstPriority

With SelectionWithFormatConditions(1)

.TopBottom = xlTop10Top

.Rank = 10

.Percent = False

End With

With Selection.FormatConditions(1).Font

.Color = -16752384

.TintAndShade = 0

End With

With Selection.FormatConditions(1).Interior

.PatternColorIndex = xlAutomatic

.Color = 13561798

.TintAndShade = 0

End With

Selection.FormatConditions(1).StopIfTrue = False

End Sub

20. Highlight Top 10 Values

Sub LinkedPicture()

Selection.Copy

ActiveSheet.Pictures.Paste(Link:=True).Select

End Sub



Books You Can Try
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http://amzn.to/292vyTx
http://amzn.to/28W5swi
http://amzn.to/29bTl3E
http://amzn.to/29bTkwD
http://amzn.to/29bTgNq
http://amzn.to/29bT54N
http://amzn.to/29bT4Ol
http://amzn.to/29bTzaZ
http://amzn.to/29bTm7E
http://amzn.to/29bT2WC
http://amzn.to/28W4TCC
http://amzn.to/29bTcNv
http://amzn.to/28W5qo6
http://amzn.to/28W5x3h
http://amzn.to/29bSpMv
http://amzn.to/29bT1Ss


Excel Courses
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Course Tutor

Excel Power Query Course Mynda Treacy

Excel for Decision Making Dr. Isaac Gottlieb

Power Pivot Course Mynda Treacy

Excel Dashboard Course Mynda Treacy

Xtreme Pivot Table Course John Michaloudis

Excel Course For Accountants Jeff Lenning

Excel Dashboard Course Sumit Bansal

Excel VBA Jetpack Course Sumit Bansal
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